View Issue Details

IDProjectCategoryView StatusLast Update
0000971ScribusUser Interfacepublic2004-09-28 23:35
Reporterlouisdesjardins Assigned Tocbradney  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSMandrakeOS Version10
Product Version1.2CVS 
Target VersionFixed in Version 
Summary0000971: Improvement in the Hyphenation Settings menus
DescriptionThe “Fully Automatic“ option in the Hyphenator Settings dialog could describe more precisely the way Scribus works. Here is how it works : User can tell the program to make or not suggestions for each possible hyphen for all the words in a given text box, according to the value set in the “smallest word“ box. This will only happen when the user will also make use of the Extra>Hyphenate Text menu.
So here is what I suggest (and I have done the same in the French translation):
DIALOG MENU: "Hyphenation suggestion" instead of “Fully Automatic“.
TOOLTIP: "A dialog box showing all possible hyphens for each word will show up when you use the “Extra>Hyphenate Text“ option.

Also, the "Check During Typing" option could also be more self-explanatory. What the program actually does is not just “checking“ (unless my knowledge of English could be in cause!). It instantaneously hyphenates (when it needs to) during typing. Users don't even have to go to the “Extra>Hyphenate Text“ menu to get their text hyphenated and they cannot make a decision because no dialog will appear when that option is checked. Thus, I suggest this (same was proposed for French):
DIALOG MENU “Hyphenate Text Automatically During Typing“ instead of “Check During Typing"
TOOLTIP: “Enables automatic hyphenation of your text while typing“ instead of "Enables automatic checking of your text while typing."

Also, I would suggest that
"Number of Hyphenations allowed:" become “Consecutive Hyphens“ or Number of Consecutive Hyphens allowed“ because I don't think “Number of Hyphenations allowed“ is what's really meant here. ;-)
TagsNo tags attached.
Patch

Relationships

child of 0003828 acknowledged Metabug: Hyphenation 

Activities

louisdesjardins

2004-08-15 12:09

developer   ~0002171

I forgot to say that my suggestion about “Fully Automatic“ being changed to “Hyphenation Suggestions“ implies a small change also in the behaviour of the check box itself as the option should be “On“ when checked and “Off“ when not, as opposed to what it is right now.

Otherwise, we would have to keep the beginning of the string “If you uncheck this...“ in the Tooltip... which I am not so pleased with: I'd rather tell what an option does when it's “on“ than what it does when it's “off“!

One last thing: if this receives approbation, please add an “s“ to “Suggestions“. Thanks!

cbradney

2004-09-28 23:35

administrator   ~0002567

Tested. Fixed.

Issue History

Date Modified Username Field Change
2004-08-14 21:36 louisdesjardins New Issue
2004-08-15 12:09 louisdesjardins Note Added: 0002171
2004-09-22 23:29 cbradney Status new => assigned
2004-09-22 23:29 cbradney Assigned To => cbradney
2004-09-24 22:00 fschmid Status assigned => resolved
2004-09-24 22:00 fschmid Resolution open => fixed
2004-09-28 23:35 cbradney Status resolved => closed
2004-09-28 23:35 cbradney Note Added: 0002567
2006-05-16 22:20 christoph_s Relationship added child of 0003828