View Issue Details

IDProjectCategoryView StatusLast Update
0009911ScribusFontspublic2016-12-08 21:41
Reportertimpul Assigned ToFahad  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPentium Dual-CoreOSMandriva LinuxOS Version2010.1 (32bit)
Product Version1.4.0svn 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0009911: RL text direction no work
DescriptionScribus originally is a DTP editor. I think it has to have ability to type glyphs from all the Unicode table. After compile the latest version (I don't know if older version has the same problem, because I haven't tried yet.) Scribus cannot show these glyphs on the pages and ‘glyph insert window’. Only text editor window can show these problematic glyphs. It was an imported text.
Steps To ReproduceThese glyphs are out of standard (U+0000 to U+FFFF) range of Unicode Standard: U+10000 to U+1FFFF.
The standard glyphs can be chosen from glyph inserting box.
I know these glyphs are old style and no human uses them in their publications.
Additional InformationThe problem font has a right-to-left and Phoenician section.
Check this font: http://opendesktop.org/content/show.php/?content=138689
I'm trying to create a very standardized font so I downloaded the latest Unicode Standard 6.0 version from the net.
See enclosed screenshot how I see it in Scribus.
Tags#please_test, fixed, HOST-Oman, RTL, scribusctl
Patch

Relationships

child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

timpul

2011-04-07 18:01

reporter  

scribustextproblem.jpg (137,548 bytes)
scribustextproblem.jpg (137,548 bytes)

timpul

2011-04-07 18:02

reporter   ~0026021

Last edited: 2011-04-07 18:14

View 2 revisions

Scribus 1.4.0 rc3 it was. I'm afraid the problem is the following.
Let's see one glyph: U+10900. This is the Phoenitian capital A. Scribus sees this glyphs U+0900. The font doesn't contain any glyph at this point. (Because this is the Devangari section.) Huuh!

timpul

2011-04-07 18:15

reporter  

scribusnoglyphs.jpg (41,342 bytes)
scribusnoglyphs.jpg (41,342 bytes)

plinnell

2011-04-08 08:03

viewer   ~0026026

We have a new branch called OIF, which has new code for handling RTL and glyph combining for Arabic, Hindi etc. It is alpha code and not complete, but this will handle what you are looking for.

Kunda

2014-06-03 09:41

manager   ~0031974

Does this bug meet the criteria to be linked to the RTL Metabug list ?

Kunda

2014-07-09 15:53

manager   ~0032628

Added to RTL metabug

Kunda

2016-03-26 13:50

manager   ~0039445

According to HOST-Oman team, these issues are fixed in the new CTL branch!
See https://github.com/HOST-Oman/scribus/issues/75#issue-142809558
There will be a build provided soon to test this fix OR one can build their branch manually.

user5122

2016-05-06 12:21

  ~0040827

The main problem here is that Scribus does not support text outside Unicode basic multilingual plane, and this is already fixed in the CTL branch.

Issue History

Date Modified Username Field Change
2011-04-07 18:01 timpul New Issue
2011-04-07 18:01 timpul File Added: scribustextproblem.jpg
2011-04-07 18:02 timpul Note Added: 0026021
2011-04-07 18:14 timpul Note Edited: 0026021 View Revisions
2011-04-07 18:15 timpul File Added: scribusnoglyphs.jpg
2011-04-08 08:03 plinnell Note Added: 0026026
2014-06-03 09:41 Kunda Note Added: 0031974
2014-07-09 15:52 Kunda Relationship added child of 0003965
2014-07-09 15:53 Kunda Note Added: 0032628
2014-07-09 15:53 Kunda Status new => confirmed
2016-03-26 13:42 Kunda Tag Attached: RTL
2016-03-26 13:50 Kunda Note Added: 0039445
2016-03-26 13:50 Kunda Tag Attached: #please_test
2016-03-26 13:50 Kunda Tag Attached: fixed
2016-03-26 13:50 Kunda Tag Attached: HOST-Oman
2016-05-06 12:21 user5122 Note Added: 0040827
2016-12-05 20:17 Kunda Tag Attached: scribusctl
2016-12-05 20:17 cbradney Assigned To => Fahad
2016-12-05 20:17 cbradney Status confirmed => resolved
2016-12-05 20:17 cbradney Resolution open => fixed
2016-12-05 20:17 cbradney Fixed in Version => 1.5.3.svn
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:41 cbradney Target Version => 1.5.3