View Issue Details

IDProjectCategoryView StatusLast Update
0010182ScribusGeneralpublic2016-12-08 21:41
ReporterAlexander Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSKUBUNTUOS Version11.04
Product Version1.4.0svn 
Target Version1.5.3Fixed in Version 
Summary0010182: Wrong update of properties information at window which opens with <F2>
DescriptionAfter several (more or less) modifications of properties of different object types (image, text) with <f2> properties window it stops actually writes new property information to document. It's looks alright at the screen (image could change it's ratio as you wish), but if you change mode of view or save and open once more document you will see that modification is lost.

Additional Information1.4.0.rc4 & 1.4.0.rc5 with Russian interface
Tags#please_test, #tobeclosed, duplicate-of ID missing
PatchNo

Relationships

related to 0007059 closed Sometimes the property dialog doesn't show the right font propterties of a text frame 

Activities

ale

2011-08-16 06:41

manager   ~0026723

hi, you should give a specific example... and steps to reproduce :-)

jghali

2011-08-21 22:18

administrator   ~0026763

Please provide sample and steps to reproduce, otherwise the bug will be closed as we are unable to reproduce the issue.

Alexander

2011-08-22 20:07

reporter  

logo_test.sla (184,074 bytes)

Alexander

2011-08-22 20:26

reporter   ~0026771

Last edited: 2015-06-27 22:36

View 2 revisions

if you add several images (in my case - jpg 450x470 ~ 100 Kb) to provided file (logo_test.sla) at several image boxes and will start resize images, edit text, resize text than at some point sooner or later property window will not respond adequately.

Switching between activities is necessary. Manually resize image, change text, next image, next text ...Several times may be 10, 20, but not more than 30.
If you use only one type of operations (image resizing) than everything is okay.
I couldn't say do it 3 times and you see it, but in my case this effect is very stable.

chirlu

2014-03-06 02:19

reporter   ~0031464

I’ve seen this several times while working on a document (with 1.4.3.svn, on Debian), but unfortunately I can’t give exact steps to reproduce it either. Image frames seem to be a necessary ingredient to this problem.

It appears that the Properties windows under certain conditions becomes “detached” from the selected object. In this state, when a different object is selected, Properties still displays the data of the old object (including the ID), and changes made in the Properties window aren’t propagated to either object.

Closing and reopening the Properties window or the document do not help; it is necessary to restart Scribus to make this work again after the problem has surfaced.

Kunda

2014-07-13 02:00

updater   ~0032710

chirlu, can you confirm that this happens in the Russian UI as well ?

chirlu

2014-07-13 20:06

reporter   ~0032726

I was using Scribus in German. It would be difficult to test the Russian UI because I don’t read Russian, it’d have to try and guess the meaning of the various buttons/menu items/… by their position.

Kunda

2016-04-04 01:29

updater   ~0039745

I can't reproduce on 1.5.2svn r21159
OP please retest with latest 1.4.6 and 1.5.2svn

Kunda

2016-04-04 01:32

updater   ~0039746

alexandre, can you test this with russian interface ?
Thanks!

Kunda

2016-12-05 18:35

updater   ~0042682

resolving

Issue History

Date Modified Username Field Change
2011-08-15 19:32 Alexander New Issue
2011-08-16 06:41 ale Note Added: 0026723
2011-08-21 22:18 jghali Note Added: 0026763
2011-08-22 20:07 Alexander File Added: logo_test.sla
2011-08-22 20:26 Alexander Note Added: 0026771
2014-03-06 02:19 chirlu Note Added: 0031464
2014-07-13 02:00 Kunda Note Added: 0032710
2014-07-13 02:00 Kunda Status new => feedback
2014-07-13 20:06 chirlu Note Added: 0032726
2015-05-25 03:44 Kunda Patch => No
2015-05-25 03:44 Kunda Target Version => 1.6 milestone
2015-05-25 04:45 Kunda Relationship added related to 0007059
2015-06-27 22:36 Kunda Note Edited: 0026771 View Revisions
2015-06-27 22:37 Kunda Tag Attached: duplicate-of ID missing
2016-04-04 01:29 Kunda Note Added: 0039745
2016-04-04 01:29 Kunda Tag Attached: #tobeclosed
2016-04-04 01:30 Kunda Tag Attached: #please_test
2016-04-04 01:32 Kunda Note Added: 0039746
2016-12-05 18:35 Kunda Status feedback => resolved
2016-12-05 18:35 Kunda Resolution open => fixed
2016-12-05 18:35 Kunda Note Added: 0042682
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:41 cbradney Target Version 1.6 milestone => 1.5.3