View Issue Details

IDProjectCategoryView StatusLast Update
0007059ScribusStory Editor / Text Framespublic2016-05-15 22:53
ReporteraliB Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionunable to reproduce 
PlatformDell Inspiron 9400OSSuSEOS Version10.3
Product Version 
Target VersionFixed in Version 
Summary0007059: Sometimes the property dialog doesn't show the right font propterties of a text frame
DescriptionProperty dialog just doesn't remember the used font properties for a text frame and shows always the default font.
But the text frame still uses the right font properties (font, font-size, line spacing etc. pp).
Steps To Reproduce1 Create a new text frame change some font settings.
2 select an other text frame
3 select the first text frame an check the font settings

Sometimes you have to save an reopen the document to reproduce this behavior.
Additional InformationIt seems, it happens more often with pasted text / text-frames
Tags#please_test, #tobeclosed, duplicate-of ID missing
Patch

Relationships

related to 0009173 assignedavox un-wanted font style persistent even after changing for entire frame/selection/text 
related to 0012096 closedfschmid Broken font height setting 
has duplicate 0010525 closedjghali Selected Text's properties do not accurately reflect in Properties window 
related to 0010182 closed Wrong update of properties information at window which opens with <F2> 
related to 0013935 closedjghali Changing font in PP doesn't take affect 
related to 0013501 confirmed impossible to set the character formatting at the end of the frame 
related to 0008725 confirmed Font settings for text frames in the Document Setup are ignored 

Activities

aliB

2008-05-28 09:05

reporter   ~0019756

Forgot to mention:
Scribus 1.3.5 newest svn

jghali

2008-05-28 13:42

administrator   ~0019758

Since 1.3.4 font is not a property of the text frame anymore. Applying a font to a frame will just apply it to the underlying text. Paragraph/character style at frame level will be implemented later, correctly this time, not like in 133x.

jghali

2008-05-28 13:43

administrator   ~0019760

And btw, no need to add yourself to the monitor list. That is done implicitly and automatically for the issue reporter.

daspostloch

2011-05-29 12:20

reporter   ~0026281

Last edited: 2015-06-27 22:38

View 2 revisions

bump / info: still present for scribus 1.5.0.svn C-C-T-F-C1.10.2-64bit

this is really annoying and i would like to see an upgrade of the severity. in combination with things like e.g. 0009812 and 0009173, text box editing becomes pretty tough business.

thanks for the great program though.

Kunda

2016-04-02 17:07

updater   ~0039718

I can't reproduce this on OSX 10.10.5 1.5.2svn r21154 Qt5.6

Kunda

2016-04-02 17:08

updater   ~0039719

please test this ticket

PeterBenedek

2016-04-02 19:23

developer   ~0039724

I can't reproduce this on LinuxMint17.3 1.5.2svn r21141 Qt5.6RC

Issue History

Date Modified Username Field Change
2008-05-28 09:04 aliB New Issue
2008-05-28 09:05 aliB Note Added: 0019756
2008-05-28 13:42 jghali Note Added: 0019758
2008-05-28 13:43 jghali Note Added: 0019760
2011-05-29 12:20 daspostloch Note Added: 0026281
2012-02-19 17:24 jghali Relationship added has duplicate 0010525
2015-05-25 04:45 Kunda Relationship added related to 0010182
2015-06-27 22:37 Kunda Tag Attached: duplicate-of ID missing
2015-06-27 22:38 Kunda Note Edited: 0026281 View Revisions
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2016-04-02 17:06 Kunda Relationship added related to 0009812
2016-04-02 17:06 Kunda Relationship added related to 0009173
2016-04-02 17:07 Kunda Note Added: 0039718
2016-04-02 17:08 Kunda Note Added: 0039719
2016-04-02 17:08 Kunda Tag Attached: #please_test
2016-04-02 17:08 Kunda Tag Attached: #tobeclosed
2016-04-02 19:23 PeterBenedek Note Added: 0039724
2016-04-02 20:33 Kunda Status new => resolved
2016-04-02 20:33 Kunda Resolution open => unable to reproduce
2016-04-02 20:33 Kunda Assigned To => Kunda
2016-04-02 20:33 Kunda Assigned To Kunda =>
2016-04-09 06:28 Kunda Relationship added related to 0013935
2016-04-09 12:59 Kunda Relationship added related to 0013501
2016-04-09 13:10 Kunda Relationship added related to 0012096
2016-04-14 15:55 Kunda Relationship added related to 0008725
2016-04-14 21:09 JLuc Relationship deleted related to 0009812
2016-05-15 22:53 cbradney Status resolved => closed