View Issue Details

IDProjectCategoryView StatusLast Update
0001030ScribusGeneralpublic2008-01-26 13:14
Reporterakvadrako Assigned ToHerm  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.3 
Target VersionFixed in Version1.3.5svn 
Summary0001030: [RFE] Add support for Math
DescriptionScribus would be much more useful if it had support for math. Ideally, something as easy to use as with LaTex. I would like pretty printing, like self-sizing parenthesis and integral signs and fractions. And entering the math should be down with control or alt-key sequences, like alt-m-f to start a new fraction.
TagsNo tags attached.
Patch

Relationships

related to 0003698 closedHerm Latex import 
child of 0003896 acknowledged Metabug: Scientific Publishing 

Activities

plinnell

2005-05-31 04:51

viewer   ~0004844

bumping to 1.3

scls19fr

2005-10-08 07:43

reporter   ~0006957

Hello,

I would like to be informed when this feature will be add to Scribus.
Because it is a very important feature for me.

About the key sequence, I think the shortcut ALT-$ or CTRL-$ could be a good idea because $ is used for inserting math equations with LaTeX.

LyX use CTRL-m shortcurt.

I want to say that equation should be of 2 types :

On line equation (CTRL-m with LyX or $...$ with LateX)

Out of line equation (SHIFT-CTRL-M with LyX or $$...$$ with LaTeX)

The \displaystyle command should be emulated too.


Regards

plinnell

2005-10-08 10:44

viewer   ~0006958

I have added a workaround to import formulas via OO into Scribus here: h t tp://docs.scribus.net/index.php?lang=en&page=importhints3

Imperfect, I realize, but it does work reliably in my experience.

scls19fr

2005-10-08 11:17

reporter   ~0006961

yes but the OOo Equation syntax is different from LaTeX syntax

Moreover I guess that equations imported like this can't be edit from Scribus (because it is in fact an EPS file, not a file with an equation content (MathML, LaTeX, OOo Equation, etc...)

ringerc

2005-10-09 06:01

reporter   ~0006979

I still like the idea of a PageItem that lets you edit the TeX source of an equation and remembers it, but draws its self by rendering the TeX source to DVI or PostScript and doing a vector import.

This would require the new PageItem structure to be done sanely, since PageItems would need to be able to contain other items (like vectors).

scribus4formula

2006-02-23 12:36

reporter   ~0008872

I am very interested in including LaTex-formulas in Scribus. Expecially for scientific poster this would be an ideal option

user715

2006-03-16 12:17

  ~0009337

how about mathml? scribus doc's format is based on xml, so maybe it is possible to implement mathml? or make possible to use oo math editor in scribus (using something like ole in windows or the one implemented in oo)?

scls19fr

2006-03-16 17:28

reporter   ~0009347

MathML is usefull for computer (XML based...) but it is not very easy to type MathML syntax for a human...

LaTeX syntax for math is much more human readable !!!

user715

2006-03-17 07:50

  ~0009353

editor (like oo math editor or ms equation) is necessary of course. btw - oo editor is enabled to export equation as mathml

scls19fr

2006-06-07 19:45

reporter   ~0011596

An other way could be to use an independant Math Editor (using a LaTeX syntax) that can export (or drag and drop) a PDF file into a Scribus document.

The PDF file inserted in the scribus should be able to be edited again using the math editor (for example, the formula could be written in the description field of the PDF file)

That way is used for example on Mac OS X (with PDF Equation and/or LateXit)

http://www.apple.com/downloads/macosx/math_science/latexit.html
http://ktd.club.fr/programmation/latexit_en.php


http://www.apple.com/downloads/macosx/math_science/pdfequation.html
http://metaquark.de/en/software/pdf_equation/

user715

2006-06-20 07:06

  ~0011668

the best way is native scribus' equation editor...
other idea is implementing something like windows' ole - it allow to insert object (in graphical but edited form) of any kind, not math only, but for example chemical structures from chemtex (i don't know if the name is written right)

christoph_s

2007-08-24 01:00

administrator   ~0017146

Now that Herm's Summer of Code project is finished, I think we should close the issue as resolved. The tool will probably see some improvements, but it works.

cbradney

2007-08-24 21:42

administrator   ~0017153

Base "/tmp/scribus_temp_latex_S16672"
Full command "pdflatex /tmp/scribus_temp_latex_S16672"
LATEX: latex finished with exit code: 0
LATEX: loading image file: /tmp/scribus_temp_latex_S16672.pdf
Filter: ("scribus_temp_latex_S16672*") "/tmp"
LATEX: Deleting "scribus_temp_latex_S16672" (please check that this file is correct!)
LATEX: Deleting "scribus_temp_latex_S16672.aux" (please check that this file is correct!)
LATEX: Deleting "scribus_temp_latex_S16672.log" (please check that this file is correct!)
LATEX: Deleting "scribus_temp_latex_S16672.pdf" (please check that this file is correct!)


Still some debug statements, and wasnt there an editor, even the basic version?

christoph_s

2007-08-24 21:46

administrator   ~0017154

Herm forgot to remove the debug statements. The bug is fixed. As for the editor, yes, it's being written on, but math support is definitely in and working.

Herm

2008-01-26 12:47

administrator   ~0018734

Editor is finished, debug statements removed, so I close this bug.

Issue History

Date Modified Username Field Change
2004-09-04 13:15 akvadrako New Issue
2005-05-31 04:51 plinnell Note Added: 0004844
2005-05-31 04:51 plinnell Status new => acknowledged
2005-05-31 04:51 plinnell Product Version 1.2 => 1.3
2005-10-08 07:43 scls19fr Note Added: 0006957
2005-10-08 10:44 plinnell Note Added: 0006958
2005-10-08 11:17 scls19fr Note Added: 0006961
2005-10-09 06:01 ringerc Note Added: 0006979
2006-02-23 12:36 scribus4formula Note Added: 0008872
2006-03-16 12:17 user715 Note Added: 0009337
2006-03-16 17:28 scls19fr Note Added: 0009347
2006-03-17 07:50 user715 Note Added: 0009353
2006-06-07 19:19 christoph_s Relationship added child of 0003896
2006-06-07 19:45 scls19fr Note Added: 0011596
2006-06-14 12:15 mhanski Relationship added related to 0003698
2006-06-20 07:06 user715 Note Added: 0011668
2007-08-24 01:00 christoph_s Note Added: 0017146
2007-08-24 21:42 cbradney Note Added: 0017153
2007-08-24 21:46 christoph_s Note Added: 0017154
2008-01-26 12:47 Herm Status acknowledged => resolved
2008-01-26 12:47 Herm Fixed in Version => 1.3.5svn
2008-01-26 12:47 Herm Resolution open => fixed
2008-01-26 12:47 Herm Assigned To => Herm
2008-01-26 12:47 Herm Note Added: 0018734
2008-01-26 13:14 christoph_s Status resolved => closed