View Issue Details

IDProjectCategoryView StatusLast Update
0001041ScribusPrintingpublic2006-12-26 00:23
Reporterprokoudine Assigned Tofschmid  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.3 
Target VersionFixed in Version1.3.4cvs 
Summary0001041: Support for art box, bleed box, crop box, media box and trim box
DescriptionPlease add support for art box, bleed box, crop box, media box and trim box
Additional InformationHere are definitions for all those types, extracted from http://developer.apple.com/documentation/GraphicsImaging/Reference/CGPDFDocument/Reference/function_group_4.html#//apple_ref/doc/uid/TP30000958-CH202-F17188:

The art box defines the extent of the page’s meaningful content (including potential white space) as intended by the document creator. The default value is the page’s crop box.

The bleed box defines the bounds to which the contents of the page should be clipped when output in a production environment. The default value is the page’s crop box.

The crop box defines the region to which the contents of the page are to be clipped (or cropped) when displayed or printed. Unlike the other boxes, the crop box has no defined meaning in terms of physical page geometry or intended use—it merely suggests where the page should be clipped.

The media box defines the location and size of the physical medium on which the page is intended to be displayed or printed. For example, if the page size is 8.5 by 11 inches, this function returns the coordinate pairs (0,0) and (612,792).

The trim box defines the intended dimensions of the finished page after trimming. It may be smaller than the media box, to allow for production-related content such as printing instructions, cut marks, or color bars. The default value is the page’s crop box.
TagsNo tags attached.
Patch

Relationships

related to 0002932 acknowledged Metabug: PDF Enhancements 
related to 0002705 closedplinnell Spot Color Seperations are not working 

Activities

afindlay

2004-09-23 14:18

reporter   ~0002482

Automatic generation of crop marks would be good too.

See also reports 129 and 1144

mhanski

2004-09-23 15:17

developer   ~0002483

See also RFE 194: http://bugs.scribus.net/bug_view_advanced_page.php?bug_id=0000194

packetbell

2004-09-23 15:45

reporter   ~0002484

Great feature. Can't wait so see it implemented.

thorwil

2006-01-23 08:57

reporter   ~0008287

For PDF (or other format) export it should be an option to either use the media box or the trim box as page size. So you could use one source document for a screen presentation (cropped to final size) and printing (positioned on standard size paper and with cut marks).

fschmid

2006-11-09 12:49

administrator   ~0013341

Have committed today the first steps to this.

cbradney

2006-12-26 00:19

administrator   ~0014236

Franz, if this is fixed, please close. I dont know where to look for this.

Issue History

Date Modified Username Field Change
2004-09-08 12:52 prokoudine New Issue
2004-09-23 14:18 afindlay Note Added: 0002482
2004-09-23 15:17 mhanski Note Added: 0002483
2004-09-23 15:45 packetbell Note Added: 0002484
2004-09-23 23:22 cbradney Product Version => 1.3
2005-10-10 06:19 ringerc Relationship added related to 0002705
2005-10-10 06:19 ringerc Status new => acknowledged
2005-12-30 00:05 plinnell Relationship added related to 0002932
2006-01-23 08:57 thorwil Note Added: 0008287
2006-11-01 22:50 plinnell Status acknowledged => assigned
2006-11-01 22:50 plinnell Assigned To => fschmid
2006-11-09 12:49 fschmid Note Added: 0013341
2006-11-10 11:08 fschmid Status assigned => resolved
2006-11-10 11:08 fschmid Fixed in Version => 1.3.4cvs
2006-11-10 11:08 fschmid Resolution open => fixed
2006-12-26 00:19 cbradney Note Added: 0014236
2006-12-26 00:22 fschmid Status resolved => closed