View Issue Details

IDProjectCategoryView StatusLast Update
0010735ScribusGraphics / Image Framespublic2019-09-02 06:16
Reporterhwsd Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.4.6.svn 
Target Version1.4.7Fixed in Version 
Summary0010735: Changing ghostscript DPI settings, duplicated Image Frames produce mismatch between canvas view and exported PDF
DescriptionI found a strange behavior in Scribus 1.4.1 (andprevious versions I think...).

If we place an image frame, load an image and duplicate image frame (doing copy/paste)
on scribus we can see two image frames containing the same image.
Now if we export in PDF, or print, the document only the first will be exported.

Same thing if we take an image frame, load an image, take another image frame and load same image file.

The only workaround that I found was take image file, copy it with a different name and load there two different files in two image frame.
Steps To ReproduceSteps updated with 1.4.6.svn:

0) Launch Scribus
1) Go to: File > Preferences... > External Tools:
     there you can see "PostScript Interpreter":
     change Resolution from 72 dpi to 150 dpi
2) Create a new document (A3 - Landscape)
3) Insert an Image Frame > right-click > Get Image... > "src.pdf" (attached)
4) Select the Image Frame > right-click > Adjust Frame to Image
5) Copy and Paste the Image Frame (place it on a free area of the document)
6) Export as PDF

In the exported PDF there is a mismatch between canvas view and exported PDF of the copied Image Frame.

NOTE: in order to reproduce this issue with 1.5.0, you need rev 20055+ as it fixes 0013048 (easy way). Check that File > Preferences... > Item Tools > Images: Scaling is set to "Free Scale" 100% as default for 1.4.6.svn otherwise you won't reproduce it.
Additional Information1.4.6.svn (20050)
1.5.0 (20052)
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0015797 closedjghali PDFs imported and duplicated in image frames wrongly scaled on PDF export 
related to 0008378 newfschmid PDF/EPS image scaling depends non-portably on gs resolution preference 

Activities

hwsd

2012-06-05 16:31

reporter  

error-example.sla (97,373 bytes)

hwsd

2012-06-05 16:32

reporter  

src.pdf (1,555 bytes)

hwsd

2012-06-05 16:32

reporter  

error-result.pdf (685,249 bytes)

hwsd

2012-06-05 16:32

reporter  

screenshot.PNG (88,562 bytes)
screenshot.PNG (88,562 bytes)

jghali

2012-06-05 19:32

administrator   ~0028086

Unable to reproduce here.

ale

2012-06-05 20:09

manager   ~0028089

jean, i can't reproduce, either.

but vlada wrote to the mailing list that it alraedy happend to him, too.

i wonder if somebody who knows how things works, could have a look at the .sla and the resulting PDF attached to this report and try to figure out why on stefano's computer the pdf don't get inserted in the PDF.

the only thing i can think of, is a RAM problem... but i can't believe it's that...

hwsd

2012-06-12 08:37

reporter   ~0028121

Running Scribus on Linux I can't reproduce the problem. On XP it happens every time.

ale

2012-06-12 09:39

manager   ~0028122

ciao stefano,
jean works on windows and couldn't reproduce... so it's something more than just a windows problem... there must be one more paratemer:

where are the images? on a shared volume?
are there accents in the path?
can you paste one of the paths?

hwsd

2012-06-12 09:43

reporter   ~0028123

Images are in local hard disk.
Path: "C:\Temp\scriberr\"

All attached files are in this path.

hwsd

2012-07-06 16:07

reporter   ~0028387

Last edited: 2012-07-06 16:21

View 3 revisions

After some test I notice this:

If in Preferences/externat tools/postrcript interpreter the ghostscrpt resolution is 72 dpi all work. If resolution is more than 72 (ex 150) happens this problem.

More big is the resolution more small is the duplicated image when exported.

See attached files:

gs-72dpi.pdf gs-150dpi.pdf gs-300dpi.pdf gs-600dpi.pdf

hwsd

2012-07-06 16:19

reporter  

gs-72dpi.pdf (2,352 bytes)

hwsd

2012-07-06 16:19

reporter  

gs-150dpi.pdf (2,375 bytes)

hwsd

2012-07-06 16:19

reporter  

gs-300dpi.pdf (2,375 bytes)

hwsd

2012-07-06 16:20

reporter  

gs-600dpi.pdf (2,375 bytes)

ale

2012-07-08 08:06

manager   ~0028399

jawohl!

can replicate now...

hwsd

2012-07-11 14:39

reporter   ~0028421

Last edited: 2015-09-27 10:41

View 2 revisions

This issue could be related also to this bug: 0008378

FirasH

2015-05-05 16:42

developer   ~0035033

It is also reproducible on 1.5.0 but there is another bug that makes things harder to reproduce 0013048.

Kunda

2015-05-05 20:43

manager   ~0035037

Last edited: 2015-05-05 20:44

View 2 revisions

I followed the steps, FirasH. I can't reproduce. Am I missing something ?
https://www.dropbox.com/s/p3riob5mhpmle86/Screenshot%202015-05-05%2015.43.51.png?dl=0

Kunda

2015-09-27 10:44

manager   ~0036413

Adding to 1.4.6 roadmap for review

jghali

2019-09-02 02:44

administrator   ~0046603

Fixed with issue 0015797 in 1.5.6.svn.

Issue History

Date Modified Username Field Change
2012-06-05 16:31 hwsd New Issue
2012-06-05 16:31 hwsd File Added: error-example.sla
2012-06-05 16:32 hwsd File Added: src.pdf
2012-06-05 16:32 hwsd File Added: error-result.pdf
2012-06-05 16:32 hwsd File Added: screenshot.PNG
2012-06-05 19:32 jghali Note Added: 0028086
2012-06-05 20:09 ale Note Added: 0028089
2012-06-12 08:37 hwsd Note Added: 0028121
2012-06-12 09:39 ale Note Added: 0028122
2012-06-12 09:43 hwsd Note Added: 0028123
2012-07-06 16:07 hwsd Note Added: 0028387
2012-07-06 16:08 hwsd Note Edited: 0028387 View Revisions
2012-07-06 16:19 hwsd File Added: gs-72dpi.pdf
2012-07-06 16:19 hwsd File Added: gs-150dpi.pdf
2012-07-06 16:19 hwsd File Added: gs-300dpi.pdf
2012-07-06 16:20 hwsd File Added: gs-600dpi.pdf
2012-07-06 16:21 hwsd Note Edited: 0028387 View Revisions
2012-07-08 08:06 ale Note Added: 0028399
2012-07-11 14:39 hwsd Note Added: 0028421
2014-07-21 04:45 FirasH Relationship added related to 0008378
2015-05-05 13:13 FirasH Patch => No
2015-05-05 13:13 FirasH Status new => confirmed
2015-05-05 13:13 FirasH OS Windows XP =>
2015-05-05 13:13 FirasH OS Version SP3 =>
2015-05-05 13:13 FirasH Platform WIN32 =>
2015-05-05 13:13 FirasH Product Version 1.4.1 => 1.4.6.svn
2015-05-05 13:13 FirasH Summary Duplicate image frame shown but not printed/exported or printed exported at wrong size => Changing ghostscript DPI settings, duplicated Image Frames produce mismatch between canvas view and exported PDF
2015-05-05 13:13 FirasH Steps to Reproduce Updated View Revisions
2015-05-05 13:13 FirasH Additional Information Updated View Revisions
2015-05-05 16:42 FirasH Note Added: 0035033
2015-05-05 16:42 FirasH Additional Information Updated View Revisions
2015-05-05 20:43 Kunda Note Added: 0035037
2015-05-05 20:44 Kunda Note Edited: 0035037 View Revisions
2015-05-05 20:59 FirasH Steps to Reproduce Updated View Revisions
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames
2015-09-27 10:41 Kunda Note Edited: 0028421 View Revisions
2015-09-27 10:44 Kunda Note Added: 0036413
2015-09-27 10:44 Kunda Target Version => 1.4.6
2016-01-12 13:11 jghali Target Version 1.4.6 => 1.4.7
2019-09-02 02:44 jghali Assigned To => jghali
2019-09-02 02:44 jghali Status confirmed => resolved
2019-09-02 02:44 jghali Resolution open => duplicate
2019-09-02 02:44 jghali Note Added: 0046603
2019-09-02 02:44 jghali Relationship added duplicate of 0015797
2019-09-02 06:16 jghali Status resolved => closed