View Issue Details

IDProjectCategoryView StatusLast Update
0015797ScribusPDFpublic2019-12-08 21:24
Reporterjim78b Assigned Tojghali  
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSwin7 OS Version64bit
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015797: PDFs imported and duplicated in image frames wrongly scaled on PDF export
Descriptioni see all correct but when i export to pdf the image frames in which i load pdf are wrong because has wrong scale,
in preferences as the image i attach, if set to 72 all pdf in image frame when export are correct but i lost the high resolution view in document because is set to max 72 dpi!

so I come to the conclusion that in external tools -> applications where there is postscript interpreter dpi pref. if I put the resolution over 72 dpi then I export everything is wrong.

ususally i set postscript interpreter 300 dpi i see all pdf in image frames correct but when export to pdf is a mistake.
Steps To Reproducetry to insert a pdf in image frame near text i think is this that cause error to export.
then export to pdf as the image attached the warning icon is very small!!
Tagsacrobat, pdf export, wrong size
PatchNo

Relationships

related to 0008378 newfschmid PDF/EPS image scaling depends non-portably on gs resolution preference 
has duplicate 0010735 closedjghali Changing ghostscript DPI settings, duplicated Image Frames produce mismatch between canvas view and exported PDF 

Activities

jim78b

2019-09-01 12:22

reporter  

postscript bug.jpg (179,450 bytes)
postscript bug.jpg (179,450 bytes)
Nuova cartella.zip (171,131 bytes)

utnik

2019-09-01 15:24

updater   ~0046597

i can confirm the problem on macOS10.14.6 with scribus1.5.5 and 1.5.6-r23124.
but it's a bit different here:
- when i set the resolution for the postscript interpreter at 250ppi, i get a .pdf file with small warning triangles (except the one on the first page). everything else looks correct.
- after changing the resolution to 72ppi all the placed .pdf files are scaled down. only the .pdf files keep their size… (see attached file)

test156-72.pdf (683,294 bytes)

utnik

2019-09-01 15:27

updater   ~0046598

correction:
…only the .jpg files keep their size…

jim78b

2019-09-01 17:08

reporter   ~0046599

Yes is annoying that .but exist a 1.5.6 version ?i have just install 1.5.6 portable the only one in the scribus site

jim78b

2019-09-01 17:11

reporter   ~0046600

Yes for pdf i become crazy

utnik

2019-09-01 17:20

updater   ~0046601

you'll find snapshots on https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.6.svn/ – but ask stuff like that in the forums.

jghali

2019-09-02 02:41

administrator   ~0046602

I fixed the issue where a same PDF imported in several image frames would be incorrectly exported to PDF, except for the first frame where it is located. However I have not fixed the other part of the issue, which has already been reported as 0008378. 0008378 implies you must not change GhostScript resolution settings in preferences after having imported a PDF/EPS in a document.

utnik

2019-09-02 03:54

updater   ~0046604

thanks – that was fast!

jim78b

2019-09-02 05:54

reporter   ~0046605

Is not new /resolved As i told if you set 72dpi in postscript work .for me is not resilved

jghali

2019-09-02 06:06

administrator   ~0046606

This part is already covered by issue 0008378 which is indeed not resolved. If you change the Ghostscript resolution and open an already existing document already edited with a different GS resolution, you have to manually adjust the scale of images using properties palette.

jghali

2019-09-02 06:11

administrator   ~0046608

For example if your old GS resolution is 300 dpi and your new GS resolution is 72 dpi, you would have to multiply the X-scale and Y-scale of imported PDF/EPS images by 300 / 72 after reopening document.

jim78b

2019-09-02 06:20

reporter   ~0046609

Is annoying because i set 300 and import various pdf in image frames.i see all correct .but when export is wrong scale .

Issue History

Date Modified Username Field Change
2019-09-01 12:22 jim78b New Issue
2019-09-01 12:22 jim78b File Added: postscript bug.jpg
2019-09-01 12:22 jim78b File Added: Immagine.jpg
2019-09-01 12:22 jim78b File Added: Nuova cartella.zip
2019-09-01 14:52 jghali Summary 1.5.5 portable or not pdf export issue-bug postscript => PDFs imported in image frame wrongly scaled on PDF export
2019-09-01 15:15 jghali Summary PDFs imported in image frame wrongly scaled on PDF export => PDFs imported and duplicated in image frames wrongly scaled on PDF export
2019-09-01 15:24 utnik File Added: test156-72.pdf
2019-09-01 15:24 utnik Note Added: 0046597
2019-09-01 15:27 utnik Note Added: 0046598
2019-09-01 17:08 jim78b Note Added: 0046599
2019-09-01 17:11 jim78b Note Added: 0046600
2019-09-01 17:20 utnik Note Added: 0046601
2019-09-02 02:41 jghali Assigned To => jghali
2019-09-02 02:41 jghali Status new => resolved
2019-09-02 02:41 jghali Resolution open => fixed
2019-09-02 02:41 jghali Fixed in Version => 1.5.6.svn
2019-09-02 02:41 jghali Note Added: 0046602
2019-09-02 02:44 jghali Relationship added has duplicate 0010735
2019-09-02 02:45 jghali Relationship added related to 0008378
2019-09-02 03:54 utnik Note Added: 0046604
2019-09-02 05:54 jim78b Note Added: 0046605
2019-09-02 06:04 jim78b File Deleted: Immagine.jpg
2019-09-02 06:06 jghali Note Added: 0046606
2019-09-02 06:11 jghali Note Added: 0046608
2019-09-02 06:20 jim78b Note Added: 0046609
2019-09-02 09:50 jim78b Tag Attached: acrobat
2019-09-02 09:50 jim78b Tag Attached: pdf export
2019-09-02 09:50 jim78b Tag Attached: wrong size
2019-12-08 21:24 cbradney Status resolved => closed