View Issue Details

IDProjectCategoryView StatusLast Update
0011017ScribusUser Interfacepublic2016-03-06 10:09
ReporterFoske Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0011017: Palettes: By default, show them docked instead of undocked
DescriptionThis is an user experience topic: I noticed that when I enabled a palette for the first time, it is undocked, and the different palettes show up on different places of the screen. I think it is very good that you can dock and undock them now, but in my opinion the default should be docked: This gives the user a much neater impression, and doesn't immediately require him to move the floating window to a sane position. Of course undocking still must be possible, and the tool must still remember that an user undocked a palette.

To add to the coolness you can also remember whether the user last docked on the left or right side (Edit: fixed in 0011544) and automatically dock on that side instead of the default (which I would make left).
Steps To ReproduceClear scribus application configuration settings, open a doc, enable all palettes and see them clutter the screen.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0011544 closedfschmid Docked palettes position / size is not saved between sessions. 

Activities

Foske

2012-08-09 08:21

reporter   ~0028789

If people disagree with this bug report, at least I would advise to look at the code that positions the popups. Quick fix: Center them all, better fix: starting from the upper left corner of the canvas, one below the other.

Kunda

2016-03-02 22:15

manager   ~0038953

In 0011544 Franz fixed the "Docked palettes position / size is not saved between sessions" issue.

As for the default behavior, my opinion, it's OK that that the palettes open up undocked.

Kunda

2016-03-04 02:27

manager   ~0038961

Resolving this since IMO,
User can add palettes to dock and it will remember where they were added. So essentially the user only needs to choose where they want to dock their palette once.

Issue History

Date Modified Username Field Change
2012-08-09 08:10 Foske New Issue
2012-08-09 08:21 Foske Note Added: 0028789
2016-03-02 22:15 Kunda Patch => No
2016-03-02 22:15 Kunda Note Added: 0038953
2016-03-02 22:16 Kunda Description Updated View Revisions
2016-03-02 22:16 Kunda Relationship added related to 0011544
2016-03-04 02:27 Kunda Note Added: 0038961
2016-03-04 02:27 Kunda Relationship replaced duplicate of 0011544
2016-03-04 02:27 Kunda Status new => resolved
2016-03-04 02:27 Kunda Resolution open => duplicate
2016-03-04 02:27 Kunda Assigned To => fschmid
2016-03-06 10:09 cbradney Status resolved => closed