View Issue Details

IDProjectCategoryView StatusLast Update
0001129ScribusGeneralpublic2004-09-23 22:53
Reporterblazej Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSMandrakeOS Version9.2
Product Version1.2 
Target VersionFixed in Version 
Summary0001129: Polish hyphenation is not satisfactory
DescriptionThis is very unfortunate because I was hoping to use it for my project... A few examples: diame-tral-nie, roz-mawiali, pew-niakiem. It looks like I will have to hyphanate 60 pages of text manually, aaargh!
Additional InformationThe frame is set to polish language and so is the hyphenator.
TagsNo tags attached.
Patch

Relationships

related to 0001136 closedfschmid Hyphenation marks not visible on linked frames 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

mhanski

2004-09-20 08:19

developer   ~0002432

Blazej, before you start to hyphenate manually, try this:

1. Grab the "official" OO.org Polish hyphenate dictionary from their site:

 http://lingucomponent.openoffice.org/hyph_dic.html

2. Replace with it the current hyph dictionary in Sribus (something like /usr/local/lib/scribus/dicts/hyph_pl.dic)

3. Please insert as the first line into the "new" hyph file it's language encoding, something like ISO8859-2 (should be the same as in the old file)

4. Look, if you get better results with the new hyphenation file and the same text as earlier

5. If you are satisfied with it, submit the new Polish hyphenation file for inclusion into the Scribus 1.2.1 (a bugfix release, which is planned next - submit your file here using the "Upload File" button).

Thanks in advance
Maciej

cbradney

2004-09-20 10:11

administrator   ~0002433

blazej, as he says.. please follow the step and let us know how it goes.

2004-09-21 02:49

 

hyph_pl.dic (30,551 bytes)

blazej

2004-09-21 02:52

reporter   ~0002445

Yep, it works much better.

However, there is a another serious problem now:
I have multiple linked text frames.
After applying the hyphenation to the first one, all of them get hyphenated - cool!
PROBLEM: the dashes are visible ONLY in the first frame! Subsequent frames are hyphenated but the dashes are not visible!!!!

If someone figures this out, can they tell me how I can fix this on my machine - I need this hyphenator guy to work!

mhanski

2004-09-21 20:35

developer   ~0002451

>Yep, it works much better.

I agree with it after some testing. Dear Scribus team, please include this file into the 1.2.1 release.

Regarding the invisible dashes in the second text frame: I've noticed that too, but since it occurs in both cases, i.e. while using both the old and the new hyph_pl.dic files, it clearly isn't related to Polish hyphenation. I copied Your (and added mine) remarks on this into the bug http://bugs.scribus.net/view.php?id=1130 which you submitted subsequently, so that this bug can be clearly resolved after adding the new hyph_pl.dic file to the Scribus sources.

cbradney

2004-09-22 00:28

administrator   ~0002468

Ive added 1136 to handle the dashes not showing.

cbradney

2004-09-23 22:53

administrator   ~0002500

The missing hyphens on linked frames is now in a new bug. Closing this one.

Issue History

Date Modified Username Field Change
2004-09-20 02:20 blazej New Issue
2004-09-20 08:19 mhanski Note Added: 0002432
2004-09-20 10:11 cbradney Note Added: 0002433
2004-09-21 02:49 blazej File Added: hyph_pl.dic
2004-09-21 02:52 blazej Note Added: 0002445
2004-09-21 20:35 mhanski Note Added: 0002451
2004-09-21 22:18 fschmid Status new => resolved
2004-09-21 22:18 fschmid Resolution open => fixed
2004-09-21 22:18 fschmid Assigned To => fschmid
2004-09-21 22:55 cbradney Product Version => 1.2
2004-09-22 00:27 cbradney Relationship added related to 0001136
2004-09-22 00:28 cbradney Note Added: 0002468
2004-09-23 22:53 cbradney Status resolved => closed
2004-09-23 22:53 cbradney Note Added: 0002500
2006-05-16 22:21 christoph_s Relationship added child of 0003828