View Issue Details

IDProjectCategoryView StatusLast Update
0011391ScribusUsabilitypublic2014-07-11 14:16
Reportermelanes Assigned To 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformOSXubuntuOS Version12.10
Product Version 
Target VersionFixed in Version 
Summary0011391: Scribus Signal 0000011 crash after opening local file
DescriptionWhen opening a scribus file from within the program causes this error message: Scribus crashes due to Signal 11. Clicking ok forces the program to close. I am able to create a new document, save it, and then not be able to open it again after closing it.

I tried QT_ACCESSIBILITY=0 scribus from the terminal, attempted to open my document, and the program returned the error report and closed. The terminal reported:

Scribus Crash
-------------
Scribus crashes due to Signal 0000011
Calling Emergency Save
Segmentation fault (core dumped)
Steps To ReproduceDouble click a scribus file from the window manager.

or

From within Scribus, click file open and navigate to the file and select to open.
Additional InformationMy version of Scribus:
Scribus Version 1.4.1.svn
6 February 2012
Build ID: C-C-T-F-C1.12.2
Using Ghostscript version 9.06

My system
Xubuntu 12.10, but also experienced same bug with 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: scribus 1.4.0.dfsg+r17300-1.1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic i686
ApportVersion: 2.6.1-0ubuntu9
Architecture: i386
Date: Wed Jan 9 11:36:23 2013
InstallationDate: Installed on 2012-04-25 (259 days ago)
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: scribus
UpgradeStatus: Upgraded to quantal on 2013-01-07 (2 days ago)
TagsNo tags attached.
Patch

Activities

melanes

2013-01-22 16:41

reporter  

Dependencies.txt (6,666 bytes)
adduser 3.113+nmu1ubuntu1
apt-utils 0.9.7.5ubuntu5.2
base-passwd 3.5.26
blt 2.4z-4.2ubuntu2
busybox-initramfs 1:1.19.3-7ubuntu1.1
coreutils 8.13-3.2ubuntu2.1
cpio 2.11-8ubuntu3
cups-bsd 1.6.1-0ubuntu11.3
cups-client 1.6.1-0ubuntu11.3
cups-common 1.6.1-0ubuntu11.3
dbus 1.6.4-1ubuntu4
debconf 1.5.46ubuntu1
debconf-i18n 1.5.46ubuntu1
debianutils 4.3.4
dpkg 1.16.7ubuntu6
e2fslibs 1.42.5-1ubuntu2
e2fsprogs 1.42.5-1ubuntu2
file 5.11-2
findutils 4.4.2-4ubuntu2
fontconfig 2.10.1-0ubuntu3
fontconfig-config 2.10.1-0ubuntu3
gcc-4.7-base 4.7.2-2ubuntu1
ghostscript 9.06~dfsg-0ubuntu4
gsfonts 1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1
icc-profiles-free 2.0.1+dfsg-1
ifupdown 0.7.2ubuntu2
initramfs-tools 0.103ubuntu0.2
initramfs-tools-bin 0.103ubuntu0.2
initscripts 2.88dsf-13.10ubuntu13
insserv 1.14.0-4ubuntu1
iproute 20120521-3ubuntu1
klibc-utils 2.0.1-1ubuntu2
krb5-locales 1.10.1+dfsg-2
libacl1 2.2.51-8ubuntu2
libapt-inst1.5 0.9.7.5ubuntu5.2
libapt-pkg4.12 0.9.7.5ubuntu5.2
libasn1-8-heimdal 1.6~git20120403+dfsg1-2
libattr1 1:2.4.46-8ubuntu1
libaudio2 1.9.3-5
libavahi-client3 0.6.31-1ubuntu2
libavahi-common-data 0.6.31-1ubuntu2
libavahi-common3 0.6.31-1ubuntu2
libblkid1 2.20.1-5.1ubuntu2
libbz2-1.0 1.0.6-4
libc-bin 2.15-0ubuntu20
libc6 2.15-0ubuntu20
libcairo2 1.12.2-1ubuntu2.2
libcap2 1:2.22-1ubuntu4
libclass-isa-perl 0.36-3
libcomerr2 1.42.5-1ubuntu2
libcups2 1.6.1-0ubuntu11.3
libcupsimage2 1.6.1-0ubuntu11.3
libdb5.1 5.1.29-5ubuntu2
libdbus-1-3 1.6.4-1ubuntu4
libdrm-intel1 2.4.39-0ubuntu1
libdrm-nouveau1a 2.4.39-0ubuntu1
libdrm-nouveau2 2.4.39-0ubuntu1
libdrm-radeon1 2.4.39-0ubuntu1
libdrm2 2.4.39-0ubuntu1
libexpat1 2.1.0-1ubuntu1
libffi6 3.0.11-2
libfile-copy-recursive-perl 0.38-1
libfontconfig1 2.10.1-0ubuntu3
libfontenc1 1:1.1.1-1
libfreetype6 2.4.10-0ubuntu1
libgcc1 1:4.7.2-2ubuntu1
libgcrypt11 1.5.0-3ubuntu1
libgdbm3 1.8.3-11
libgl1-mesa-dri 9.0-0ubuntu1
libgl1-mesa-glx 9.0-0ubuntu1
libglapi-mesa 9.0-0ubuntu1
libglib2.0-0 2.34.1-1ubuntu1
libglib2.0-data 2.34.1-1ubuntu1
libgnutls26 2.12.14-5ubuntu4
libgpg-error0 1.10-3.1ubuntu1
libgpm2 1.20.4-6
libgs9 9.06~dfsg-0ubuntu4
libgs9-common 9.06~dfsg-0ubuntu4
libgssapi-krb5-2 1.10.1+dfsg-2
libgssapi3-heimdal 1.6~git20120403+dfsg1-2
libhcrypto4-heimdal 1.6~git20120403+dfsg1-2
libheimbase1-heimdal 1.6~git20120403+dfsg1-2
libheimntlm0-heimdal 1.6~git20120403+dfsg1-2
libhx509-5-heimdal 1.6~git20120403+dfsg1-2
libice6 2:1.0.8-2
libidn11 1.25-2
libijs-0.35 0.35-8build1
libjbig0 2.0-2ubuntu1
libjbig2dec0 0.11-1ubuntu2
libjpeg-turbo8 1.2.1-0ubuntu2
libjpeg8 8c-2ubuntu7
libk5crypto3 1.10.1+dfsg-2
libkeyutils1 1.5.5-3
libklibc 2.0.1-1ubuntu2
libkms1 2.4.39-0ubuntu1
libkrb5-26-heimdal 1.6~git20120403+dfsg1-2
libkrb5-3 1.10.1+dfsg-2
libkrb5support0 1.10.1+dfsg-2
liblcms1 1.19.dfsg-1.1ubuntu2
liblcms2-2 2.2+git20110628-2ubuntu4
libldap-2.4-2 2.4.31-1ubuntu2
libllvm3.1 3.1-2ubuntu1
liblocale-gettext-perl 1.05-7build2
liblzma5 5.1.1alpha+20120614-1
libmagic1 5.11-2
libmng1 1.0.10-3build1
libmount1 2.20.1-5.1ubuntu2
libmysqlclient18 5.5.28-0ubuntu0.12.10.2
libncurses5 5.9-10ubuntu1
libncursesw5 5.9-10ubuntu1
libnih-dbus1 1.0.3-4ubuntu11
libnih1 1.0.3-4ubuntu11
libp11-kit0 0.13-1
libpam-modules 1.1.3-7ubuntu3
libpam-modules-bin 1.1.3-7ubuntu3
libpam0g 1.1.3-7ubuntu3
libpaper-utils 1.1.24+nmu2
libpaper1 1.1.24+nmu2
libpciaccess0 0.13.1-2
libpcre3 1:8.30-5ubuntu1
libpixman-1-0 0.26.0-3
libplymouth2 0.8.4-0ubuntu3
libpng12-0 1.2.49-1ubuntu1
libpodofo0.9.0 0.9.0-1.1ubuntu1
libpopt0 1.16-7ubuntu2
libprocps0 1:3.3.3-2ubuntu3
libpython2.7 2.7.3-5ubuntu4
libqt4-dbus 4:4.8.3+dfsg-0ubuntu3
libqt4-declarative 4:4.8.3+dfsg-0ubuntu3
libqt4-network 4:4.8.3+dfsg-0ubuntu3
libqt4-script 4:4.8.3+dfsg-0ubuntu3
libqt4-sql 4:4.8.3+dfsg-0ubuntu3
libqt4-sql-mysql 4:4.8.3+dfsg-0ubuntu3
libqt4-xml 4:4.8.3+dfsg-0ubuntu3
libqt4-xmlpatterns 4:4.8.3+dfsg-0ubuntu3
libqtcore4 4:4.8.3+dfsg-0ubuntu3
libqtgui4 4:4.8.3+dfsg-0ubuntu3
libreadline6 6.2-9
libroken18-heimdal 1.6~git20120403+dfsg1-2
libsasl2-2 2.1.25.dfsg1-5
libsasl2-modules 2.1.25.dfsg1-5
libselinux1 2.1.9-5ubuntu1
libslang2 2.2.4-15ubuntu1
libsm6 2:1.2.1-2
libsqlite3-0 3.7.13-1
libss2 1.42.5-1ubuntu2
libssl1.0.0 1.0.1c-3ubuntu2
libstdc++6 4.7.2-2ubuntu1
libswitch-perl 2.16-2
libtalloc2 2.0.7+git20120207-1
libtasn1-3 2.13-2
libtdb1 1.2.10-2
libtext-charwidth-perl 0.04-7build2
libtext-iconv-perl 1.7-5build1
libtext-wrapi18n-perl 0.06-7
libtiff5 4.0.2-1ubuntu2.1
libtinfo5 5.9-10ubuntu1
libtxc-dxtn-s2tc0 0~git20110809-3
libudev0 175-0ubuntu13
libutempter0 1.1.5-4build1
libuuid1 2.20.1-5.1ubuntu2
libwbclient0 2:3.6.6-3ubuntu5
libwind0-heimdal 1.6~git20120403+dfsg1-2
libx11-6 2:1.5.0-1
libx11-data 2:1.5.0-1
libx11-xcb1 2:1.5.0-1
libxau6 1:1.0.7-1
libxaw7 2:1.0.10-2
libxcb-glx0 1.8.1-1ubuntu1
libxcb-render0 1.8.1-1ubuntu1
libxcb-shape0 1.8.1-1ubuntu1
libxcb-shm0 1.8.1-1ubuntu1
libxcb1 1.8.1-1ubuntu1
libxcomposite1 1:0.4.3-2build2
libxdamage1 1:1.1.3-2build2
libxdmcp6 1:1.1.1-1
libxext6 2:1.3.1-2
libxfixes3 1:5.0-4ubuntu5
libxfont1 1:1.4.5-2
libxft2 2.3.1-1
libxi6 2:1.6.1-1
libxinerama1 2:1.1.2-1
libxml2 2.8.0+dfsg1-5ubuntu2.1
libxmu6 2:1.1.1-1
libxmuu1 2:1.1.1-1
libxpm4 1:3.5.10-1
libxrandr2 2:1.4.0-1
libxrender1 1:0.9.7-1
libxss1 1:1.2.2-1
libxt6 1:1.1.3-1
libxtst6 2:1.2.1-1
libxv1 2:1.0.7-1
libxxf86dga1 2:1.1.3-2
libxxf86vm1 1:1.1.2-1
lsb-base 4.0-0ubuntu26.1
makedev 2.3.1-91ubuntu2
mime-support 3.52-1ubuntu1
module-init-tools 3.16-1ubuntu6
mount 2.20.1-5.1ubuntu2
mountall 2.42ubuntu0.3
multiarch-support 2.15-0ubuntu20
mysql-common 5.5.28-0ubuntu0.12.10.2
ncurses-bin 5.9-10ubuntu1
netbase 5.0ubuntu1
passwd 1:4.1.4.2+svn3283-3ubuntu7
perl 5.14.2-13ubuntu0.1
perl-base 5.14.2-13ubuntu0.1
perl-modules 5.14.2-13ubuntu0.1
plymouth 0.8.4-0ubuntu3
plymouth-theme-ubuntu-text 0.8.4-0ubuntu3
procps 1:3.3.3-2ubuntu3
psmisc 22.19-1ubuntu1
python 2.7.3-0ubuntu7
python-minimal 2.7.3-0ubuntu7
python-tk 2.7.3-1ubuntu2
python2.7 2.7.3-5ubuntu4
python2.7-minimal 2.7.3-5ubuntu4
qdbus 4:4.8.3+dfsg-0ubuntu3
readline-common 6.2-9
samba-common 2:3.6.6-3ubuntu5
samba-common-bin 2:3.6.6-3ubuntu5
sed 4.2.1-10ubuntu1
sensible-utils 0.0.7ubuntu1
sgml-base 1.26+nmu3ubuntu1
shared-mime-info 1.0-1ubuntu2
smbclient 2:3.6.6-3ubuntu5
sysv-rc 2.88dsf-13.10ubuntu13
sysvinit-utils 2.88dsf-13.10ubuntu13
tar 1.26-4ubuntu1
tcl8.5 8.5.11-2ubuntu1
tk8.5 8.5.11-2
ttf-dejavu-core 2.33-2ubuntu1
tzdata 2012e-0ubuntu2
ucf 3.0025+nmu3
udev 175-0ubuntu13
update-inetd 4.43
upstart 1.5-0ubuntu9
util-linux 2.20.1-5.1ubuntu2
uuid-runtime 2.20.1-5.1ubuntu2
x11-common 1:7.7+1ubuntu4
x11-utils 7.7~1ubuntu1
xbitmaps 1.1.1-1
xfonts-encodings 1:1.0.4-1ubuntu1
xfonts-scalable 1:1.0.3-1
xfonts-utils 1:7.7~1
xml-core 0.13+nmu1
xterm 278-1ubuntu2
zlib1g 1:1.2.7.dfsg-13
Dependencies.txt (6,666 bytes)

cezaryece

2013-01-22 21:00

developer   ~0029754

Maybe problem is in wrong preferences files?
Try to delete ~/scribus folder. It is folder where application`s preferences are stored and deleting it brings all preferences to default values.
Next create new doc, save it and try to open.

melanes

2013-01-23 18:52

reporter   ~0029759

Last edited: 2013-01-23 18:54

View 2 revisions

Deleting the preferences folder allowed me to open my document once from the window manager and once from within Scribus - only by deleting the preferences file first each time. After that, I could no longer open my document without Scribus crashing despite deleting the preferences folder.

Also tested deleting the preferences folder again. Opened Scribus and created a new document with various objects, saved it and closed it. I can open the test document from either the window manager or from within Scribus without any crashes.

I suspect that my original document is either corrupted or has some feature that causes the crash. This document has a few master pages, guides, and text boxes. I can submit this document for review if that would be helpful.

melanes

2013-02-02 00:42

reporter   ~0029781

I believe the original file corruption occurred when I tried to manage the master pages. That was one of the last operations performed prior to the crash. This was confirmed when I created a new document. I created some master pages then decided I didn't like them. Went to edit -> manage master pages. Selected the master page to delete. Sometimes the crash will occur after deleting just one and sometimes the crash occurs after deleting a second master page. I was able to reopen my document after the crash several times and repeated the procedure with scribus crashing each time. On the final attempt, I deleted one master page, hit file -> save, and then crash. Now my document does not open at all and crashes scribus each time I attempt to open it as described above.

Please advise if I should create a new bug report.

Kunda

2014-07-04 03:34

updater   ~0032465

Does this issue still persist?

Kunda

2014-07-08 13:36

updater   ~0032587

This is a good opportunity to fix crashes because the team is poised to release the new 1.5 dev release. You are invited to share further details such as the way we can reproduce this issue + the .sla file and any other details. If not we will close this issue soon.

Kunda

2014-07-09 15:39

updater   ~0032626

If this issue persists on a a more current version of Scribus (specifically SVN) please file a new bug report with reproducible steps when possible upload the SLA file. Closing this for now.

melanes

2014-07-11 13:33

reporter   ~0032687

I updated to 1.4.3 and the issue was resolved.

FirasH

2014-07-11 14:16

developer   ~0032688

Closing as fixed.

Issue History

Date Modified Username Field Change
2013-01-22 16:41 melanes New Issue
2013-01-22 16:41 melanes File Added: Dependencies.txt
2013-01-22 21:00 cezaryece Note Added: 0029754
2013-01-23 18:52 melanes Note Added: 0029759
2013-01-23 18:54 melanes Note Edited: 0029759 View Revisions
2013-02-02 00:42 melanes Note Added: 0029781
2014-07-04 03:34 Kunda Note Added: 0032465
2014-07-04 03:34 Kunda Status new => feedback
2014-07-08 13:36 Kunda Note Added: 0032587
2014-07-09 15:39 Kunda Note Added: 0032626
2014-07-09 15:39 Kunda Status feedback => closed
2014-07-09 15:39 Kunda Resolution open => unable to reproduce
2014-07-11 13:33 melanes Note Added: 0032687
2014-07-11 13:33 melanes Status closed => feedback
2014-07-11 13:33 melanes Resolution unable to reproduce => reopened
2014-07-11 14:16 FirasH Note Added: 0032688
2014-07-11 14:16 FirasH Status feedback => closed
2014-07-11 14:16 FirasH Resolution reopened => fixed