View Issue Details

IDProjectCategoryView StatusLast Update
0011519ScribusUsabilitypublic2013-05-04 22:04
ReporterMarikus Assigned Tojghali  
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformIntel P4 3Ghz 1GB RAMOSWindowsOS VersionXP Professional
Product Version1.4.2 
Target VersionFixed in Version 
Summary0011519: Manipulating a Line/Bezier Curve causes change in XY postition
DescriptionThis bug was originally reported by Stu for Scribus Version 1.3.3.12 at 08-Nov-24 under 0007628.

As this issue is still present, I report it now again for the new Scribus 1.4.2.

Original Description:

After editing the shape of a Line or Bezeir Curve: either by deleting a Node or moving a Control Point, the entire line then has it's X and Y Postiton changed. So in other words: everytime you make a change to a Line via the Nodes tab it shifts the Line slightly to the right.


The change in position is usually only about 1mm or so.
Using Undo doesn't shift the Line back to it's original position.


Work around this:

1. Increase the magnification to a very high level.
2. Change the node (In high mag view the unwanted changes scribus does are tiny small).
3. Change back the size.

Alternatively you can write the coordinates on paper for each point and just write them into X/Y.
Steps To Reproduce1. Mark an object like a box, a circle, etc.
2. Right click on the mouse
3. Properties
4. Shape
5. Edit
6. Press upper left button "Move Nodes".
7. Click on one of the nodes.
8. Pay attention to X/Y
9. Repeat at step 7, move ahead.
Additional InformationThis bug is absolutely uninteresting as long as you can use Inkscape to edit your objects.

But when you need to edit objects in relation to other objects, this bug is a pain.
TagsNo tags attached.
Patch

Relationships

duplicate of 0007628 closedKunda Manipulating a Line/Bezier Curve causes change in XY postition 

Activities

jghali

2013-05-04 22:04

administrator   ~0030128

No need to report it again. 0007628 has not been closed, so it is expected to be still present.

Issue History

Date Modified Username Field Change
2013-05-04 21:43 Marikus New Issue
2013-05-04 22:04 jghali Note Added: 0030128
2013-05-04 22:04 jghali Relationship added duplicate of 0007628
2013-05-04 22:04 jghali Status new => resolved
2013-05-04 22:04 jghali Resolution open => duplicate
2013-05-04 22:04 jghali Assigned To => jghali
2013-05-04 22:04 jghali Status resolved => closed