View Issue Details

IDProjectCategoryView StatusLast Update
0007628ScribusShape Drawingpublic2016-02-13 19:51
ReporterStu Assigned ToKunda  
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionunable to reproduce 
PlatformWindowsOSXPOS VersionService pack 3
Product Version1.3.3.12 
Target Version1.5.1Fixed in Version 
Summary0007628: Manipulating a Line/Bezier Curve causes change in XY postition
DescriptionAfter editing the shape of a Line or Bezeir Curve: either by deleting a Node or moving a Control Point, the entire line then has it's X and Y Postiton changed. So in other words: everytime you make a change to a Line via the Nodes tab it shifts the Line slightly to the right.

The change in position is usually only about 1mm or so.
Using Undo doesn't shift the Line back to it's original position.
Steps To ReproduceCreate a Bezeir curve and manipulate but it doesn't occur all the time.
TagsNo tags attached.
PatchNo

Relationships

related to 0012347 closedjghali Deleting Bezier Curve nodes leads to wrong result 
has duplicate 0011519 closedjghali Manipulating a Line/Bezier Curve causes change in XY postition 
related to 0013676 closedjghali move a control point outside the existing boundary of shape = changes X & width values in PP 
child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

Marikus

2013-05-04 09:55

reporter   ~0030124

Last edited: 2013-05-04 14:08

View 5 revisions

I just wanted to report this bug, but now I see its allready reported. My personal workaround for this is:

1. Increase the magnification to a very high level.
2. Change the node (In high mag view the unwanted changes scribus does are tiny small).
3. Change back the size.

Alternatively you can write the coordinates on paper for each point and just write them into X/Y.



Unfortunately you MUST click on the node. Would be good to navigate to them just by TAB. Would also be good to quit the selection of one dragged (and not yet dropped) node by pressing ESC. But we canĀ“t have all these things... ;-)

This Issue applies also to Scribus 1.4.2

Kunda

2016-01-15 20:18

manager   ~0038181

Hey GarryP, you work with Bezier Curves a lot. Have you encountered this bug recently ?

GarryP

2016-01-17 12:53

developer   ~0038216

I have plenty of issues with the node editor but I've never noticed a line or bezier move around on its own accord. I've used the node editor for hours at a time and haven't seen anything like this on either Linux (1.4.2/3?) or OSX (1.4.5).

One thing I have noticed is that if you move a control point outside the existing boundary of the shape, the X/Y/Width/Height values change accordingly, which seems strange to me.

For example, draw a rectangle, double-click to get the node editor, select "Move Control Points", drag a control point of the top-left corner of the rectangle to the left. You'll see the X and Width values change in the PP. Also, when you stop editing, the values in the PP reflect the maximum extents of both the nodes and control points of the shape rather than just the nodes which is what I'd expect. I wouldn't class the positions of the control points as being part of the position/size of the shape. This could be confusing. Maybe that's just me though.

The canvas has its own "granularity" that can cause nodes to jump to places you might not expect them to but you've got to be zoomed in quite far and the jump is nothing like the millimetre suggested, and it only affects the node you've dragged and not the whole line/bezier.

It might be helpful to know the exact value that the line has moved and what units the user is using at the time but I guess if it's happening "randomly" it might not be easy to get this info.

Kunda

2016-01-18 00:59

manager   ~0038228

Last edited: 2016-01-23 17:45

View 2 revisions

Garry, thanks for the reply. Do you mind creating a new bug report for the bug you mentioned above? Thanks!

Edit: Created GarryP's issue in new ticket 0013676

Kunda

2016-01-18 01:01

manager   ~0038229

Marking this as unabled to reproduce. We do need someone on windows to confirm the issue. But there is a high likelihood this is a non-issue. Please reopen if needed

Issue History

Date Modified Username Field Change
2008-11-24 12:52 Stu New Issue
2013-05-04 09:55 Marikus Note Added: 0030124
2013-05-04 09:56 Marikus Note Edited: 0030124 View Revisions
2013-05-04 13:57 Marikus Note Edited: 0030124 View Revisions
2013-05-04 14:07 Marikus Note Edited: 0030124 View Revisions
2013-05-04 14:08 Marikus Note Edited: 0030124 View Revisions
2013-05-04 22:04 jghali Relationship added has duplicate 0011519
2014-07-02 02:07 Kunda Target Version => 1.6 milestone
2014-07-14 04:12 Kunda Relationship added related to 0012347
2014-07-14 04:13 Kunda Relationship added child of 0012500
2014-07-14 04:53 Kunda Target Version 1.6 milestone => 1.5.1
2016-01-15 20:11 Kunda Patch => No
2016-01-15 20:11 Kunda Status new => confirmed
2016-01-15 20:18 Kunda Note Added: 0038181
2016-01-17 12:53 GarryP Note Added: 0038216
2016-01-18 00:59 Kunda Note Added: 0038228
2016-01-18 01:01 Kunda Note Added: 0038229
2016-01-18 01:01 Kunda Status confirmed => resolved
2016-01-18 01:01 Kunda Resolution open => unable to reproduce
2016-01-18 01:01 Kunda Assigned To => Kunda
2016-01-23 17:17 cbradney Target Version 1.5.1 => 1.5.3
2016-01-23 17:38 Kunda Target Version 1.5.3 => 1.5.1
2016-01-23 17:45 Kunda Note Edited: 0038228 View Revisions
2016-01-23 17:45 Kunda Relationship added related to 0013676
2016-02-13 19:51 cbradney Status resolved => closed