View Issue Details

IDProjectCategoryView StatusLast Update
0012277ScribusShape Drawingpublic2019-12-08 21:24
ReporterPancho Assigned Toale  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.4.3 
Target VersionFixed in Version1.5.6.svn 
Summary0012277: Simplify UI of even-odd vs. nonzero filling rules
DescriptionThe concepts of even-odd vs. nonzero filling rules are very complex. So is the tooltip. Nobody is going to understand from the mathematical definition what it is about.

So don't we rather want just a few words (and icons) helping the user identify what they might be looking for? Building upon good practice from Inkscape, I'd propose the following tooltip texts:

"Even-odd rule:
Any path self-intersections or enclosed subpaths create holes in the fill."

"Non-zero winding rule:
Fill is solid unless an enclosed subpath is counterdirectional."

I'd also propose using simple icons as present in Inkscape.
TagsNo tags attached.
Patch

Relationships

related to 0015811 closedale [PATCH] Indigo UI: shrink the "shape" tab of the properties palette 

Activities

Pancho

2014-04-23 23:25

reporter  

even-odd-inkscape.png (6,908 bytes)
even-odd-inkscape.png (6,908 bytes)

Pancho

2014-04-23 23:25

reporter  

nonzero-inkscape.png (6,281 bytes)
nonzero-inkscape.png (6,281 bytes)

Pancho

2014-04-23 23:26

reporter  

even-odd-karbon.png (7,947 bytes)
even-odd-karbon.png (7,947 bytes)

christoph_s

2014-04-24 05:52

administrator   ~0031799

You're absolutely right. I even refused to translate this because it's much too complicated. However, we're in string-freeze for 1.4.4, so if there will be a 1.4.5, I'll change it according to your suggestions. And it will be changed in 1.5.x/1.6.x once the new PP has been designed.

Kunda

2016-04-25 04:58

manager   ~0040456

Christoph, we assigning this to 1.4.7svn ?

ale

2019-11-09 11:33

manager   ~0047045

resolved with 15811

Issue History

Date Modified Username Field Change
2014-04-23 23:25 Pancho New Issue
2014-04-23 23:25 Pancho File Added: even-odd-inkscape.png
2014-04-23 23:25 Pancho File Added: nonzero-inkscape.png
2014-04-23 23:26 Pancho File Added: even-odd-karbon.png
2014-04-24 05:52 christoph_s Note Added: 0031799
2014-04-24 05:52 christoph_s Assigned To => christoph_s
2014-04-24 05:52 christoph_s Status new => acknowledged
2016-04-25 04:58 Kunda Note Added: 0040456
2019-09-06 17:20 ale Relationship added related to 0015811
2019-11-09 11:33 ale Assigned To christoph_s => ale
2019-11-09 11:33 ale Status acknowledged => resolved
2019-11-09 11:33 ale Resolution open => fixed
2019-11-09 11:33 ale Fixed in Version => 1.5.6.svn
2019-11-09 11:33 ale Note Added: 0047045
2019-12-08 21:24 cbradney Status resolved => closed