View Issue Details

IDProjectCategoryView StatusLast Update
0012534ScribusImport / Exportpublic2015-11-15 19:14
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0012534: native FileDialog
DescriptionQt managed filedialogs bookmarks are buggy (regularly forgotten)

Do we have to use non-native filedialogs ?

Steps To Reproducefollowing patch brings use of native filedialogs and systemwide bookmarks

Index: scribus/ui/scfilewidget.cpp
===================================================================
--- scribus/ui/scfilewidget.cpp (révision 19352)
+++ scribus/ui/scfilewidget.cpp (copie de travail)
@@ -18,7 +18,7 @@
 
 ScFileWidget::ScFileWidget(QWidget * parent) : QFileDialog(parent, Qt::Widget)
 {
- setOption(QFileDialog::DontUseNativeDialog);
+// setOption(QFileDialog::DontUseNativeDialog);
     setSizeGripEnabled(false);
     setModal(false);
     setViewMode(QFileDialog::List);

Are there any drawbacks ?
TagsNo tags attached.
Patch

Relationships

duplicate of 0012068 confirmed [Qt5 BUG] Open file dialog doesnt remember bookmarked folders 

Activities

JLuc

2014-07-17 09:39

developer   ~0032805

Note 1) The multi-tabs splash dialog is not changed with this patch. Some dedicated patch has to be done for it.

Note 2) Drawback with system-wide bookmarks is that they are system wide, and not specifically dedicated to scribus DTP work.
With Qt managed bookmarks, when they work, scribus user benefits of his DTP-work specifics bookmarks. This is an advantage when these specific bookmarks have been setup (and are not forgotten), but it is a drawback when opening scribus for the first time and having no bookmark at all.

ale

2014-07-17 11:01

manager   ~0032806

Last edited: 2014-07-17 11:01

View 2 revisions

after having removed the multi-tabs dialog from all my scribuses, i wonder if we really need it...

all in all, i don't miss it in any of the programs that don't have it and it only shines for annoyance in the ones that implement it (mostly poorly).

just my point of view...

JLuc

2014-07-17 12:36

developer   ~0032807

well, to be honnest, i like the multitab open dialog a lot. It's a powerfull central place to be ready for any-every SLA files related action. I wouldnt be chocked when it would become a non-modal window, available for any SLA file action at any time.

JLuc

2014-07-17 12:38

developer   ~0032808

but these tabs vs no-tabs discussions are a bit out of the subject of this report...

JLuc

2014-07-19 08:06

developer   ~0032829

Last edited: 2014-07-26 13:41

View 2 revisions

So as to bring systemwide bookmarks (= native filedialogs) to the splash open dialog, diff is :

Index: scribus/ui/newfile.cpp
===================================================================
--- scribus/ui/newfile.cpp (révision 19357)
+++ scribus/ui/newfile.cpp (copie de travail)
@@ -368,7 +368,7 @@
     fileDialog = new QFileDialog(openDocFrame, tr("Open"), docDir, formats);
     fileDialog->setFileMode(QFileDialog::ExistingFile);
     fileDialog->setAcceptMode(QFileDialog::AcceptOpen);
- fileDialog->setOption(QFileDialog::DontUseNativeDialog);
+// fileDialog->setOption(QFileDialog::DontUseNativeDialog);
     fileDialog->setNameFilterDetailsVisible(false);
     fileDialog->setReadOnly(true);
     fileDialog->setSizeGripEnabled(false);

This patch has to be added to the initial report one (it adds to it, not replace).
Its not perfect because with this patch, the native filedialog pops up off the multitab splash dialog instead of being opened inside it.

JLuc

2014-07-19 08:07

developer   ~0032830

These qt bookmarks issues make me feel like wanting a scribus option :
- yes/no : use system wide bookmarks / Qt managed bookmarks

JLuc

2014-07-26 13:42

developer   ~0033026

hacking 0012068

jghali

2014-07-26 13:46

administrator   ~0033028

Hack refused, breaks file dialogs on Windows and cause other issues on Ubuntu and OS X such as 0011996.

Kunda

2015-03-27 11:55

manager   ~0034770

Does this hack still break file dialogs on Windows and Ubuntu ?

jghali

2015-03-27 17:40

administrator   ~0034771

Yes, it still does.

jghali

2015-11-15 19:14

administrator   ~0037506

Closing as this is a duplicate of 0012068. And we won't use native file dialogs.

Issue History

Date Modified Username Field Change
2014-07-17 08:24 JLuc New Issue
2014-07-17 09:39 JLuc Note Added: 0032805
2014-07-17 11:01 ale Note Added: 0032806
2014-07-17 11:01 ale Note Edited: 0032806 View Revisions
2014-07-17 12:36 JLuc Note Added: 0032807
2014-07-17 12:38 JLuc Note Added: 0032808
2014-07-19 08:06 JLuc Note Added: 0032829
2014-07-19 08:07 JLuc Note Added: 0032830
2014-07-26 13:41 JLuc Note Edited: 0032829 View Revisions
2014-07-26 13:42 JLuc Note Added: 0033026
2014-07-26 13:46 jghali Note Added: 0033028
2015-03-27 11:55 Kunda Note Added: 0034770
2015-03-27 17:40 jghali Note Added: 0034771
2015-11-15 19:14 jghali Note Added: 0037506
2015-11-15 19:14 jghali Relationship added duplicate of 0012068
2015-11-15 19:14 jghali Status new => resolved
2015-11-15 19:14 jghali Resolution open => duplicate
2015-11-15 19:14 jghali Assigned To => jghali
2015-11-15 19:14 jghali Status resolved => closed