View Issue Details

IDProjectCategoryView StatusLast Update
0012901ScribusCanvaspublic2019-10-17 02:22
ReporterPeterBenedek Assigned Tojghali  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86OSLinux Mint OS Version17 (32bit)
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0012901: Resizing rotated Item leads to wrong positioning (X-Pos/Y-Pos values) on Canvas
DescriptionPositioning of rotated Items is not correct when applying specific resizing.

Screencast of the issue:
https://www.dropbox.com/s/sgj8zopgdzdors4/resize_rotated_object.avi?dl=0
Steps To Reproduce1) Insert an Item (eg Text Frame) on Canvas
2) Rotate the Item
3) Resize the Item moving the handle over the whole width/height (cursor goes beyond the opposite side) of the Item
4) Scribus places the item wrongly on Canvas (probably does not take into account current rotation of the Item)n
Additional Information1.5.1.svn (20577)
Very likely a long standing bug even with previous revisions.
Tags#pending, resize, rotate
PatchNo

Relationships

duplicate of 0012118 closedjghali Resizing rotated items going over 0 width/height behaves strangely 
related to 0013563 confirmed Resizing 2 items (one of which is rotated) leads to wrong canvas placement (semi-fixed) 
related to 0012177 closedfschmid Changing Arc height/width places the Arc out of the Frame + crash 
related to 0015854 closedjghali With a top right base point, a rotated item moves when the width changes 

Activities

JLuc

2015-02-01 11:13

developer   ~0034407

[EDIT / JLuc] : 2 issues here

1) when moving a rotated frame's border over the opposite border of the frame, the X,Y coordinates of the frame change when they shouldnt. The whole frame moves when only one of its border should move (reproduced here).

2) "scribus stopped" after a while (not tested here).

FirasH

2015-11-25 16:38

developer   ~0037678

Confirmed with 1.5.1.svn (20577).

Kunda

2016-01-23 21:11

manager   ~0038378

Last edited: 2016-05-03 11:56

View 3 revisions

Looks like 0012118 and this ticket are simliar or even duplicates

Kunda

2016-05-03 17:14

manager   ~0040748

This ticket needs to be cleaned up so we know what's still relevant.

Kunda

2016-05-19 13:57

manager   ~0041217

Hey Peter, do you mind cleaning up the ticket (seeing what's relevant).,. and perhaps merging it with 0012118 if needed ?

PeterBenedek

2016-05-19 14:03

developer   ~0041218

Last edited: 2016-05-19 14:04

View 2 revisions

Okay!

Thanks!

jghali

2019-10-17 02:21

administrator   ~0046790

Duplicate of 0012118

Issue History

Date Modified Username Field Change
2015-01-30 17:37 PeterBenedek New Issue
2015-02-01 11:13 JLuc Description Updated View Revisions
2015-02-01 11:13 JLuc Note Added: 0034407
2015-02-27 13:18 Kunda Priority normal => high
2015-02-27 13:18 Kunda Target Version => 1.5.1
2015-11-25 16:38 FirasH Note Added: 0037678
2015-11-25 16:38 FirasH Status new => confirmed
2015-11-25 16:41 FirasH Relationship added related to 0013563
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-01-23 21:11 Kunda Relationship added related to 0012118
2016-01-23 21:11 Kunda Note Added: 0038378
2016-01-23 21:12 Kunda Note Edited: 0038378 View Revisions
2016-01-24 10:00 Kunda Relationship added related to 0012177
2016-03-31 16:53 Kunda Tag Attached: resize
2016-05-03 11:52 Kunda Tag Attached: rotate
2016-05-03 11:56 Kunda Note Edited: 0038378 View Revisions
2016-05-03 17:14 Kunda Note Added: 0040748
2016-05-19 13:57 Kunda Note Added: 0041217
2016-05-19 13:57 Kunda Tag Attached: #pending
2016-05-19 14:03 PeterBenedek Note Added: 0041218
2016-05-19 14:04 PeterBenedek Note Edited: 0041218 View Revisions
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4
2017-06-23 10:46 FirasH Summary Rotated object after resizing incorrect x,y values => Resizing rotated Item leads to wrong positioning (X-Pos/Y-Pos values) on Canvas
2017-06-23 10:46 FirasH Description Updated View Revisions
2017-06-23 10:46 FirasH Steps to Reproduce Updated View Revisions
2017-06-23 10:48 FirasH Steps to Reproduce Updated View Revisions
2017-06-23 10:48 FirasH Additional Information Updated View Revisions
2019-10-15 18:19 PeterBenedek Relationship added has duplicate 0015854
2019-10-15 23:47 jghali Relationship deleted has duplicate 0015854
2019-10-15 23:47 jghali Relationship added related to 0015854
2019-10-17 02:21 jghali Assigned To => jghali
2019-10-17 02:21 jghali Status confirmed => resolved
2019-10-17 02:21 jghali Resolution open => duplicate
2019-10-17 02:21 jghali Note Added: 0046790
2019-10-17 02:21 jghali Relationship replaced duplicate of 0012118
2019-10-17 02:21 jghali Target Version 1.5.4 =>
2019-10-17 02:22 jghali Status resolved => closed