View Issue Details

IDProjectCategoryView StatusLast Update
0012118ScribusCanvaspublic2019-12-08 21:24
ReporterFirasH Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.4.3.svn 
Target Version1.5.4Fixed in Version1.5.6.svn 
Summary0012118: Resizing rotated items going over 0 width/height behaves strangely
DescriptionIf you resize a rotated element going over its opposite side, this element will be placed strangely on Canvas.
Steps To Reproduce0) Create a new document
1) Insert a Frame/Polygon
2) Rotate the Frame/Polygon with "Rotate Item" tool (with more rotation the issue is more visible)
3) Try to resize the element height/width going over the 0
(continue resizing going over the opposite side of the Frame/Polygon)

with Scribus 1.5.0 the "blue" preview on Canvas show exactly where the Frame/Polugon will be placed.

If the rotation is not applied, Scribus works as expected.
Additional InformationIssue present on:
Scribus 1.4.3 (18865) - Qt 4.8.5
Scribus 1.5.0 (18868) - Qt 5.2.1
Tagsresize, rotate
PatchNo

Relationships

related to 0010678 confirmed Resizing rotated items moving handles does not snap to Guides 
related to 0003612 closedjghali Changing width or height of rotated items behaves inconsistently depending on basepoint 
related to 0013676 closedjghali move a control point outside the existing boundary of shape = changes X & width values in PP 
has duplicate 0012901 closedjghali Resizing rotated Item leads to wrong positioning (X-Pos/Y-Pos values) on Canvas 
related to 0013563 confirmed Resizing 2 items (one of which is rotated) leads to wrong canvas placement (semi-fixed) 
related to 0012177 closedfschmid Changing Arc height/width places the Arc out of the Frame + crash 
related to 0008860 closedFirasH Resizing with Alt or Alt+Shift and arrows is wrong when rotation is applied to an Item 
related to 0009113 closed Rotated frames are poorly editable 
related to 0014390 confirmed Resizing with Alt+Shift+Arrow going under 0 Width/Height leads to wrongly managed Item size 

Activities

FirasH

2014-05-15 13:22

developer   ~0031853

Screencast of the issue:
https://www.dropbox.com/s/2k36xxvlk46ccsp/FlippedFramesResize.mp4

Kunda

2014-07-25 02:46

manager   ~0032978

Confirmed on OSX 10.8.5 1.5svn r19366 (Qt5.3.1)

Mazoon

2015-10-28 11:30

reporter   ~0037035

Last edited: 2015-11-04 10:38

View 4 revisions

EDIT: after looking at the code my previous assumptions were "very" wrong.
It seems that it is related to issue 0003612.

Kunda

2016-01-23 20:57

manager  

polygon-issues-test.gif (235,845 bytes)
polygon-issues-test.gif (235,845 bytes)

PeterBenedek

2019-10-17 08:06

developer   ~0046791

Tested in Linux Mint 19.x

-- Make object (TextFrame)
-- Rotate 90 or 270 degrre
-- Resize object

The result is ok, but preview is wrong.

resize_rotate.gif (212,840 bytes)
resize_rotate.gif (212,840 bytes)

jghali

2019-10-18 06:50

administrator   ~0046794

Last edited: 2019-10-22 05:28

View 2 revisions

Fixed

PeterBenedek

2019-10-22 05:32

developer   ~0046818

Tested in r23266

I can't reproduce anymore. Works well!
Thanks Jean.

Issue History

Date Modified Username Field Change
2014-03-04 18:37 FirasH New Issue
2014-05-15 13:22 FirasH Note Added: 0031853
2014-07-25 02:44 Kunda Summary Resizing rotated Frames/Polygons beaves strangely => Resizing rotated Frames/Polygons behaves strangely
2014-07-25 02:46 Kunda Note Added: 0032978
2014-07-25 02:46 Kunda Status new => confirmed
2014-07-25 02:46 Kunda Target Version => 1.5.1
2015-10-28 11:30 Mazoon Note Added: 0037035
2015-10-28 11:32 Mazoon Note Edited: 0037035 View Revisions
2015-10-29 05:18 Mazoon Note Edited: 0037035 View Revisions
2015-10-29 19:14 Kunda Relationship added related to 0010678
2015-11-04 10:38 Mazoon Note Edited: 0037035 View Revisions
2015-11-04 11:50 Kunda Relationship added related to 0003612
2015-11-25 16:41 FirasH Relationship added related to 0013563
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-01-23 19:37 Kunda Relationship added related to 0013676
2016-01-23 20:49 Kunda File Added: polygon-issues.gif
2016-01-23 20:50 Kunda File Deleted: polygon-issues.gif
2016-01-23 20:57 Kunda File Added: polygon-issues-test.gif
2016-01-23 21:02 Kunda Relationship added related to 0012177
2016-01-23 21:11 Kunda Relationship added related to 0012901
2016-01-23 21:13 Kunda Relationship added related to 0008860
2016-03-31 16:51 Kunda Tag Attached: resize
2016-04-06 22:24 Kunda Tag Attached: rotate
2016-05-21 13:01 Kunda Relationship added related to 0009113
2016-11-27 21:13 FirasH Relationship added related to 0014390
2016-11-27 21:15 FirasH Summary Resizing rotated Frames/Polygons behaves strangely => Resizing rotated Items going over 0 Width/Height behaves strangely
2016-11-27 21:15 FirasH Patch => No
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4
2019-10-16 11:30 jghali Summary Resizing rotated Items going over 0 Width/Height behaves strangely => Resizing rotated items going over 0 width/height behaves strangely
2019-10-17 01:37 jghali Assigned To => jghali
2019-10-17 01:37 jghali Status confirmed => resolved
2019-10-17 01:37 jghali Resolution open => fixed
2019-10-17 01:37 jghali Fixed in Version => 1.5.6.svn
2019-10-17 02:21 jghali Relationship replaced has duplicate 0012901
2019-10-17 08:06 PeterBenedek File Added: resize_rotate.gif
2019-10-17 08:06 PeterBenedek Note Added: 0046791
2019-10-17 08:34 PeterBenedek File Added: unexpected.gif
2019-10-18 06:01 PeterBenedek Status resolved => feedback
2019-10-18 06:01 PeterBenedek Resolution fixed => reopened
2019-10-18 06:50 jghali Note Added: 0046794
2019-10-18 06:59 jghali Status feedback => resolved
2019-10-18 06:59 jghali Resolution reopened => fixed
2019-10-22 05:28 PeterBenedek Note Edited: 0046794 View Revisions
2019-10-22 05:32 PeterBenedek Note Added: 0046818
2019-10-22 05:32 PeterBenedek File Deleted: unexpected.gif
2019-12-08 21:24 cbradney Status resolved => closed