View Issue Details

IDProjectCategoryView StatusLast Update
0013104ScribusCanvaspublic2016-01-14 14:47
ReporterAlmaTlust Assigned To 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionduplicate 
PlatformKDEOSKubuntuOS Version15.04
Product Version 
Target VersionFixed in Version 
Summary0013104: random switching between open documents
DescriptionSometimes when performing actions, scribus switches between open documents, i.o.w the one I'm working on is put to the background and another one comes up front. Of course the action is not performed.
When taking the document I'm working on to the front and repeating the action, everything works.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0012204 closedjghali Opening/Closing Properties palette tabs moves the view to the first document (2+ document Tabs) 

Activities

Kunda

2015-06-01 19:23

updater   ~0035304

Can you provide a step-by-step way to reproduce the behavior? Thanks Alma

AlmaTlust

2015-06-02 07:11

reporter   ~0035308

Last edited: 2015-06-02 07:12

View 2 revisions

I actually can't as it appears randomly, although pretty frequently. Pretty much every time I have two or more documents open, at some point scribus switches focus. Last time it was when I changed the thickness of a line, but I could not reproduce it the next time. Also, since yesterday (Update to Plasma 5.3.1), Scribus crashes when trying to open a recent document...

AlmaTlust

2015-06-23 16:22

reporter   ~0035488

I found a reproducable case: Open the first document, open another document (via "recent documents". Press F2 to open the palette, click twice on "drop shadow" quickly - voila, suddenly the first document is in the front.

AlmaTlust

2015-06-23 16:23

reporter   ~0035489

It doesn't even be quickly, and any tab, just click it twice, and the first document comes to the front.

cbradney

2015-06-23 21:03

administrator   ~0035490

What version of Scribus are you running?

AlmaTlust

2015-06-24 05:51

reporter   ~0035492

1.5.0 from the ubuntu repositories. I can try to reproduce with 1.5.1 svn from the Scribus friends ppa as well if you like.

Kunda

2015-10-12 00:42

updater   ~0036643

Alma, can you try to reproduce on 1.5.1 please ?

ale

2015-10-12 09:10

manager   ~0036649

i think that i have a guess on what is happening...

but i cannot reproduce with the 1.5.0 dmg

if you an item selected in the other document, when you apply a change to the item it will focus on the selected item on the other document.

1.5.0 correctly disables the properties palette, when no item is selected in the current document.
the version almatlust is using might not do that (i somehow recall it being a past bug...)

AlmaTlust

2015-10-12 09:10

reporter   ~0036650

Yes, it's still there... although it can take up to four clicks on different tabs until it switches to the first document.

AlmaTlust

2015-10-12 11:22

reporter   ~0036652

Just checked. It does not matter whether you have selected any object in the first document or not. Also, the properties palette is disabled when nothing is selected.

Of course you have to select something in the second document to be able to use the properties palette there... ;-)

Kunda

2016-01-13 18:49

updater   ~0038121

alma, do you mind merging any relevant info from this ticket in to 0012204 and then I'll close this bug.

AlmaTlust

2016-01-14 08:46

reporter   ~0038150

Kunda, I think I have added all relevant information to 0012204, you can close this one. (btw, how do you insert the link to a different bug?)

Kunda

2016-01-14 14:47

updater   ~0038155

Thank Alma

put a # in front of the different bug number, 0012204
if you want to reference a thread comment, put a ~ in front of the specific comment number, so you're previous comment was 38150 then adding ~ in front of it produces 0013104:0038150

Issue History

Date Modified Username Field Change
2015-06-01 13:36 AlmaTlust New Issue
2015-06-01 19:23 Kunda Note Added: 0035304
2015-06-02 07:11 AlmaTlust Note Added: 0035308
2015-06-02 07:12 AlmaTlust Note Edited: 0035308 View Revisions
2015-06-23 16:22 AlmaTlust Note Added: 0035488
2015-06-23 16:23 AlmaTlust Note Added: 0035489
2015-06-23 21:03 cbradney Note Added: 0035490
2015-06-24 05:51 AlmaTlust Note Added: 0035492
2015-10-12 00:42 Kunda Note Added: 0036643
2015-10-12 09:10 ale Note Added: 0036649
2015-10-12 09:10 AlmaTlust Note Added: 0036650
2015-10-12 11:22 AlmaTlust Note Added: 0036652
2016-01-12 06:21 Kunda Relationship added duplicate of 0012204
2016-01-13 18:49 Kunda Note Added: 0038121
2016-01-14 08:46 AlmaTlust Note Added: 0038150
2016-01-14 14:47 Kunda Note Added: 0038155
2016-01-14 14:47 Kunda Status new => closed
2016-01-14 14:47 Kunda Resolution open => duplicate