View Issue Details

IDProjectCategoryView StatusLast Update
0013204ScribusUsabilitypublic2016-05-15 22:53
Reporterrobhagemans Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD64OSUbuntuOS Version15.04
Product Version1.5.0 
Target VersionFixed in Version1.5.2.svn 
Summary0013204: Unusably tiny tool icons on HiDPI screen on Ubuntu Unity desktop
DescriptionI am using Scribus on Ubuntu 15.04 x68_64, Unity desktop with a 13-inch 3200x1800 display. Unity interface scaling settings set to 2x.

While text appears in readable size, icons in the toolbar do not scale correctly, leaving the toolbar icons less than 2 millimetres in size on my screen.

The result is poor usability due to the need to squint and look very close to the monitor to be able to select a tool.

Expected result would be for icons to be of a usable size on a high-DPI screen automatically or for an icon size setting to be provided.

Thank you very much for Scribus!
Steps To Reproduce1. Use a 3200x1800 display
2. System Settings/All Settings/Display/Scale for menu and title bars: set to 2
3. Install Scribus 1.5.0 on Ubuntu:
  sudo add-apt-repository ppa:scribus/ppa
  sudo apt-get update
  sudo apt-get install scribus-ng
4. Start scribus-ng and look at toolbar of main window.
TagsHiDPI, Qt5.6
PatchNo

Relationships

related to 0013179 closedcbradney GNOME: Please provide a bigger icon for Scribus (for HiDPI screen) 
related to 0013818 new HiDPI workaround: Ability to change Scribus UI icons size via right mouse button 
related to 0013255 closed Menus broken on high resolution screen 
related to 0014004 closedcbradney Improve Canvas rendering on Hi-DPI screens 
related to 0014023 closed 1.5.2svn HiDPI GUI font too small 

Activities

Kunda

2015-07-07 02:00

updater   ~0035678

related 0013179

Kunda

2015-07-16 23:30

updater   ~0035811

So does this mean that we need to generate a whole host of icons for higher res screens ?

robhagemans

2015-07-17 08:13

reporter   ~0035818

From a usability point of view, just allowing the icons to be scaled with the desktop scaling setting (that may be a Unity rather than GTK thing) would do the trick I think. Of course hi res icons would look nicer but scaling may be a quicker fix.

user5030

2015-08-04 03:13

  ~0035964

This is also an issue on my 4k monitor. I agree that it is important for Scribus to add support for hidpi displays. Using scalable svg icons would be the best approach, but for now having an option to scale the UI icons up would already be a major improvement.

Kunda

2016-02-02 19:13

updater   ~0038539

Hey folks, can you test how the new iconset looks like on a HiDPI screen ?
I think you will need to install trunk to test it.

Kunda

2016-03-09 13:11

updater   ~0039081

please test on 1.5.1

Kunda

2016-03-10 13:38

updater   ~0039101

Also https://www.phoronix.com/scan.php?page=news_item&px=Cross-Platform-HiDPI-Qt-5.6

robhagemans

2016-03-19 09:18

reporter   ~0039260

Hi, thanks for the update. I've tested on Scribus Version 1.5.2.svn (scribus-trunk in Ubuntu 15.04) with a Dell XPS 13 HiDPI screen. It's certainly an improvement as the icons are crisper and therefore easier to distinguish.

They remain very small though and still require me to come very close to the screen to be able to select a tool button - it appears they do not scale with the rest of the desktop.

Kunda

2016-03-19 13:09

updater   ~0039265

Glad that helped you some.

Qt HiDPI is still very new and a lot of opensource projects that use Qt are still scratching their heads trying to figure out how they've implemented it.

Created feature request 0013818 maybe a 3rd party dev would like to have a hand at it since the main devs do have their hands full.

user5122

2016-05-02 13:25

  ~0040703

Have you tried to set QT_AUTO_SCREEN_SCALE_FACTOR (Qt 5.6+) or QT_DEVICE_PIXEL_RATIO (Qt 5.4 and 5.5)?

Kunda

2016-05-02 13:36

updater   ~0040704

Khaled, are you saying to assign to set them as env variables ?
export QT_AUTO_SCREEN_SCALE_FACTOR=1

Or in the code ?

user5122

2016-05-02 15:21

  ~0040708

Environment variables. We c also set Qt::AA_EnableHighDpiScaling attribute to QApplication (http://doc.qt.io/qt-5/qt.html#ApplicationAttribute-enum) so that this environment variable is not needed, but I didn’t find the right place in the code to set it.

user5122

2016-05-02 15:30

 

0001-Enable-Hi-DPI-support.patch (793 bytes)
From e6e068ef5897c25fdb03aad6e61b4f581ca9cb23 Mon Sep 17 00:00:00 2001
From: Khaled Hosny <khaledhosny@eglug.org>
Date: Mon, 2 May 2016 17:26:25 +0200
Subject: [PATCH] Enable Hi-DPI support

This should make it work without needing to set an environment variable:
http://doc.qt.io/qt-5/qtlabscontrols-highdpi.html
---
 scribus/main_nix.cpp | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/scribus/main_nix.cpp b/scribus/main_nix.cpp
index 503d756..8b9f710 100644
--- a/scribus/main_nix.cpp
+++ b/scribus/main_nix.cpp
@@ -68,6 +68,9 @@ int mainApp(int argc, char **argv)
 {
 	emergencyActivated=false;
 
+#if QT_VERSION >= 0x050600
+	ScribusQApp::setAttribute(Qt::AA_EnableHighDpiScaling);
+#endif
 	ScribusQApp app(argc, argv);
 	initCrashHandler();
 	app.parseCommandLine();
-- 
2.8.2

user5122

2016-05-02 15:31

  ~0040709

Here is a patch that enables Hi-DPI support on X11 without needing to set an environment variables. Based on: http://doc.qt.io/qt-5/qtlabscontrols-highdpi.html

Kunda

2016-05-02 21:03

updater   ~0040731

Franz committed Khaled's patch in r21275
HiDPI testers needed to confirm

Kunda

2016-05-02 21:38

updater   ~0040735

jghali committed the windows counterpart in r21277

Kunda

2016-05-15 02:25

updater   ~0041066

andreasn1, can you check this on Fedora or even better Ubuntu ?

Issue History

Date Modified Username Field Change
2015-07-05 12:24 robhagemans New Issue
2015-07-07 02:00 Kunda Note Added: 0035678
2015-07-07 02:01 Kunda Relationship added related to 0013179
2015-07-16 23:30 Kunda Note Added: 0035811
2015-07-17 08:13 robhagemans Note Added: 0035818
2015-07-29 21:05 cbradney Relationship added related to 0013255
2015-08-04 03:13 user5030 Note Added: 0035964
2016-02-02 19:13 Kunda Note Added: 0038539
2016-03-09 13:10 Kunda Tag Attached: HiDPI
2016-03-09 13:11 Kunda Note Added: 0039081
2016-03-10 13:38 Kunda Note Added: 0039101
2016-03-10 13:56 Kunda Tag Attached: Qt5.6
2016-03-19 09:18 robhagemans Note Added: 0039260
2016-03-19 13:06 Kunda Relationship added related to 0013818
2016-03-19 13:09 Kunda Note Added: 0039265
2016-05-02 13:25 user5122 Note Added: 0040703
2016-05-02 13:36 Kunda Note Added: 0040704
2016-05-02 14:03 Kunda Relationship added related to 0014004
2016-05-02 15:21 user5122 Note Added: 0040708
2016-05-02 15:30 user5122 File Added: 0001-Enable-Hi-DPI-support.patch
2016-05-02 15:31 user5122 Note Added: 0040709
2016-05-02 20:59 fschmid Status new => resolved
2016-05-02 20:59 fschmid Fixed in Version => 1.5.2.svn
2016-05-02 20:59 fschmid Resolution open => fixed
2016-05-02 20:59 fschmid Assigned To => fschmid
2016-05-02 21:03 Kunda Note Added: 0040731
2016-05-02 21:38 Kunda Note Added: 0040735
2016-05-04 20:49 Kunda Relationship added related to 0014023
2016-05-15 02:25 Kunda Note Added: 0041066
2016-05-15 22:53 cbradney Status resolved => closed