View Issue Details

IDProjectCategoryView StatusLast Update
0013596ScribusOS-MacOSXpublic2015-12-22 21:05
Reporterstansanderson Assigned To 
Status closedResolutionduplicate 
PlatformAppleOSMacintoshOS Version10.11.2 (El Capi
Product Version1.4.5 
Summary0013596: [1.4.5] Render Frames does not work out of the box, needs to be set manually
DescriptionThe Preference file (Library>Preferences>Scribus>scribus 140.rc) shows [LatexEditor="/Library/TeX/texbin/LaTeX"] which apparently takes me to the appropriate directory, since adding "pdflatex --interaction nonstop mode" fires up

kpathsea: Running mktexfmt LaTeX.fmt
mktexfmt: mktexfmt is using the following fmtutil.cnf files (in precedence order):
mktexfmt: /usr/local/texlive/2015/texmf-dist/web2c/fmtutil.cnf
mktexfmt: mktexfmt is using the following fmtutil.cnf file for writing changes:
mktexfmt: /Users/ssanders/Library/texlive/2015/texmf-config/web2c/fmtutil.cnf
mktexfmt [INFO]: Disabled formats: 10
mktexfmt [INFO]: Not selected formats: 46
I can't find the format file `LaTeX.fmt'

Steps To ReproduceOpen Scribus. On a new page, select the "Render Frame" tool and draw a render frame box. The message "Render Error" is shown in the box and an error message:
The application "pdflatex --interaction nonstop mode" failed to start! Please check the path: "

However, no path is shown.
Additional InformationScribus was installed from a disk image downloaded from SourceForge. I also verified that version 1.4.5 installed through MacPorts behaves in the same manner. Scribus 1.5.0 from SourceForge also does not find the correct path.

OS 10.11 SIP (system integrity protection) has not been disabled. TeXShop, TeXLive, TeXStudio are installed and working; I've tried to use their paths to pdflatex for Scribus in the Scribus>Preferences>Tools pane, both by using the change command dialog and change external tool commands with no success.

Administrator Kunda asked me to post this to the bug list. I would be happy to provide more information if needed.
TagsNo tags attached.


duplicate of 0009282 assignedcbradney Check for Render frame dependencies 



2015-12-22 13:13

updater   ~0037961

Running 1.4.5 on OSX 10.10.5
Render Frames does not work out of the box
I needed to go in to
Prefrences > External Tools > Render Frames
Choose LaTeX > Command Change
and then use the whole path to pdflatex as such:
/usr/texbin/pdflatex --interaction nonstopmode


2015-12-22 15:33

reporter   ~0037962

For OS 10.11.2 with SIP enabled (default), I followed the above suggestion but again it produced no result. However, since the terminal query "which pdflatex" returned
I entered

/Library/TeX/texbin/pdflatex "--interaction nonstopmode"

(note quotes!) and the render frame is now working. I have not yet tried this with Scribus 1.5.

Thanks to Kunda for the suggestion.


2015-12-22 16:57

updater   ~0037965

stansanderson, thanks for the follow-up. sorry for the delay in response.

Note: Craig recently hardcoded a path in the 'External Tools' for OSX for another tool...and I'm trying to find that ticket and link it to this one.


2015-12-22 21:05

updater   ~0037975

This is a duplicate of 0009282

Issue History

Date Modified Username Field Change
2015-12-09 15:59 stansanderson New Issue
2015-12-10 16:16 Kunda Target Version => 1.4.6
2015-12-22 13:13 Kunda Note Added: 0037961
2015-12-22 15:33 stansanderson Note Added: 0037962
2015-12-22 16:57 Kunda Note Added: 0037965
2015-12-22 16:59 Kunda Summary Render Frame path not set, can't find one that is suitable => [1.4.5] Render Frames does not work out of the box, needs to be set manually
2015-12-22 17:00 Kunda Category Integration => OS-MacOSX
2015-12-22 17:00 Kunda Assigned To => cbradney
2015-12-22 17:00 Kunda Status new => assigned
2015-12-22 21:00 Kunda Relationship added child of 0009282
2015-12-22 21:04 Kunda Relationship replaced duplicate of 0009282
2015-12-22 21:05 Kunda Note Added: 0037975
2015-12-22 21:05 Kunda Status assigned => closed
2015-12-22 21:05 Kunda Assigned To cbradney =>
2015-12-22 21:05 Kunda Resolution open => duplicate
2015-12-22 21:05 Kunda Target Version 1.4.6 =>