View Issue Details

IDProjectCategoryView StatusLast Update
0001368ScribusStory Editor / Text Framespublic2006-05-07 12:29
Reporterlouisdesjardins Assigned Toavox  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSMandrakeOS Version10
Product Version1.2.1cvs 
Target VersionFixed in Version1.3.4cvs 
Summary0001368: Justified or right aligned text is misaligned when hyphenated
DescriptionSome hyphens just pop out of the text frame or out of the column (in the gutter) when text is justified (or right aligned) and hyphenated. This happens with a variety of fonts. There doesn't seem to be a pattern. One or a few hyphens will misalign when text is hyphenated.

To a lesser degree, the same will occur with commas and periods, although these will fall short and will not *hang*.

The result is justified blocks of text that are not perfectly aligned.
Steps To Reproduce(Quite a few paragraphs might be needed to see the problem.)
1. Import any text in a text frame, justify or right align it, and hyphenate it.
2. Draw a guide to help see the *hanging* hyphens.


This will happen using (seems to):
a) any font (not always at the same lines) 0f course ;-)
b) any face (same with italic, bold, bold italic)
c) any language (tried with French, English, Polish. Same result).
d) it doesn't matter wether text is formatted with stylesheet or not.
Additional InformationThe problem will show on screen and on PDF.
TagsNo tags attached.
Patch

Relationships

child of 0003828 acknowledged Metabug: Hyphenation 

Activities

louisdesjardins

2004-12-11 16:33

developer   ~0003103

Just realized bug 0001192 states the same issue.
Actual 0001368 gives only further explanations/details.
These bugs should be merged.
IMO, the 0001368 title seems to me a bit more self-explanatory.

louisdesjardins

2005-01-15 14:42

developer   ~0003481

In Jan. 8, 2005 build, the issue is still present.
Tested only with justified text.
I have a screenshot ready.

2005-01-15 14:43

 

hypheninmargin.png (317,842 bytes)
hypheninmargin.png (317,842 bytes)

louisdesjardins

2005-01-15 14:44

developer   ~0003482

First hyphen is OK.
Second one is in the margin (scroll down)

2005-08-17 10:27

 

test13.sla (427,363 bytes)

cweber

2005-08-17 10:29

reporter   ~0006140

Problem persists in 1.3.1cvs and 1.2.2. See attached test13.sla

plinnell

2005-08-17 23:02

viewer   ~0006145

I tested this with a variety of fonts and all text aligment possibilities. No issue here with 1.2.3cvs, nor 1.3.1cvs.

plinnell

2005-08-26 12:54

viewer   ~0006239

reopened for more discussion. probably a local issue

2005-08-26 13:09

 

1368-131a.png (245,990 bytes)
1368-131a.png (245,990 bytes)

fschmid

2005-08-26 13:50

administrator   ~0006240

Closing this again, as i think the bugtracker is not the right place to start a discussion about a local issue. Thats more a thing for the mailing list or IRC. Its rather confusing for me to have reopened bugs just for the sake of discussion.

plinnell

2005-08-26 17:57

viewer   ~0006241

Sorry Franz, original reporter mailed Craig off-list after installing 1.3.1cvs and I got CC'd to double check the fix. You are correct this is not the usual place for discussion, but perhaps the new version of mantis will allow comments for everyone even when a bug is closed.

Now, I am *certain* this is fixed and should stay closed.

In IRC this afternoon, I asked Alessandro Rimaldi to do an extensive test on his ppc gentoo system. He confirmed to me the bug was indeed fixed with a pile of different fonts.

Further, I did more tests both on the alpha Win32 build and OSX with completely different fonts, just to take platform out of the question. It behaves exactly as I would expect. I could be proven wrong, but I cannot really spend more time on this.

avox

2006-05-04 20:44

administrator   ~0010922

Looks like this one raised its ugly head again...

Apperently it appears for full lines.

2006-05-05 22:06

 

Document-om.pdf (75,007 bytes)

avox

2006-05-06 00:28

administrator   ~0010993

Also added optical margins, see attached PDF

Issue History

Date Modified Username Field Change
2004-12-09 03:55 louisdesjardins New Issue
2004-12-11 16:33 louisdesjardins Note Added: 0003103
2004-12-11 22:03 cbradney Status new => assigned
2004-12-11 22:03 cbradney Assigned To => fschmid
2005-01-03 12:12 cbradney Status assigned => resolved
2005-01-03 12:12 cbradney Fixed in Version => 1.2.1cvs
2005-01-03 12:12 cbradney Resolution open => fixed
2005-01-04 12:20 cbradney Status resolved => closed
2005-01-15 14:42 louisdesjardins Status closed => feedback
2005-01-15 14:42 louisdesjardins Resolution fixed => reopened
2005-01-15 14:42 louisdesjardins Note Added: 0003481
2005-01-15 14:43 louisdesjardins File Added: hypheninmargin.png
2005-01-15 14:44 louisdesjardins Note Added: 0003482
2005-08-17 10:27 cweber File Added: test13.sla
2005-08-17 10:29 cweber Note Added: 0006140
2005-08-17 23:02 plinnell Note Added: 0006145
2005-08-17 23:02 plinnell Status feedback => resolved
2005-08-17 23:02 plinnell Resolution reopened => fixed
2005-08-26 12:54 plinnell Status resolved => feedback
2005-08-26 12:54 plinnell Resolution fixed => reopened
2005-08-26 12:54 plinnell Note Added: 0006239
2005-08-26 13:09 plinnell File Added: 1368-131a.png
2005-08-26 13:50 fschmid Status feedback => resolved
2005-08-26 13:50 fschmid Resolution reopened => fixed
2005-08-26 13:50 fschmid Note Added: 0006240
2005-08-26 17:57 plinnell Note Added: 0006241
2005-08-26 17:58 plinnell Status resolved => closed
2006-05-04 20:44 avox Assigned To fschmid => avox
2006-05-04 20:44 avox Status closed => feedback
2006-05-04 20:44 avox Resolution fixed => reopened
2006-05-04 20:44 avox Note Added: 0010922
2006-05-04 20:45 avox Status feedback => assigned
2006-05-05 22:06 avox File Added: Document-om.pdf
2006-05-06 00:28 avox Status assigned => resolved
2006-05-06 00:28 avox Fixed in Version 1.2.1cvs => 1.3.4cvs
2006-05-06 00:28 avox Resolution reopened => fixed
2006-05-06 00:28 avox Note Added: 0010993
2006-05-07 12:29 mhanski Status resolved => closed
2006-05-16 21:44 christoph_s Relationship added child of 0003828
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames