View Issue Details

IDProjectCategoryView StatusLast Update
0014840ScribusImport / Exportpublic2019-06-04 20:56
Reporterchristoph_s Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.3 
Target VersionFixed in Version1.5.4.svn 
Summary0014840: Exporting embedded pdf file sometime produces incorrect result
DescriptionI have attached a "Collect for Output" sample which includes the original SLA file, as well as the PDFs imported into image frames. The PDFs have been created with Scribus in A5 minus the crop mark space and exported with crop marks, so that the final page size, including crop marks was still A5.

The next step was to align the PDFs on an A3 page, using guides, image frames and the embed option in the PDF export dialog. This worked very well. However, the crop marks in the resulting PDF don't look as expected.
Steps To ReproduceOpen the attached SLA file and export it with the 'EPS' "embedding" option enabled. Open it in a PDF viewer and look at the crop marks. Something doesn't add up here.
TagsNo tags attached.
PatchNo

Relationships

has duplicate 0015113 closedjghali Exporting embedded pdf file with ArtBox != MediaBox. 

Activities

christoph_s

2017-06-02 06:27

administrator  

crop_marks.7z (1,016,199 bytes)

utnik

2017-06-02 18:56

updater   ~0043982

in the file 'bogen12' i don't see any crop marks. is that what's wrong in your eyes?

it looks as scribus would just load the content of the trimbox – i don't know if this is the expected behavior, but at least it isn't designed as an impositioning tool…

jghali

2017-06-05 09:33

administrator   ~0043999

Last edited: 2017-06-05 09:33

View 2 revisions

When importing PDF into an image frame, Scribus uses the PDF ArtBox which is kind of a "zone of interest" in PDF. Crop marks and other marks are usually outside this zone. So current behavior is expected. As utnik mentioned it, Scribus is not an imposition tool. However on export, the imported PDF was clearly wrongly cropped and offset. I fixed that in r22052.

christoph_s, is there anything else to fix?

christoph_s

2017-06-08 06:54

administrator   ~0044013

Jean, for this particular purpose, using Scribus as an imposition tool was the ideal solution. It was no coincidence that I used image frames plus PDF embedding, because it is incredibly fast. With your latest change, I don't get crop marks at all in the final PDF.

IMHO, there should be a dialogue with options similar to direct PDF-import when it comes to embedding PDFs, i.e.: Media Box, Trim Box, Art Box, Crop Box, Bleed Box.

u ltd.

2018-01-29 01:11

reporter   ~0044887

In r22360 the bug still exists.
See uploaded files.

Simple_Box_im_PDF_editiert.pdf (9,935 bytes)
Testdokument.pdf (19,991 bytes)
Testdokument.sla (15,372 bytes)
TUUWI-Logo--hochkant-weiss.pdf (330,279 bytes)

u ltd.

2018-01-29 01:14

reporter   ~0044888

(So Testdokument.sla imports TUUWI-Logo--hochkant-weiss.pdf and Simple_Box_im_PDF_editiert.pdf)

TUUWI-Logo--hochkant-weiss.pdf has a perfect ArtBox, I checked that with Inkscape and the pdf text.
Simple_Box_im_PDF_editiert.pdf has not a perfect ArtBox (The red borders are cut I think).

jghali

2018-02-01 13:09

administrator   ~0044898

I have committed an additional fix in r22362. I'm going to resolve this issue now as PDF box choice is explicitly the subject of issue 0015114.

u ltd.

2018-02-06 07:44

reporter   ~0044925

Thank you, now it's working.

Issue History

Date Modified Username Field Change
2017-06-02 06:27 christoph_s New Issue
2017-06-02 06:27 christoph_s Status new => assigned
2017-06-02 06:27 christoph_s Assigned To => jghali
2017-06-02 06:27 christoph_s File Added: crop_marks.7z
2017-06-02 18:56 utnik Note Added: 0043982
2017-06-05 09:33 jghali Note Added: 0043999
2017-06-05 09:33 jghali Note Edited: 0043999 View Revisions
2017-06-08 06:54 christoph_s Note Added: 0044013
2018-01-28 19:38 jghali Relationship added has duplicate 0015113
2018-01-29 01:11 u ltd. File Added: Simple_Box_im_PDF_editiert.pdf
2018-01-29 01:11 u ltd. File Added: Testdokument.pdf
2018-01-29 01:11 u ltd. File Added: Testdokument.sla
2018-01-29 01:11 u ltd. File Added: TUUWI-Logo--hochkant-weiss.pdf
2018-01-29 01:11 u ltd. Note Added: 0044887
2018-01-29 01:14 u ltd. Note Added: 0044888
2018-02-01 13:03 jghali Summary Incorrect display and print of crop marks => Exporting embedded pdf file sometime produces incorrect result
2018-02-01 13:09 jghali Status assigned => resolved
2018-02-01 13:09 jghali Resolution open => fixed
2018-02-01 13:09 jghali Fixed in Version => 1.5.4.svn
2018-02-01 13:09 jghali Note Added: 0044898
2018-02-06 07:44 u ltd. Note Added: 0044925
2019-06-04 20:56 cbradney Status resolved => closed