View Issue Details

IDProjectCategoryView StatusLast Update
0001494ScribusImport / Exportpublic2005-06-28 19:16
Reportercniehaus Assigned Tocbradney  
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
PlatformGentoo LinuxOSGentoo LinuxOS Version2.6.9
Product Version1.2.1cvs 
Target VersionFixed in Version 
Summary0001494: Scribus crashes on Attached file (pdf-export)
DescriptionAfter exporting the file to pdf scribus crashed. I cannot reproduce but the file looks now pretty strange. The second textframe on page one was on the empty page. The .svg's have been done with Inkscape 0.39. I am using KDE 3.3.2 and Qt 3.3.3.
Additional InformationProgram received signal SIGSEGV, Segmentation fault.
(gdb) bt
#0 0x081d2dde in Page::slotDoCurs(bool) (this=0x86c51a0, draw=false)
    at page.cpp:6703
0000001 0x081a34f4 in Page::paintEvent(QPaintEvent*) (this=0x86c51a0, e=0xbfffeac0)
    at page.cpp:478
0000002 0x40585ece in QWidget::event(QEvent*) () from /usr/qt/3/lib/libqt-mt.so.3
0000003 0x404f38ef in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/qt/3/lib/libqt-mt.so.3
0000004 0x404f2c55 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/qt/3/lib/libqt-mt.so.3
0000005 0x4048c0b6 in QETWidget::translatePaintEvent(_XEvent const*) ()
   from /usr/qt/3/lib/libqt-mt.so.3
0000006 0x086c51a0 in ?? ()
0000007 0xbfffeac0 in ?? ()
0000008 0xbfffeabc in ?? ()
0000009 0x4048ba00 in QETWidget::translateKeyEvent(_XEvent const*, bool) ()
   from /usr/qt/3/lib/libqt-mt.so.3
0000010 0x4000b260 in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
TagsNo tags attached.
Patch

Relationships

child of 0002931 acknowledged Metabug: SVG 

Activities

2005-01-05 14:56

 

diapause_arten.sla (77,133 bytes)

cniehaus

2005-01-05 15:10

reporter   ~0003348

There was no emergency-save-file. So I reconstructed everything and exported again to pdf. Printed in KGhostView. Everything works, can't reproduce the crash.

cbradney

2005-01-07 12:05

administrator   ~0003390

User cannot replicate anymore.

Issue History

Date Modified Username Field Change
2005-01-05 14:56 cniehaus New Issue
2005-01-05 14:56 cniehaus File Added: diapause_arten.sla
2005-01-05 15:10 cniehaus Note Added: 0003348
2005-01-06 23:14 plinnell Status new => feedback
2005-01-06 23:14 plinnell Resolution open => unable to reproduce
2005-01-07 12:05 cbradney Status feedback => resolved
2005-01-07 12:05 cbradney Assigned To => cbradney
2005-01-07 12:05 cbradney Note Added: 0003390
2005-01-08 10:16 cbradney Status resolved => closed
2005-06-28 19:16 cbradney Category - => Import / Export
2006-05-17 19:24 christoph_s Relationship added child of 0002931