View Issue Details

IDProjectCategoryView StatusLast Update
0014943ScribusGeneralpublic2017-08-09 21:56
Reporterponce Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSSlackwareOS Version14.2 and current
Product Version1.5.4.svn 
Target VersionFixed in Version 
Summary0014943: segfault at launch
DescriptionQt and Qt-webkit versions used are 5.7.1 (but I tried also with 5.9.0)
gcc is either 5.3.0 or 7.1.0.
this manifests also with scribus 1.5.3 but *NOT* with 1.5.2 (that works fine)
- - -
building it from source is succesful, but trying to run the binary results in a segfault
Steps To Reproducebuild from source on Slackware stable or current after having installed all the dependencies and then try to run it
Additional Informationbacktrace
- - -
(gdb) run
Starting program: /usr/bin/scribus
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x00000000009a1968 in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x0)
    at /usr/include/c++/7.1.0/bits/atomic_base.h:396
396 return __atomic_load_n(&_M_i, __m);
(gdb) backtrace
#0 0x00000000009a1968 in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x0)
    at /usr/include/c++/7.1.0/bits/atomic_base.h:396
0000001 QAtomicOps<int>::load<int> (_q_value=...) at /usr/include/qt5/QtCore/qatomic_cxx11.h:227
0000002 0x00000000009a18e0 in QBasicAtomicInteger<int>::load (this=0x0) at /usr/include/qt5/QtCore/qbasicatomic.h:99
0000003 0x00000000009a22a4 in QtPrivate::RefCount::ref (this=0x0) at /usr/include/qt5/QtCore/qrefcount.h:55
0000004 0x00000000009a68da in QString::QString (this=0x7fffffffddc8, other=...) at /usr/include/qt5/QtCore/qstring.h:901
0000005 0x000000000110ae49 in __static_initialization_and_destruction_0 (__initialize_p=1, __priority=65535)
    at /tmp/SBo/scribus-r22129/scribus/ui/colorlistmodel.cpp:13
0000006 0x000000000110aed9 in _GLOBAL__sub_I_colorlistmodel.cpp(void) ()
    at /tmp/SBo/scribus-r22129/scribus/ui/colorlistmodel.cpp:278
0000007 0x00000000016733d6 in __do_global_ctors_aux ()
0000008 0x6665642073692030 in ?? ()
0000009 0x0000000000000000 in ?? ()
TagsNo tags attached.
PatchNo

Activities

jghali

2017-08-09 16:29

administrator   ~0044290

This crash occurs in code generated by compiler at exit of a function which has basically no reason to crash. Might be a compiler bug. I do not see such crash on Windows using Visual C++ compiler.

ponce

2017-08-09 16:54

reporter   ~0044291

hey jghali, good catch!

I just tried to build 1.5.3 and the latest svn using clang-4.0.1 (sorry I didn't think about it earlier) and they didn't segfault at launch! :)

as using an alternative compiler is perfectly acceptable (both are installed by default on Slackware), packaging on Slackware of the development version, IMHO, is OK.

ponce

2017-08-09 17:03

reporter   ~0044292

ah, I forgot to say thanks! :D

jghali

2017-08-09 21:56

administrator   ~0044293

I've tested latest trunk revision on Ubuntu 17.04 (gcc 6.3) and OpenSuse Leap 42.2 (gcc 4.8.5). No crash either. So it really looks like a bug on Slackware gcc.

Issue History

Date Modified Username Field Change
2017-08-09 09:45 ponce New Issue
2017-08-09 10:57 jghali Severity block => crash
2017-08-09 12:50 jghali Category Qt5 Port => General
2017-08-09 16:29 jghali Note Added: 0044290
2017-08-09 16:54 ponce Note Added: 0044291
2017-08-09 17:03 ponce Note Added: 0044292
2017-08-09 21:56 jghali Assigned To => jghali
2017-08-09 21:56 jghali Status new => resolved
2017-08-09 21:56 jghali Resolution open => no change required
2017-08-09 21:56 jghali Note Added: 0044293
2017-08-09 21:56 jghali Status resolved => closed