View Issue Details

IDProjectCategoryView StatusLast Update
0015077ScribusImport / Exportpublic2018-01-15 18:11
Reportermarkus_m Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSDebianOS Versiontesting
Product Version1.4.6 
Target VersionFixed in Version1.4.7.svn 
Summary0015077: importing eps-files with Scribus 1.4.6 and Ghostscript 9.22 fails
DescriptionWhen I try to import an eps-file as a vector file (File --> Import --> Get Vector File...) it fails ("Fatal Error").
This happens with Scribus 1.4.6 and Ghostscript 9.22. With older Ghostscript versions it used to work.
I also get the following error message in the terminal:

PostScript import failed when calling gs as:
-q -dNOPAUSE -dNODISPLAY -dBATCH -dDELAYBIND -g264x264 -r288 -dTextAlphaBits=4 -dGraphicsAlphaBits=4 -c 0 0 translate -sTraceFile=/home/username/.scribus//ps.out -sExportFiles=/home/username/Document--test_gs_9 /usr/lib/scribus/import.prolog /tmp/test_gs_9.22.eps -c flush cfile closefile quit

Ghostscript diagnostics:

    

     *** WARNING - the DELAYBIND command has been deprecated, and will be

                   removed in the next version. For now you can restore

                   the behaviour by using -dREALLYDEALYBIND but if you

                   require continued use of this command you should contact

                   the Ghostscript developers. Commercial customers of

                   Artifex should email their support contact, free users

                   are encouraged to talk to us on the #ghostscript IRC

                   channel on irc.freenode.net.

    

    Unrecoverable error: undefined in DELAYBIND
Steps To ReproduceTry to import the attached eps-file (test_gs_9.22.eps) with Scribus 1.4.6 and Ghostscript 9.22
or try to open it directly with Scribus.
Additional InformationSearch for "DELAYBIND" on the following website:

https://www.ghostscript.com/doc/9.22/History9.htm
TagsNo tags attached.
PatchNo

Relationships

has duplicate 0015075 closedjghali Can't insert barcode when using Ghostscript 9.22 
has duplicate 0015098 closedjghali Insertion of barcode triggers an error 

Activities

markus_m

2017-12-18 19:01

reporter  

test_gs_9.22.eps (1,871 bytes)

jghali

2017-12-18 19:16

administrator   ~0044764

Fyi importing PDF as vectors is not quite supported with Scribus 1.4.6.

ale

2017-12-19 13:49

manager   ~0044770

what about disabling it?

Issue History

Date Modified Username Field Change
2017-12-18 19:01 markus_m New Issue
2017-12-18 19:01 markus_m File Added: test_gs_9.22.eps
2017-12-18 19:11 jghali Priority urgent => normal
2017-12-18 19:15 jghali Summary importing eps-files (and pdfs) with Scribus 1.4.6 and Ghostscript 9.22 fails => importing eps-files with Scribus 1.4.6 and Ghostscript 9.22 fails
2017-12-18 19:16 jghali Note Added: 0044764
2017-12-18 22:41 jghali Assigned To => jghali
2017-12-18 22:41 jghali Status new => resolved
2017-12-18 22:41 jghali Resolution open => fixed
2017-12-18 22:41 jghali Fixed in Version => 1.4.7.svn
2017-12-18 22:43 jghali Relationship added has duplicate 0015075
2017-12-19 13:49 ale Note Added: 0044770
2017-12-19 14:56 markus_m Status resolved => closed
2018-01-15 18:11 jghali Relationship added has duplicate 0015098