View Issue Details

IDProjectCategoryView StatusLast Update
0015425Scribus-public2018-09-19 07:03
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version1.5.5.svn 
Target VersionFixed in Version 
Summary0015425: toolbar icons are too big on hdpi screen (on linux)
Descriptionfor multiple sides, we have reports that, since the support for hdpi has been activated, the size of the toolbars icons are too big.

setting

QT_SCALE_FACTOR=0

disables the auto scaling and, then, i'm back to the tiny icons that are completely unusable.

when the autoscaling is disabled,

export QT_AUTO_SCREEN_SCALE_FACTOR=2

gives me a sane value.

(when autoscaling is enabled, the factor seems to be 3)

i see three possible solutions:

- scaling the icons, so that they are shown at a "sane" size by default.
- define the default scale in scribus so that it looks good.
- add a setting in the preferences that allows a change of size.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0014335 confirmedKunda Big icons on HiDPI (hdpi) and large status bar 

Activities

jghali

2018-09-15 15:09

administrator   ~0045456

Duplicate of 0014335

ale

2018-09-17 07:34

manager   ~0045463

well... if the other bug says hidpi instead of hdpi it's hard to find it : - )

... i've edited the other bug's title to contain both abbreviations...

Issue History

Date Modified Username Field Change
2018-09-15 08:47 ale New Issue
2018-09-15 15:09 jghali Assigned To => jghali
2018-09-15 15:09 jghali Status new => resolved
2018-09-15 15:09 jghali Resolution open => duplicate
2018-09-15 15:09 jghali Note Added: 0045456
2018-09-15 15:09 jghali Relationship added duplicate of 0014335
2018-09-15 15:09 jghali Status resolved => closed
2018-09-17 07:34 ale Note Added: 0045463
2018-09-19 07:03 ale Description Updated View Revisions