View Issue Details

IDProjectCategoryView StatusLast Update
0015427ScribusGeneralpublic2019-04-04 21:42
Reporterpag Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version1.4.7 
Target VersionFixed in Version 
Summary0015427: Shapes do not render
DescriptionThe shapes in my document stopped rendering. I did some experiment test case reduction, and discovered that removing all PAGEOBJECT tags from the SLA file starting from line 1127 and on resolves the issue.
Steps To ReproduceOpen document in Scribus 1.4.7. You should only see black, that is the failure mode.
Open document in text editor, remove lines 1127 through 1227, save SLA file.
Open modified SLA file in Scribus 1.4.7, observe very colourful poster now correctly renders.
Additional InformationI'm not sure how my document got into this state. Additionally, I was able to segfault Scribus on the "fixed" document by cutting and pasting one of the groups of shapes, though I haven't reproduced this particular failure.
TagsNo tags attached.
PatchNo

Relationships

has duplicate 0015622 closedjghali bug d'affichage/display bug 

Activities

pag

2018-09-16 18:06

reporter  

cppcon-poster-2018-broken.sla (684,512 bytes)

ale

2018-09-16 18:20

manager   ~0045458

i also get a black document in 1.4... but in 1.5 it shows ok...

jghali

2018-09-16 18:51

administrator   ~0045459

Last edited: 2018-09-16 18:55

View 2 revisions

The issue is caused by the somewhat flaky implementation of groups in 1.4.x. This is a known issue of 1.4.x branch. The solution to avoid problems is to avoid any manipulation of items placed inside a group including:
- removing objects belonging to a group
- cutting objects placed inside a group
- ungrouping a group placed itself inside a group
- modifying level of an object placed inside a group

The implementation of groups in 1.5.x development branch has already been completely rewritten and is now much more robust. At this point of 1.4.x life there will be no fixes or changes to the group implementation due to the extent of modifications this would require.

ale

2018-09-17 07:51

manager   ~0045464

so the possible solutions i can suggest:

- restart from scratch (or with what you can rescue by manually deleting items)
- continue your work with scribus 1.5 (you can install both versions alongside)

Issue History

Date Modified Username Field Change
2018-09-16 18:06 pag New Issue
2018-09-16 18:06 pag File Added: cppcon-poster-2018-broken.sla
2018-09-16 18:20 ale Note Added: 0045458
2018-09-16 18:51 jghali Assigned To => jghali
2018-09-16 18:51 jghali Status new => resolved
2018-09-16 18:51 jghali Resolution open => won't fix
2018-09-16 18:51 jghali Note Added: 0045459
2018-09-16 18:52 jghali Status resolved => closed
2018-09-16 18:55 jghali Note Edited: 0045459 View Revisions
2018-09-17 07:51 ale Note Added: 0045464
2019-04-04 21:42 jghali Relationship added has duplicate 0015622