View Issue Details

IDProjectCategoryView StatusLast Update
0015681ScribusStory Editor / Text Framespublic2020-04-27 23:10
ReporterJLuc Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu OS Version18.04
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015681: Crash when deleting text with footnotes
DescriptionScribus crashes when deleting selected text that containes footnotes

- Original report is 0011661
- demonstrating file is https://bugs.scribus.net/file_download.php?file_id=6409&type=bug
Steps To Reproduce- open file
- select all contained text
- delete
- see : scribus has crashed
Additional Informationbt says
# 8 0x0000555556157618 in ScribusDoc::setUndoDelNote(TextNote*) ()
# 9 0x0000555555e628a3 in PageItem_TextFrame::removeMarksFromText(bool) ()
# 10 0x0000555555e5812a in PageItem_TextFrame::deleteSelectedTextFromFrame() ()
# 11 0x0000555555e55789 in PageItem_TextFrame::handleModeEditKey(QKeyEvent*, bool&) ()


see full uploaded backtrace
TagsNo tags attached.
PatchNo

Relationships

related to 0014140 closedjghali Cutting/Pasting then deleting footnote frame results in crash 
has duplicate 0011661 closed Numbering of all footnotes is zero 
has duplicate 0016018 closedjghali Deleting text content crashes (with Marks) 

Activities

JLuc

2019-05-09 18:13

developer  

backtrace (4,905 bytes)
found Unicode enc for Liberation Sans Narrow Regular as map 2 with 1336 glyphs
using Unicode enc for Liberation Sans Narrow Regular
ASSERT: "pos > -1" in file /build/scribus-trunk-H1Fyey/scribus-trunk-1.5.5svn~r22597~20180710~ppa73~ubuntu17.10.1/scribus/scribusdoc.cpp, line 17424
scribus-trunk: /build/scribus-trunk-H1Fyey/scribus-trunk-1.5.5svn~r22597~20180710~ppa73~ubuntu17.10.1/scribus/scribuscore.cpp :89 : void abort_on_error(QtMsgType, const QMessageLogContext&, const QString&):  l'assertion « false » a échoué.

Thread 1 "scribus-trunk" received signal SIGABRT, Aborted.
__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
51	../sysdeps/unix/sysv/linux/raise.c: Aucun fichier ou dossier de ce type.
(gdb) bt
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#1  0x00007ffff169b801 in __GI_abort () at abort.c:79
#2  0x00007ffff168b39a in __assert_fail_base (
    fmt=0x7ffff7f94f2c "%s%s%s :%u : %s%s l'assertion « %s » a échoué.\n%n", assertion=assertion@entry=0x555556987fff "false", 
    file=file@entry=0x555556987f90 "/build/scribus-trunk-H1Fyey/scribus-trunk-1.5.5svn~r22597~20180710~ppa73~ubuntu17.10.1/scribus/scribuscore.cpp", 
    line=line@entry=89, 
    function=function@entry=0x555556988340 "void abort_on_error(QtMsgType, const QMessageLogContext&, const QString&)") at assert.c:92
#3  0x00007ffff168b412 in __GI___assert_fail (
    assertion=0x555556987fff "false", 
    file=0x555556987f90 "/build/scribus-trunk-H1Fyey/scribus-trunk-1.5.5svn~r22597~20180710~ppa73~ubuntu17.10.1/scribus/scribuscore.cpp", line=89, 
    function=0x555556988340 "void abort_on_error(QtMsgType, const QMessageLogContext&, const QString&)") at assert.c:101
#4  0x00005555560d6ce6 in ?? ()
#5  0x00007ffff2420477 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007ffff2421f9e in QMessageLogger::fatal(char const*, ...) const ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007ffff241d486 in qt_assert(char const*, char const*, int) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x0000555556157618 in ScribusDoc::setUndoDelNote(TextNote*) ()
---Type <return> to continue, or q <return> to quit--- 
#9  0x0000555555e628a3 in PageItem_TextFrame::removeMarksFromText(bool) ()
#10 0x0000555555e5812a in PageItem_TextFrame::deleteSelectedTextFromFrame() ()
#11 0x0000555555e55789 in PageItem_TextFrame::handleModeEditKey(QKeyEvent*, bool&) ()
#12 0x0000555555ca5e11 in CanvasMode_Edit::keyPressEvent(QKeyEvent*) ()
#13 0x0000555556191dc8 in ScribusView::eventFilter(QObject*, QEvent*) ()
#14 0x00007ffff26156cc in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007ffff3393815 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007ffff339c642 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007ffff26159e8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007ffff33ef7c5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007ffff339383c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007ffff339b104 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007ffff26159e8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007ffff2bd40f0 in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#23 0x00007ffff2bd9035 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#24 0x00007ffff2bb02eb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#25 0x00007fffe4a831c0 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#26 0x00007fffef339417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fffef339650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fffef3396dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ffff266e99f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007ffff2613a1a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007ffff261cac4 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#32 0x0000555556775307 in mainApp(int, char**) ()
#33 0x0000555556775261 in main ()
backtrace (4,905 bytes)

PeterBenedek

2019-05-11 14:37

developer   ~0046203

It's very old fault...

zerubbabel

2020-04-07 23:08

reporter   ~0047494

This is a serious bug that makes the footnote feature dangerous to use, since you cannot delete a footnote, or even delete a story containing a footnote. I think its priority should be changed to HIGH and severity MAJOR.

zerubbabel

2020-04-27 21:56

reporter   ~0047577

The problem seems to be fixed in 1.5.6svn

Issue History

Date Modified Username Field Change
2019-05-09 18:13 JLuc New Issue
2019-05-09 18:13 JLuc File Added: backtrace
2019-05-09 18:14 JLuc Relationship added has duplicate 0011661
2019-05-11 14:36 PeterBenedek Relationship added duplicate of 0014140
2019-05-11 14:37 PeterBenedek Note Added: 0046203
2019-05-11 14:46 PeterBenedek Relationship deleted 0014140
2019-05-11 14:46 PeterBenedek Relationship added related to 0014140
2019-12-18 01:06 jghali Relationship added has duplicate 0016018
2020-04-07 23:08 zerubbabel Note Added: 0047494
2020-04-20 10:35 jghali Assigned To => jghali
2020-04-20 10:35 jghali Status new => resolved
2020-04-20 10:35 jghali Resolution open => fixed
2020-04-20 10:35 jghali Fixed in Version => 1.5.6.svn
2020-04-27 21:56 zerubbabel Note Added: 0047577
2020-04-27 23:10 jghali Severity minor => crash
2020-04-27 23:10 jghali Description Updated View Revisions
2020-04-27 23:10 jghali Steps to Reproduce Updated View Revisions
2020-04-27 23:10 jghali Additional Information Updated View Revisions