View Issue Details

IDProjectCategoryView StatusLast Update
0016062ScribusStory Editor / Text Framespublic2020-02-29 13:02
Reporternadi Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSMac OS X CatalinaOS Version
Product Version1.5.5 
Target VersionFixed in Version1.5.6.svn 
Summary0016062: Selecting individual bullet character crashes Scribus
DescriptionSelecting individual bullet character crashes Scribus due to signal 0000011
Steps To ReproduceThe same story during editing style and in Text Properties during editing text.

In Text Properties:
1. Go to the text box (editing cursor).
2. Select Text Properties -> Paragraph Effects -> Bulleted List.
3. Select Char Table and select for example black triangle character, then Insert.
4. Sometimes you have to repeat those action tow or three times, maybe also close window with character selection.
5. The popup appears "Scribus crashes due to signal 0000011", after closing it - Scribus hangs.

In Styles:
1. Select from main menu Edit -> Styles (F4).
2. Choose any style and select Edit.
3. Select Paragraph Effects -> Bulleted List.
... and the rest is like above.
Tagsparagraph effects
PatchNo

Activities

jghali

2020-02-26 23:31

administrator   ~0047420

Thanks for the report. This is now fixed in 1.5.6.svn.

nadi

2020-02-27 22:09

reporter   ~0047421

Maybe, but version 1.5.6.svn closes itself during start with this error "Scribus crashes due to Signal 0000011" so I cannot check it :(

nadi

2020-02-29 13:02

reporter   ~0047423

I added bug to version 1.5.6 svn - I cannot run application (https://bugs.scribus.net/view.php?id=16063). In the time being I cannot check the solution of this bug.

Issue History

Date Modified Username Field Change
2020-02-26 22:21 nadi New Issue
2020-02-26 22:21 nadi Tag Attached: paragraph effects
2020-02-26 23:15 jghali Severity major => crash
2020-02-26 23:16 jghali Category Fonts => Story Editor / Text Frames
2020-02-26 23:16 jghali Priority high => normal
2020-02-26 23:30 jghali Summary Selecting individual bullet character crashes Scribus due to signal 0000011 => Selecting individual bullet character crashes Scribus
2020-02-26 23:30 jghali Assigned To => jghali
2020-02-26 23:30 jghali Status new => resolved
2020-02-26 23:30 jghali Resolution open => fixed
2020-02-26 23:30 jghali Fixed in Version => 1.5.6.svn
2020-02-26 23:31 jghali Note Added: 0047420
2020-02-27 22:09 nadi Note Added: 0047421
2020-02-29 13:02 nadi Note Added: 0047423