View Issue Details

IDProjectCategoryView StatusLast Update
0016331ScribusGraphics / Image Framespublic2020-11-12 18:46
Reportermkranker Assigned Tojghali  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSPop!_OSOS VersionPop!_OS 20.10
Product Version1.5.6.svn 
Target VersionFixed in Version 
Summary0016331: Closed Scribus while trying to open a PDF file and now Scribus no longer works
DescriptionSo I was opening a PDF file and I closed the application while it was still opening that file. After I re-opened Scribus it no longer worked. The load screen would finish and then the application opens. After a small amount of time the app closes and then re-opens. After that I can no longer use the GUI. The tab options do not respond and the red x on the top right corner doesn't respond either. I have to then use the terminal in order to close the application.

I wonder whether this is a QT GUI bug rather than being a scribus bug. The strange part about the screen re-opening is that it looks exactly like the way the screen opens when the computer starts back up after re-boot. Un-installing and re-installing does nothing to fix the problem, so I question whether this is a Scribus source bug and is instead a system/os problem or one of the
dependencies for scribus is now corrupted.

Opening scribus in the terminal outputs no error other than missing App Images which I don't think is causing the problem.
Steps To ReproduceThis bug seems to be permanent, so I wouldn't be able to reproduce the bug unless I used scribus on a different computer and did the same steps of closing while opening a PDF file.
Additional InformationI included a compressed .mp4 file that shows what scribus does when I open it through the terminal.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0016295 new Scribus crashes on Ubuntu 20.10 

Activities

mkranker

2020-11-12 17:45

reporter  

scribus_app_fail_compressed.mp4 (1,671,690 bytes)

jghali

2020-11-12 18:45

administrator   ~0048383

Duplicate of issue 0016295. There is a workaround mentioned in the notes of that issue. Unfortunately what occurs is apparently a crash in Ubuntu's GNOME/GTK components, so something we cannot fix ourselves.

Issue History

Date Modified Username Field Change
2020-11-12 17:45 mkranker New Issue
2020-11-12 17:45 mkranker File Added: scribus_app_fail_compressed.mp4
2020-11-12 18:45 jghali Assigned To => jghali
2020-11-12 18:45 jghali Status new => resolved
2020-11-12 18:45 jghali Resolution open => duplicate
2020-11-12 18:45 jghali Note Added: 0048383
2020-11-12 18:45 jghali Relationship added duplicate of 0016295
2020-11-12 18:46 jghali Status resolved => closed