View Issue Details

IDProjectCategoryView StatusLast Update
0016295ScribusGeneralpublic2021-07-11 16:42
Reporterbubu Assigned Tojghali  
Status closedResolutionno change required 
Product Version1.5.6.svn 
Summary0016295: Scribus crashes on Ubuntu 20.10
DescriptionScribus (1.5.5+svn23928+dfsg-1build1) crashes on startup on Ubuntu 20.10.

Steps To Reproduce- On Ubuntu 20.10 install scribus: $ sudo apt install scribus
This will install scribus_1.5.5+svn23928+dfsg-1build1_amd64.deb

- Start it: $ scribus
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/register.png: File not found
Scribus Crash
Scribus crashes due to Signal ... 0000011
load glyph failed err=6 face=0x56249d475a90, glyph=6
Segmentation fault (core dumped)
Additional InformationOther reports:
TagsNo tags attached.


has duplicate 0016287 closedjghali o scribus não funciona 
has duplicate 0016331 closedjghali Closed Scribus while trying to open a PDF file and now Scribus no longer works 



2020-10-30 13:07

manager   ~0048265

could you add the debug symbols and run it with gdb?

... it looks like a library issue...


2020-10-30 15:20

administrator   ~0048267

I managed to reproduced the crash in my Ubuntu 20.10 VM. It does not happen systematically tho. Looks like a crash in a GTK event loop or something like that.


2020-10-30 22:20

administrator   ~0048268

It seems I cannot reproduce the crash anymore with latest Ubuntu updates.


2020-10-31 10:07

reporter   ~0048269

OK, I'm trying to help, but I'm really not a C++ developer, so I'm a noob for debugging Scribus. I found only very outdated wiki pages how to build Scribus on Ubuntu 20.10 with debug symbols and I do not fully understand what gdb is...

I build Scribus cmake -DWANT_DEBUG=1 -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/scribus_svn ..

When I start it I get this output:
/usr/local/scribus_svn/bin$ gdb ./scribus
GNU gdb (Ubuntu 9.2-0ubuntu2) 9.2
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./scribus...
(gdb) run
Starting program: /usr/local/scribus_svn/bin/scribus
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7ffff1880640 (LWP 42463)]
[New Thread 0x7fffebe94640 (LWP 42464)]
[New Thread 0x7fffeb693640 (LWP 42465)]
[New Thread 0x7fffeac4e640 (LWP 42466)]
[New Thread 0x7fffea1cc640 (LWP 42468)]
[Detaching after fork from child process 42469]
[Detaching after fork from child process 42470]
[Detaching after fork from child process 42471]
[Detaching after fork from child process 42472]
[Detaching after fork from child process 42473]
pathForIcon: Unable to load icon /usr/local/scribus_svn/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/local/scribus_svn/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/local/scribus_svn/share/scribus/icons/1_5_1/register.png: File not found
Unsupported ICC profile class 70727472
fromIccProfile: failed general sanity check
QPngHandler: Failed to parse ICC profile
[New Thread 0x7fffd8e06640 (LWP 42476)]
[New Thread 0x7fffcffff640 (LWP 42477)]
[New Thread 0x7fffcf7fe640 (LWP 42478)]
[New Thread 0x7fffceffd640 (LWP 42479)]
[New Thread 0x7fffce7fc640 (LWP 42480)]
[New Thread 0x7fffcdffb640 (LWP 42481)]
[New Thread 0x7fffcce51640 (LWP 42482)]
[New Thread 0x7fffb7fff640 (LWP 42483)]
[Thread 0x7fffcdffb640 (LWP 42481) exited]
[Thread 0x7fffcf7fe640 (LWP 42478) exited]
[Thread 0x7fffceffd640 (LWP 42479) exited]
[Thread 0x7fffd8e06640 (LWP 42476) exited]
[Thread 0x7fffcffff640 (LWP 42477) exited]
[Thread 0x7fffce7fc640 (LWP 42480) exited]

@ale, if you give me a wiki description I will do more.
@jhali, I updated my Ubuntu (including Scribus), but it continues to crash.


2020-10-31 12:47

manager   ~0048270

with ubuntu, you don't need to compile scribus yourself to start scribus with the debugger.

i can see if i can put together a short tutorial.

anyway, i think that jean got the information he needed to reproduce and ubuntu seems to have fixed the bug...


2020-10-31 15:28

reporter   ~0048271

After upgrading to scribus-trunk amd64 1.5.6svn~r24132~20201031~ppa78~ubuntu20.10.1 I got this warning:

There is a problem loading 1 of 55 plugins. This is probably caused by some kind of dependency issue or old plugins existing in your install directory. If you clean out your install directory and reinstall and this still occurs, please report it on

And yes, there is a /usr/lib/scribus-trunk/plugins/ file. If I remove it the crash persists.


2020-10-31 16:34

administrator   ~0048272

>> anyway, i think that jean got the information he needed to reproduce and ubuntu seems to have fixed the bug...

Arghhh!! After restarting my VM this morning, the crash is unfortunately back. Here is the backtrace I'm getting:

#0 0x00007fb6b221766f in __GI___poll (fds=0x562a6e01a7d0, nfds=4,
    timeout=2992) at ../sysdeps/unix/sysv/linux/poll.c:29
0000001 0x00007fb6b197e71e in ?? () from /lib/x86_64-linux-gnu/
0000002 0x00007fb6b197e853 in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/
0000003 0x00007fb6b2941843 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/
0000004 0x00007fb6b28e8a4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/
0000005 0x00007fb6b35a001f in QDialog::exec() ()
   from /lib/x86_64-linux-gnu/
0000006 0x0000562a69c7e8cf in ScribusMainWindow::startUpDialog (this=
    at /home/developer/Documents/scribus-trunk/Scribus/scribus/scribus.cpp:1970
0000007 0x0000562a69cd916f in ScribusCore::startGUI (this=0x562a6c45cda0,
    showSplash=true, showFontInfo=false, showProfileInfo=false,
    at /home/developer/Documents/scribus-trunk/Scribus/scribus/scribuscore.cpp:132
0000008 0x0000562a69cd519e in ScribusQApp::init (this=0x7fff7beb3290)
    at /home/developer/Documents/scribus-trunk/Scribus/scribus/scribusapp.cpp:364
0000009 0x0000562a6a342643 in mainApp (argc=1, argv=0x7fff7beb3438)
    at /home/developer/Documents/scribus-trunk/Scribus/scribus/main_nix.cpp:72
0000010 0x0000562a6a3425b8 in main (argc=1, argv=0x7fff7beb3438)
    at /home/developer/Documents/scribus-trunk/Scribus/scribus/main_nix.cpp:51

Unfortunately it seems something bad happens deep inside Qt and glib. So the fix will likely have to happen on Ubuntu side.


2020-10-31 23:36

administrator   ~0048277

Tested here .. no crash on 20.10


2020-11-01 12:15

reporter   ~0048278

I tested it on a fresh Ubuntu 20.10 (VM) and get this result. I installed only the scribus package:
- 1st start Scribus works well
- Close Scribus and restart it: crashed :-(.


2020-11-01 19:01

reporter   ~0048279

New test here... If I remove that 2 files before running Scribus every time:
there is no crash on startup anymore, Scribus is usable.
I tested this on fresh Ubuntu 20.10 and on my real desktop. I hope this helps.


2020-11-01 21:54

administrator   ~0048280

Try editing the theme="" in scribus150.rc to be "Fusion" or "Windows" and see if it starts up.

I have zero issue here with all 3 themes on 20.10 though. Again, likely a Qt or GTK issue. Not a Scribus issue.


2020-11-02 08:38

reporter   ~0048286

@cbradney, thanks for you help. Unfortunately this fix (theme="Fusion") does not solve the crash problem completely:
- If Scribus crashes and there is an empty theme attribute, when I fill it with theme="Fusion", it solves the problem.
- But after that if I edit the Scribus preferences on GUI, after exit and restart Scribus crashes again although this theme attribute is not empty in this case.
- And on some cases Scribus starts without any problem with empty theme attribute.


2020-11-02 14:37

administrator   ~0048292

The crash can be avoided by setting in scribus150.rc the Maximized attribute of MainWindow element to "0".

For those compiling scribus themselves on Ubuntu 20.10, a temporary workaround can be to comment out following lines in scribus.cpp:
if (mainWinSettings.maximized)
        this->setWindowState((this->windowState() & ~(Qt::WindowMinimized | Qt::WindowFullScreen)) | Qt::WindowMaximized);
Of course, when starting up scribus, the maximization state of scribus main window will not be restored anymore.

I tried several workarounds in order the allow the maximization state of scribus main window to be restored while preventing the crash on Ubuntu 20.10, unfortunately without success as none of the workarounds I tried worked reliably.

So at this point, I strongly think that the fix will have to come from Ubuntu guys or GTK guys. I doubt the issue is in Qt as the same Qt 5.14.x works correctly in other distros.


2020-11-02 16:26

reporter   ~0048293

@jghali, you are right, I can confirm that <MainWindow Maximized="0" /> solves the crash. Thank you for investigation.


2020-11-13 12:57

administrator   ~0048403

It seems also that the 1.5.6 AppImage does not trigger the crash in 20.10. But that's probably because it embeds Ubuntu 18.04 components.


2020-11-16 21:14

developer   ~0048440

Actually, nope, 1.5.6 fails to respond after loading here with both AppImage and my own build from source code. Not running it with maximized window mode does solve the issue.


2020-11-16 21:37

reporter   ~0048441

This is the output in the Terminal when I launch Scribus in Ubuntu 20.10. As I mentioned on other forums, GNOME Shell crashes, and Scribus doesn't respond. I have to kill the process to close Scribus.


2020-11-17 07:52

administrator   ~0048444

Those few missing files isn't a problem, Scribus falls back to previous versions of the icons


2020-11-24 13:43

reporter   ~0048482

@bubu, removing the two files did solve the issue for me; thanks!

I still find it rather odd that stable branch is supposed to be 1.5.5 (right?), that is what the package is called, but when it runs, it appears to be 1.5.6 unstable?

Anyway, Scribus no longer crashes with the two files removed.


2020-11-24 13:45

administrator   ~0048483

stable is 1.4.x


2020-11-24 13:47

reporter   ~0048484

@antoonstessels, it is enough to modify Maximized="1" to Maximized="0" in scribus150.rc file as jghali mentioned above.


2020-11-27 09:03

reporter   ~0048497

Thanks @bubu and @jghali, changing the line in the scribus150.rc file fixes the problem.


2021-02-06 00:19

reporter   ~0048807

I find this problem gone (Ubuntu 20.10).


2021-02-06 15:32

administrator   ~0048808

Last edited: 2021-02-06 15:33

Nope, I can still reproduce it in my VM. I'm going to install latest updates and test again.


2021-02-06 17:20

administrator   ~0048809

I can still reproduce the issue with latest updates.


2021-02-07 19:47

reporter   ~0048812

Interesting, I can't reproduce anymore the issue:
- I'm running Scribus 1.5.6, scribus-trunk, my development build, appImage - all they work without any problem.
- Maximized="1" is enabled.
- Ubuntu 20.10: Linux lazar 5.8.0-41-generic 0000046-Ubuntu SMP Mon Jan 18 16:48:44 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
- Gnome 3.38.3
- Wayland /X11 does not matter.

@antoonstessels, @alexandre?


2021-05-04 13:35

reporter   ~0049117

I have the same problem here the output of gdb:

I tried some of the workarounds but they don't seem to work.

(gdb) run
Starting program: /usr/bin/scribus
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7fffefee4640 (LWP 55401)]
[New Thread 0x7fffee63c640 (LWP 55402)]
[New Thread 0x7fffede3b640 (LWP 55403)]
[New Thread 0x7fffed63a640 (LWP 55404)]
[New Thread 0x7fffecaf4640 (LWP 55405)]
[New Thread 0x7fffd7fff640 (LWP 55406)]
[New Thread 0x7fffd77fe640 (LWP 55407)]
[New Thread 0x7fffd4dc7640 (LWP 55409)]
[New Thread 0x7fffcffff640 (LWP 55410)]
[New Thread 0x7fffcf7fe640 (LWP 55411)]
[New Thread 0x7fffceffd640 (LWP 55412)]
[Detaching after fork from child process 55413]
[Detaching after fork from child process 55414]
[Detaching after fork from child process 55415]
[Detaching after fork from child process 55416]
[Detaching after fork from child process 55417]
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/register.png: File not found

Thread 1 "scribus" received signal SIGSEGV, Segmentation fault.
0x00007ffff587eb84 in QObject::objectName() const () from /usr/lib/x86_64-linux-gnu/


2021-05-04 14:07

developer   ~0049118

I never had such issue running scribus 1.5.6 or 1.5.7 appimage on ubuntu 20.10


2021-05-04 15:57

reporter   ~0049119

I can't reproduce:
- Ubuntu 21.04
- Qt 5.15.2
- X or Wayland
- Scribus (deb), 1.5.7 (appImage)


2021-07-11 16:42

administrator   ~0049186

The crash is fixed in Ubuntu 21.04 and Ubuntu 20.10 is going out of support this month, so I'm closing this issue. Given the location of the crash, it was out of scope for us anyway.

Issue History

Date Modified Username Field Change
2020-10-30 11:36 bubu New Issue
2020-10-30 13:07 ale Note Added: 0048265
2020-10-30 14:44 ale View Status public => private
2020-10-30 14:44 ale View Status private => public
2020-10-30 15:20 jghali Note Added: 0048267
2020-10-30 22:20 jghali Note Added: 0048268
2020-10-31 10:07 bubu Note Added: 0048269
2020-10-31 12:47 ale Note Added: 0048270
2020-10-31 15:28 bubu File Added: Képernyőkép erről: 2020-10-31 16-17-12.png
2020-10-31 15:28 bubu Note Added: 0048271
2020-10-31 16:34 jghali Note Added: 0048272
2020-10-31 23:36 cbradney Note Added: 0048277
2020-11-01 12:15 bubu Note Added: 0048278
2020-11-01 19:01 bubu Note Added: 0048279
2020-11-01 21:54 cbradney Note Added: 0048280
2020-11-02 04:22 jghali Relationship added has duplicate 0016287
2020-11-02 08:38 bubu Note Added: 0048286
2020-11-02 14:37 jghali Note Added: 0048292
2020-11-02 16:26 bubu Note Added: 0048293
2020-11-12 18:45 jghali Relationship added has duplicate 0016331
2020-11-13 12:57 jghali Note Added: 0048403
2020-11-16 21:14 alexandre Note Added: 0048440
2020-11-16 21:37 antoonstessels File Added: Schermafdruk van 2020-11-16 17-42-14.png
2020-11-16 21:37 antoonstessels Note Added: 0048441
2020-11-17 07:52 cbradney Note Added: 0048444
2020-11-24 13:43 antoonstessels Note Added: 0048482
2020-11-24 13:45 cbradney Note Added: 0048483
2020-11-24 13:47 bubu Note Added: 0048484
2020-11-27 09:03 antoonstessels Note Added: 0048497
2021-02-06 00:19 bubu Note Added: 0048807
2021-02-06 15:32 jghali Note Added: 0048808
2021-02-06 15:33 jghali Note Edited: 0048808
2021-02-06 17:20 jghali Note Added: 0048809
2021-02-07 19:47 bubu Note Added: 0048812
2021-05-04 13:35 jucajuca Note Added: 0049117
2021-05-04 14:07 JLuc Note Added: 0049118
2021-05-04 15:57 bubu Note Added: 0049119
2021-07-11 16:42 jghali Assigned To => jghali
2021-07-11 16:42 jghali Status new => resolved
2021-07-11 16:42 jghali Resolution open => no change required
2021-07-11 16:42 jghali Note Added: 0049186
2021-07-11 16:42 jghali Status resolved => closed