View Issue Details

IDProjectCategoryView StatusLast Update
0001731ScribusFontspublic2005-06-11 11:29
Reporterlouisdesjardins Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSMandrakeOS Version10.1
Product Version1.2.2cvs 
Target VersionFixed in Version1.2.2cvs 
Summary0001731: Overlapping letters
DescriptionSome letters are overlapping at end of lines. This bug can be replicated only when you hyphenate text. Unhyphenated text don't have this problem.
Steps To Reproduce1. Create a text box
2. Put some text
3. Format using any font
4. Hyphenate (after testing, this seems to be a condition to recreate the bug)
5. Resize the box
6. Some endlines will show overlapping letters
Note : you may have to resize a lot before getting the letters to overlap.
Additional InformationNot related to a particular font. Tested with:
Nimbus Sans L Bold
A030 Bold
Garamond No8 Regular
URW Gothic L Demi Oblique

Could not find a pattern.
Tried with various text inset. Same thing.
Tried with various hyphenation settings. Same thing.
Tried with text typed directly in text frame and text imported from .sxw file. Same Result.

An easy way to replicate the bug is by slowly enlarging the text frame using shift + mouse scroll into the width field until letters eventually overlap.
TagsNo tags attached.
Patch

Relationships

has duplicate 0002019 closedringerc hyphenation marks look and print broken 
related to 0003828 acknowledged Metabug: Hyphenation 

Activities

louisdesjardins

2005-02-27 13:27

developer   ~0003833

This is not only a screen preview issue. Export PDF and you'll get exactly what you see: overlapping letters. Very annoying.

louisdesjardins

2005-02-27 16:40

developer   ~0003835

I tested more and here is additionnal information:

1. When the overlap occurs on a line that's hyphenated, the hyphen remains there if the word is long enough but it then hyphenates wrongly. Example: effi-cace ends up eff-icace (in French, the latest is wrong).

2. The problem doesn't seem related to typesize. I've tried with lots of different sizes and I am always able to reproduce the bug.

3. Once the problem is located, it is possible to reproduce it using either the width of the text frame or the gutter width.

4. Text frame can have any number of columns, issue still present.

5. When text is justified, letters overlap and... (see 6)

6. ...when text is ragged right, the overlapping letter is pushed to the far right side of text frame.

2005-03-01 23:22

 

OverlappingLetters2.png (103,896 bytes)
OverlappingLetters2.png (103,896 bytes)

2005-03-01 23:22

 

louisdesjardins

2005-03-02 13:37

developer   ~0003855

I am taking the liberty to add Rolf's comment from the mailing list, about the same issue:
" [...] the thing appeared directly after inserting and hyphenating a text without changing the frame."

2005-03-02 13:46

 

test3.png (13,403 bytes)
test3.png (13,403 bytes)

2005-03-02 13:47

 

test4.png (23,833 bytes)
test4.png (23,833 bytes)

louisdesjardins

2005-03-02 13:49

developer   ~0003856

Test3.png and Test4.png (from Rolf) only to show it happens with various languages.
So, tested with French and German.

louisdesjardins

2005-03-06 12:32

developer   ~0003880

Well... Finally found a workaround to this issue.
Issue seems clearly related to hyphenation.
I have no other clue so far.

I am ready to investigate further if necessary.

Please let me know what the plans are.

I can also reaffirm it's *v e r y* annoying. I'm putting the last touch to a tight 12 pages of additionnal documentation on Scribus for my workshop at AQUOPS and this caused me problems, more than once.
Overall quality control and proofreading are complicated. Quite unproductive imo.

Workaround:
1. Open the Story Editor and select the word that has overlapping letters.
2. Retype this word (beware of typos...).
3. If it's a long word, retype only a portion of it, where letters overlap. Try to at least grab a hyphen, even if you don't see it.
4. Repeat for all instances in each text frame where the problem occurs.
5. Update text and leave the Story Editor.
Warning!: Beware of other instances that can occur consequently (it happens)!

This operation will take away the hyphens (the hyphens are of course invisible when not needed, still, they are there) that cause the problem. Of course, you might as well end up with a few holes in your type which will affect the overall "typographic gray". But at least your readers will be able to follow. And it's always possible to add a discretionary hyphen manually using CTRL + hyphen (-).

cweber

2005-04-07 07:28

reporter   ~0004107

Reminder sent to: fschmid

I can confirm this is a very annoying bug and it still exists in 1.3cvs. Even in the roadmap I didn't find a planned bugfix for this. I think this should have higher priority than e.g. changes in the user interface because it really breaks the functionality.

Cheers,
Christian.

fschmid

2005-04-08 19:08

administrator   ~0004195

Can you please provide a small sample doc which shows that issue?

2005-04-08 22:58

 

overlappingletters.sla (203,429 bytes)

2005-04-08 22:59

 

overlappingletters.pdf (67,395 bytes)

louisdesjardins

2005-04-08 23:01

developer   ~0004203

Hi Franz,
I have just uploaded a .sla file showing the problem, plus its .pdf version.
Please let me know if anything else was needed.
Many thanks!
Louis

plinnell

2005-06-11 11:29

viewer   ~0004995

tested the fix for both 1.2.2 and 1.3.0. Looks perfect now.

Issue History

Date Modified Username Field Change
2005-02-26 20:43 louisdesjardins New Issue
2005-02-27 13:27 louisdesjardins Note Added: 0003833
2005-02-27 16:40 louisdesjardins Note Added: 0003835
2005-03-01 23:22 louisdesjardins File Added: OverlappingLetters2.png
2005-03-01 23:22 louisdesjardins File Added: SeparatedLettersRagRight.png
2005-03-02 13:37 louisdesjardins Note Added: 0003855
2005-03-02 13:46 louisdesjardins File Added: test3.png
2005-03-02 13:47 louisdesjardins File Added: test4.png
2005-03-02 13:49 louisdesjardins Note Added: 0003856
2005-03-06 12:32 louisdesjardins Note Added: 0003880
2005-03-07 12:00 cbradney Status new => assigned
2005-03-07 12:00 cbradney Assigned To => fschmid
2005-04-07 07:28 cweber Note Added: 0004107
2005-04-08 19:08 fschmid Note Added: 0004195
2005-04-08 22:58 louisdesjardins File Added: overlappingletters.sla
2005-04-08 22:59 louisdesjardins File Added: overlappingletters.pdf
2005-04-08 23:01 louisdesjardins Note Added: 0004203
2005-06-01 22:12 ringerc Relationship added related to 0002019
2005-06-01 22:13 ringerc Relationship replaced has duplicate 0002019
2005-06-11 10:42 fschmid Status assigned => resolved
2005-06-11 10:42 fschmid Fixed in Version => 1.2.2cvs
2005-06-11 10:42 fschmid Resolution open => fixed
2005-06-11 11:29 plinnell Status resolved => closed
2005-06-11 11:29 plinnell Note Added: 0004995
2006-05-16 22:12 christoph_s Relationship added related to 0003828