View Issue Details

IDProjectCategoryView StatusLast Update
0001795Scribus-public2005-04-07 19:18
Reporterjslpzcn Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformFedora Core 3OSLinuxOS Version
Product Version1.2.1 
Target VersionFixed in Version 
Summary0001795: Dead keys do not work properly
DescriptionWhen I try to write text into a text frame and I want to show a letter with an accent e.g. á I see 'a. And when I use the internal editor, it shows á but when it copies the text I don't see nothing within the text frame. I am from Spain (Europe) and I use Fedora Core 3 and UTF-8.
Steps To Reproduce-Press a dead key. E.g. '.
-Press another key. E.g. o.
-I obtain 'o.
TagsNo tags attached.
Patch

Relationships

has duplicate 0001908 closedavox Dead Keys do not work 

Activities

cbradney

2005-03-20 20:48

administrator   ~0003939

Works fine here...

jslpzcn

2005-03-22 18:59

reporter   ~0003948

Yes, it works fine with other Linux distributions, but not with Fedora Core 3. I have tried with Mandrake 10.1 and it has worked fine, but with Fedora Core 3 it do not work correctly.

avox

2005-03-23 02:20

administrator   ~0003951

Last edited: 2005-03-23 02:22

There was a similar issue on thy LyX mailing list. They tracked it down to Qt's input method (immodule)
Apparently Fedora ships an incompatible one.
See:
"http://marc.theaimsgroup.com/?l=lyx-devel&m=110664247205027&w=2"

jslpzcn

2005-03-24 16:13

reporter   ~0003965

Yes, it happens with another KDE programs e.g. Koffice. I have updated qt to 3.3.4 version (with iiimf support) and bug has changed. Now when I press ' and a, I do not see nothing. It's a qt bug? Or is an important update issue to take in mind for all the qt programmers?

plinnell

2005-04-07 19:18

viewer   ~0004115

I would file a bug in bugzilla.redhat.com and reference this bug as well. We can confirm it works on three other distros with Qt 3.3.3+

Issue History

Date Modified Username Field Change
2005-03-20 15:13 jslpzcn New Issue
2005-03-20 20:48 cbradney Note Added: 0003939
2005-03-22 18:59 jslpzcn Note Added: 0003948
2005-03-23 02:20 avox Note Added: 0003951
2005-03-23 02:22 avox Note Edited: 0003951
2005-03-24 16:13 jslpzcn Note Added: 0003965
2005-04-07 19:18 plinnell Note Added: 0004115
2005-04-07 19:18 plinnell Status new => resolved
2005-04-07 19:18 plinnell Resolution open => no change required
2005-04-07 19:18 plinnell Status resolved => closed
2005-04-22 20:02 cbradney Relationship added has duplicate 0001908