View Issue Details

IDProjectCategoryView StatusLast Update
0002362ScribusOS-PPCOSXpublic2006-01-23 02:43
Reporteravox Assigned Toavox  
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
PlatformScribus/AquaOSOSXOS Version
Product Version1.3.0 
Target VersionFixed in Version1.3.2 
Summary0002362: Scribus hangs or crashes while searching for fonts
DescriptionA freshly installed Scribus/Aqua will not start but will stop at the Splash screen while searching for fonts. This bug was reported by users on the ML; I wasn't able to experience this myself.

1) With one user who experienced a freeze we traced it down to missing fc-cache1 files on his system.

Workaround: call "/Library/Frameworks/Fontconfig2.framework/Versions/A/bin/fc-list" from Terminal and restart Scribus.

2) Two other users reported a "Too many open files" error. This is probably due to too many installed fonts and a bug in Freetype 2.1.10.

Workaround: Install Freetype 2.19 instead and try again.
TagsNo tags attached.
Patch

Relationships

duplicate of 0002148 closedavox Scribus crashes on startup 
related to 0002881 closedavox Scribus/Aqua cannot write or read directories/files 
has duplicate 0002715 closedavox Scribus crashes while searching for Fonts while launching 
related to 0002655 closedfschmid Startup font scan is very slow 
related to 0003912 closedcbradney Preferences location is an unnecessary challenge. 
child of 0002015 closedavox This issue lists all known regressions of the Aqua port compared with the 13 Linux version 

Activities

ringerc

2005-08-01 17:34

reporter   ~0005804

marking acknowledged given that it's been given a parent.

avox

2005-08-27 16:40

administrator   ~0006259

Corrected the path to the fontconfig binaries.

avox

2005-10-03 21:25

administrator   ~0006895

Changed prio to normal. Will have to look out for this bug when next snapshot comes out.

DJ Vollkasko

2005-12-28 10:04

reporter   ~0007845

Scribus/Aqua crashes on OS during startup at step "Initialising Fontcache". All parts are installed as instructed (the .app in /Applications, all other stuff in /Library/Frameworks). What to do?


Measures taken:


    1. Installed and started Scribus (Aqua-flavour). Crashed.


    2. As per cbradney's recommendation in bug 0002715, I've started it from the Terminal with

/Applications/Scribus.app/Contents/bin/scribus --font-info


     and it crashed. This is the Terminal output:

Die Schriftart /System/Library/Fonts/?????? Pro W4.otf ist fehlerhaft und wird ab sofort ignoriert
    [= "Font _____ is damaged and will be ignored from now on."--DJV]
Die Schriftart /System/Library/Fonts/?????? Pro W3.otf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/?????? Pro W6.otf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/?????? Pro W3.otf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/?????? Pro W6.otf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/?????? Std W8.otf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/?? Pro.ttf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/????.ttf ist fehlerhaft und wird ab sofort ignoriert
Die Schriftart /System/Library/Fonts/????.ttf ist fehlerhaft und wird ab sofort ignoriert
dyld: /Applications/Scribus.app/Contents/bin/scribus can't open library: /System/Library/CoreServices/Encodings/libJapaneseConverter.dylib (Too many open files, errno = 24)
Trace/BPT trap



    3. Following above recommendation, I ran

/Library/Frameworks/Fontconfig2.framework/Versions/A/bin/fc-list


    from the terminal, which returned

Fontconfig error: Cannot load default config file

    Then I launched Scribus again, which comfortably crashed during Fontcache initialization, patently producing the following error log:


Date/Time: 2005-12-28 10:54:39 +0100
OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: Scribus
Path: /Applications/Scribus.app/Contents/MacOS/Scribus
Version: 1.3cvs (???)
PID: 14274
Thread: Unknown

Link (dyld) error:

dyld: /Applications/Scribus.app/Contents/MacOS/Scribus can't open library: /System/Library/CoreServices/Encodings/libJapaneseConverter.dylib (Too many open files, errno = 24)



    What measure next? FreeType is not installed AFAIK (I didn't set up this system).



--Your kind advice is much appreciated.

D. Vollkasko
Librarian

The Temporary Newton Library
http://www.stillnewt.org/library

avox

2006-01-23 02:42

administrator   ~0008283

The "too many open files" error was resolved in bug 0002881.

Use the new Freetype.framework from http://aqua.scribus.net/index.html

Issue History

Date Modified Username Field Change
2005-08-01 12:59 avox New Issue
2005-08-01 12:59 avox Relationship added child of 0002015
2005-08-01 16:29 avox Description Updated
2005-08-01 17:34 ringerc Note Added: 0005804
2005-08-01 17:34 ringerc Status new => acknowledged
2005-08-27 16:40 avox Note Added: 0006259
2005-08-27 16:40 avox Description Updated
2005-10-01 11:03 avox Relationship added duplicate of 0002148
2005-10-01 11:13 avox Status acknowledged => assigned
2005-10-01 11:13 avox Assigned To => avox
2005-10-03 16:10 ringerc Relationship added related to 0002655
2005-10-03 21:25 avox Note Added: 0006895
2005-10-03 21:25 avox Priority high => normal
2005-10-03 21:25 avox Description Updated
2005-10-18 17:22 avox Relationship added has duplicate 0002715
2005-12-28 10:04 DJ Vollkasko Note Added: 0007845
2005-12-28 16:10 ringerc Relationship added related to 0002881
2006-01-23 02:42 avox Status assigned => resolved
2006-01-23 02:42 avox Fixed in Version => 1.3.2
2006-01-23 02:42 avox Resolution open => fixed
2006-01-23 02:42 avox Note Added: 0008283
2006-01-23 02:43 avox Status resolved => closed
2006-06-15 16:10 ringerc Relationship added related to 0003912
2014-10-08 18:38 Kunda Category PPCOSX => OS-PPCOSX