View Issue Details

IDProjectCategoryView StatusLast Update
0002771ScribusStory Editor / Text Framespublic2005-11-08 19:33
Reportermalex Assigned Tomalex  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS Version2.6
Product Version1.3.2cvs 
Target VersionFixed in Version1.3.2cvs 
Summary0002771: Cursor position is not retained on window switch
DescriptionCursor position in the SE is changed to 0 index (before the first character) if I switch from the SE window to some other one such as OO.writer where I copy text to insert it into the SE. This leads to unpleasant surprises when text is pasted right after returning to the SE window. Please store the cursor state instead of reverting it to 0.
Steps To ReproducePaste some text into the SE. Put the cursor somewhere in the middle or at the end of this text. Switch to a different window such as OO.writer (tested) and then switch back. I used Alt+Tab key combination for that. The result - cursor is now in front of the very first character in the SE window.
TagsNo tags attached.
Patch

Relationships

related to 0002169 confirmed Long pauses with new non-modal story editor when working with large amounts of text 
child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

ringerc

2005-10-30 11:03

reporter   ~0007261

Probably caused by the text frame contents reload done by SE whenever focus changes. MrB added this during his work to make the SE non-modal.

ringerc

2005-10-30 11:05

reporter   ~0007262

I can confirm this in current CVS.

cbradney

2005-11-05 13:11

administrator   ~0007335

Seems ok here now.. though I dont know what has changed to fix it.

malex

2005-11-08 17:16

administrator   ~0007375

Yes, I can confirm that the issue is gone as of 2005-11-08 build.

Issue History

Date Modified Username Field Change
2005-10-28 17:11 malex New Issue
2005-10-30 11:03 ringerc Note Added: 0007261
2005-10-30 11:04 ringerc Relationship added related to 0002169
2005-10-30 11:04 ringerc Status new => acknowledged
2005-10-30 11:05 ringerc Note Added: 0007262
2005-10-30 11:05 ringerc Status acknowledged => confirmed
2005-11-05 13:11 cbradney Note Added: 0007335
2005-11-08 17:16 malex Status confirmed => resolved
2005-11-08 17:16 malex Fixed in Version => 1.3.2cvs
2005-11-08 17:16 malex Resolution open => fixed
2005-11-08 17:16 malex Assigned To => malex
2005-11-08 17:16 malex Note Added: 0007375
2005-11-08 19:33 cbradney Status resolved => closed
2007-05-23 21:27 christoph_s Relationship added child of 0003157
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames