View Issue Details

IDProjectCategoryView StatusLast Update
0002790ScribusOS-PPCOSXpublic2005-11-29 17:49
Reporterwordtech Assigned Toavox  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4.3
Product Version1.3.2cvs 
Fixed in Version1.3.2cvs 
Summary0002790: Document windows do not display
DescriptionDocument windows (whether new or previously saved) do not display. Floating palette windows (such as the "pages" window) display as does the preferences and help viewer windows. But the main document window does not display.
Steps To ReproduceOpen a previously saved file or create a new file. The menubar will be visible at the top of the display as is customary on the Mac, but the document window itself will not display, making it impossible to work on the document.
TagsNo tags attached.
Patch

Relationships

related to 0002750 closedmalex Ubuntu Breezy 5.10: Prebuild 1.3.1 deb package harms Gnome desktop 
has duplicate 0002796 closedavox Document windows do not display 
has duplicate 0002819 closedcbradney Page window not visible 

Activities

avox

2005-11-03 18:20

administrator   ~0007318

No idea yet as to what causes this or how to debug it... :-(

acid

2005-11-04 15:48

reporter   ~0007323

Last edited: 2005-11-04 15:56

I have the same Problem. However i found out another little thing:
If you use Expose to view all your open windows, you get the normally hidden windows named "Scribus 1.3.2cvs - Document 1". If you click on the windows using Expose, it will disappear. However, it is not the full document windows, but only some type of header. I will post a file later on to show you

System is MacOS X 10.4.3, Scribus 1.3.2cvs, all files installed and seem to be at the right place.

Edit:
The Screenshot "Scribus-error.jpg" shows the window I get when using expose.

2005-11-04 15:54

 

scribus-error.jpg (4,972 bytes)   
scribus-error.jpg (4,972 bytes)   

juh

2005-11-08 09:42

reporter   ~0007369

I am running
Mac OS X 10.4.3 (8F46)
Darwin 8.3.0

Fink Version: I do not really use fink but I have some package installed. It must be half a year old. Sorry, I never really understood fink.

Nothing special. And I cannot reproduce this bug.

juh

acid

2005-11-08 10:40

reporter   ~0007371

I dont use fink but the native aqua-version

paraplegic_racehorse

2005-11-09 06:18

reporter   ~0007381

Bug is present: no
OSX version: 10.3.9
X11: Apple

mrgrimes

2005-11-10 11:36

reporter   ~0007384

I am having the same problem in Panther (MacOX X 10.3.9).

Something even stranger happened once though: I tried opening Scribus (in some vain hope that it might magically have righted itself) and I got a meesage that too many files were open and some stuff (including Ghostscript) would be disabled. This time - and ONLY this time - the document window DID display. I have tried replicating this a few times (by opening trillions of documents before launching Scribus) but to no avail.

wordtech

2005-11-12 18:22

reporter   ~0007419

I've made some progress on debugging this.

As an experiment, I restored some old preferences files that I had backed up (instead of trashing). Scribus started up fine and all windows displayed properly. Then I backed up the files again and tried to start with some more recent preference files. The problem appeared again.

I can't account for why one set of preferences work and another does not, but I noticed a big difference between the two .scribus folders: in the preferences folder that worked, the scribus13.rc file was 78 megabytes, while the other scribus13.rc file (in the folder that didn't work) was around 80 kilobytes. I tried to open the huge file but it gagged Emacs and Text Edit. There did seem to be a lot of binary data in that file, but I have no idea what it was.

What is the difference between scribus13.rc, prefs13.xml and cfonts.xml? I'm assuming that the prefs and cfonts files are the preferences file and font cache. I am unsure what the rc file is, although it appeared (when I opened it) to also contain preferences settings.

I'm wondering if some folks are unable to reproduce this bug because your preferences files are older and working fine. Perhaps the bug lies somewhere in how the new build is generating default preferences files?

avox

2005-11-12 19:23

administrator   ~0007420

Hm, interesting indeed.

Could you show us the file which is *not* working.
The 78 MB one is broken, even if it helps with this bug (probably the reading of preferences is incomplete in this case).

wordtech

2005-11-12 21:12

reporter   ~0007421

Attached is the file that does not work.

2005-11-12 21:12

 

scribus13.rc (86,212 bytes)

acid

2005-11-12 21:23

reporter   ~0007422

Last edited: 2005-11-12 21:30

I also tried to remove .scribus and let the application renew the files... Also dosn`t work.. Perhaps it is a failure that is written on the file prefs13.xml. If I see this correct, that file configures the Windows of the app with the <context></context> constructs. So, is it possible to change it the way needed? Is it possible?

Quick Edit:

I just edited the file prefs13.xml by hand to view any errors. I just changed the values of all visible Attributes to 1, to see if it will do something for me. Didnt work. All Windows show up, but no main window

rcidesign

2005-11-13 13:51

reporter   ~0007423

Well, the issue is no real bug. As acid reports, the window is really just "hidden". To view the document window, just click the small oval button on the right of the "Scribus 1.3.2" window bar and the window will expand to show the layout space.

acid

2005-11-13 15:30

reporter   ~0007424

Please look at the screenshot i provided. That is in fact the Scribus 1.3.2 window. It is hidden und you cant bring it to the foreground. The screenshot was taken using Exposes Features (pressing F9 to view all Windows). You cant press anything on it... All other optional windows will show up if you click on Windows in the upper Menu. So in fact it is a bug ;)

mrgrimes

2005-11-13 17:20

reporter   ~0007425

Last edited: 2005-11-13 17:23

I can see exactly the thing as acid, but under 10.3.9. The top of the document window appears at the bottom of the screen in Expose, but it disappears when clicked on.

acid

2005-11-14 21:35

reporter   ~0007433

So, the problem itself seems not to be related to 10.4 Tiger but also 10.3 Panther. So, is it possible that some needed applications are in wrong version or not installed? Or there are "wrong" settings in the OS itself?

By the way:
I see in Expose that the hidden window keeps getting "lifted up". I mean you see it in the bottom of your screen, but Expose seems to fetc it from deeper grounds, likely under the dock. So, maybe the full window is somewhere under the dock and that is the reason we dont see it?

I run on a resolution of 1440x900 32bit on my iMac 17" Rev B.

What do other users that have same problems run? Maybe im on the wrong turn but hey, its worth a try isnt it?

avox

2005-11-14 23:06

administrator   ~0007434

Another test:

Look into your ~/.scribus/scribus13.rc and search for a line like:

<MAINWINDOW WIDTH="344" HEIGHT="62" YPOS="0" XPOS="0" />

Change that to

<MAINWINDOW WIDTH="600" HEIGHT="600" YPOS="40" XPOS="40" />

and start Scribus. Any better?

/Andreas

acid

2005-11-15 00:00

reporter   ~0007435

What should i say? I LOVE YOU AVOX!!! ;)

That did the trick! I dont know what was causing it, but something was wrong in the file scribus13.xml. My Statement looks like the following:
<MAINWINDOW WIDTH="600" HEIGHT="600" YPOS="15917" XPOS="15917" />

Well, now we see why we couln't see our windows. They were some (*hehe*) Pixels away from the visible screen. So i was right and the Window is just not where it should be.

But how could that happen? I did nothing on the file, I had the error since I installed scribus... But now it works flawlessly and perfect.

Thank you for your help!

wordtech

2005-11-15 00:26

reporter   ~0007436

This fix works for me as well. Not sure why the prefs file gets written this way, but now I know what to look for if it happens again.

mrgrimes

2005-11-15 08:19

reporter   ~0007437

Perfect! I see the window in Panther now. Thank you!

theodoric

2005-11-15 08:36

reporter   ~0007438

Last edited: 2005-11-15 08:40

hello,

I have the same problem under 10.4.3. ( PWB 17' 1440x900)

I have installed Scribus Aqua (not the fink version) and I can't find "scribus13.rc" or "scribus13.xml" (with spotlight) on my HD.

How can I do to, please?

mrgrimes

2005-11-15 08:53

reporter   ~0007439

Last edited: 2005-11-15 09:03

Now I'm having trouble with the preferences window! It takes a very long time to load, the text all overlaps itself, it appears half-way down the screen,it seems to extend off the right side of the screen forever, and there are no visible buttons for expandin/closing etc.

I also noticed similar mysteries to those wordtech highlighted. My scribus13.rc file also has a lot of what appears to be gobbledegook, although weighing in at 2.5MB it's nowhere near as huge as wordtech's.

The offending lines all appear to start '<SHORTCUT ACTION="' and have VERY long strings of characters something like this: Ç√ɬÇ√ǬÉ√ɬÉ√ǬÉ&0008730
I can attach the file if that's more useful.

mrgrimes

2005-11-15 09:02

reporter   ~0007440

theodoric, the file is in a hidden directory so try this:

1. open Textedit
2. go to file>open
3. hit the '/' key. A box labeled 'Go to the folder:' should appear.
4. Make sure the text field is clear then copy and paste in this: ~/.scribus/scribus13.rc
5. hit the 'Goto' button.

The file should open.

theodoric

2005-11-15 09:29

reporter   ~0007441

Thank you, mrgrimes, for your help.

Now I see the file 's window.

But I have a problem with the preference window, too. It doesn't open; or sometimes, I can't select "Preferences" in the Scribus menu.

?

avox

2005-11-15 21:47

administrator   ~0007449

theodoric: depending on langauge settings the preferences menu is reachable via Edit->Preferences.
Scribus->Preferences then only is a defunct entry added by OSX/Qt automatically but not linked to the rest of Scribus

theodoric

2005-11-15 21:54

reporter   ~0007450

Last edited: 2005-11-15 22:24

thank you, avox.

so, no more problem with the preference window...

elvince7

2005-11-24 11:31

reporter   ~0007524

Hello,

I am facing the same problem : no document window to see. But following the steps to change the MAINWINDOW data in scribus13.rc, I am not able to open the file with Textedit...

Any ideas...

Config. : G4 ; 10.4.3

Elvince7

avox

2005-11-24 16:40

administrator   ~0007525

Elvince7: how large is your scribus13.rc now? We had cases where it grew up to 80 MB which might be a problem for TextEdit.

Anyway, I have hopes that this error is fixed in current cvs. I plan to create a new snapshot this weekend, so you might wait for that.

elvince7

2005-11-25 08:20

reporter   ~0007533

Thanks for your answer... I'll be patient. Cheers.

avox

2005-11-29 17:48

administrator   ~0007579

Nov 26 snapshot uses sane windowsizes and positions

Issue History

Date Modified Username Field Change
2005-11-03 16:57 wordtech New Issue
2005-11-03 18:20 avox Note Added: 0007318
2005-11-03 18:20 avox Assigned To => avox
2005-11-03 18:20 avox Status new => acknowledged
2005-11-04 15:48 acid Note Added: 0007323
2005-11-04 15:54 acid File Added: scribus-error.jpg
2005-11-04 15:56 acid Note Edited: 0007323
2005-11-06 09:49 avox Relationship added has duplicate 0002796
2005-11-08 09:42 juh Note Added: 0007369
2005-11-08 10:40 acid Note Added: 0007371
2005-11-09 06:18 paraplegic_racehorse Note Added: 0007381
2005-11-10 11:36 mrgrimes Note Added: 0007384
2005-11-12 12:16 cbradney Relationship added has duplicate 0002819
2005-11-12 18:22 wordtech Note Added: 0007419
2005-11-12 19:23 avox Note Added: 0007420
2005-11-12 21:12 wordtech Note Added: 0007421
2005-11-12 21:12 wordtech File Added: scribus13.rc
2005-11-12 21:23 acid Note Added: 0007422
2005-11-12 21:30 acid Note Edited: 0007422
2005-11-13 13:51 rcidesign Note Added: 0007423
2005-11-13 15:30 acid Note Added: 0007424
2005-11-13 17:20 mrgrimes Note Added: 0007425
2005-11-13 17:20 mrgrimes Note Edited: 0007425
2005-11-13 17:23 mrgrimes Note Edited: 0007425
2005-11-14 21:35 acid Note Added: 0007433
2005-11-14 23:06 avox Note Added: 0007434
2005-11-15 00:00 acid Note Added: 0007435
2005-11-15 00:26 wordtech Note Added: 0007436
2005-11-15 01:02 mhanski Relationship added related to 0002750
2005-11-15 08:19 mrgrimes Note Added: 0007437
2005-11-15 08:36 theodoric Note Added: 0007438
2005-11-15 08:40 theodoric Note Edited: 0007438
2005-11-15 08:53 mrgrimes Note Added: 0007439
2005-11-15 09:02 mrgrimes Note Added: 0007440
2005-11-15 09:03 mrgrimes Note Edited: 0007439
2005-11-15 09:29 theodoric Note Added: 0007441
2005-11-15 21:47 avox Note Added: 0007449
2005-11-15 21:54 theodoric Note Added: 0007450
2005-11-15 22:24 theodoric Note Edited: 0007450
2005-11-24 11:31 elvince7 Note Added: 0007524
2005-11-24 16:40 avox Note Added: 0007525
2005-11-25 08:20 elvince7 Note Added: 0007533
2005-11-29 17:48 avox Status acknowledged => resolved
2005-11-29 17:48 avox Resolution open => fixed
2005-11-29 17:48 avox Note Added: 0007579
2005-11-29 17:49 avox Status resolved => closed
2005-11-29 17:49 avox Fixed in Version => 1.3.2cvs
2014-10-08 18:38 Kunda Category PPCOSX => OS-PPCOSX