View Issue Details

IDProjectCategoryView StatusLast Update
0002750ScribusGeneralpublic2005-11-30 04:48
Reportermhanski Assigned Tomalex  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86 LinuxOSUbuntuOS Version5.10
Product Version1.3.1 
Target VersionFixed in Version1.3.2cvs 
Summary0002750: Ubuntu Breezy 5.10: Prebuild 1.3.1 deb package harms Gnome desktop
DescriptionThe current 1.3.1 Ubuntu breezy package scribus-cvs_1.3.1+cvs20051003-1_i386.deb from Scribus Debian repository (debian.scribus.net/debian) doesn't work on Ubuntu Breezy and causes harm to the whole Gnome desktop at that.

1. Scribus launches without any window widgets (see the 1st screen shot)

2. Application which are launched afterwards don't have those widgets either (see Gimp on the 2nd screen shot)
TagsNo tags attached.
Patch

Relationships

related to 0002751 closed Scribus and Gnome: setting GUI font size and encoding 
related to 0002790 closedavox Document windows do not display 

Activities

2005-10-21 20:44

 

scribus131_ubuntu.png (101,165 bytes)
scribus131_ubuntu.png (101,165 bytes)

2005-10-21 20:45

 

cbradney

2005-10-21 23:40

administrator   ~0007171

Sounds like an Ubuntu bug to me.

mhanski

2005-10-22 00:37

developer   ~0007176

hi malex, I've just tested your new breezy package from debian.tagancha.org (20051011), the issue is still unsolved

plinnell

2005-10-22 13:48

viewer   ~0007179

I would make a suggestion to install qtconfig if it not installed and change the themes around to see if it changes the widget issue. We have had issues with Fedora Bluecurve and it was a broken theme.

alexandre

2005-10-24 17:47

developer   ~0007199

I've seen this a week ago and it doesn't look like Ubuntu bug, because just 1.3.1 (no CVS) works just fine. I will compile new anoncvs and give it a shot now.

mhanski

2005-10-26 21:43

developer   ~0007222

I've updated to the latest breezy package on debian.scribus.net (1.3.1+cvs2005-1) and made some more tests:

1. The missing widget issue is still there, even worse, scribus crashes with sig#11 on launch.

maciej@pan:~$ LANG=en_EN scribus
Scribus Crash
-------------
Scribus crashes due to Signal 0000011
Calling Emergency Save
Naruszenie ochrony pamieci (memory violation?)

2. I played around with many other Gnome themes (Human, Crux, Simple, etc.) -- it doesn't infuence this odd behaviour.

3. I installed qtconfig, changed the default font to Verdana 10pt and played with it's GUI Styles (Motif, Plantinum, Windows) -- no change apart that the polish fonts displayed correctly in Scribus GUI (see the issue 2751, font size remains still much to large) -- still no window widgets and a crash. BTW, if qtconfig is needed to correctly set up Scribus, shouldn't it be added to the deb package dependencies?

Alex, do you test your breezy packages on a stock breezy distro (default environment after a new installation) or on a patched one? My Breezy is a fresh installation out of the box. I wanted to write a howto for Linux (but not DTP) newbies about setting Scribus on Ubuntu Breezy, but I'm rather stuck right now.

plinnell

2005-10-26 22:47

viewer   ~0007223

i found chatting with Andy Fitz late last night that on his Ubuntu setup it seemed that even though kde was installed, Qt was not picking up the extra style plugins from KDE. So he could not enable Plastik for Scribus. I even walked him through adding the extra style lib directories in qtconfig.

One though on this bug: Can you create a test user and login then load scribus ? It could be something with qt resources getting messed up.

mhanski

2005-10-26 23:40

developer   ~0007224

<quoting>One though on this bug: Can you create a test user and login then load scribus ? It could be something with qt resources getting messed up</quoting>

Peter, I created the new test user, logged in and launched scribus, and it did help indeed -- the widgets are now in place :) Any ideas, how to make it work for the default user from start on?

malex

2005-10-26 23:44

administrator   ~0007225

I am confirming that there is no problem either with Scribus, my breezy scribus-cvs package, or the stock Ubuntu install. I just finished installing Ubuntu Breezy in a qemu image. I installed Gnome and scribus-cvs and didn't have any problems with widgets. As your experience with creating another user shows it is something in your custom settings that creates this problem. I am glad it's not on my side or the Scribus side, or even Ubuntu side as it makes it easier :)

malex

2005-10-26 23:51

administrator   ~0007227

Maciej,

I'm about to close this issue as it's not a bug on our side. Do you have any other comments to add? I am not sure which one of your settings causes this as I run Gnome on my Debian system and in Ubuntu/breezy under qemu and it is fine.

plinnell

2005-10-27 00:00

viewer   ~0007228

try renaming .qt in your home directory

This does not solve the issue of why it is not correct in the first place, but at least removes Scribus from the issue.

mhanski

2005-10-27 00:05

developer   ~0007229

Alex, please don't close as long as we are not really sure what is it about. Have you installed qtconfig-qt3 before Scribus installation? Scribus worked for the other user after previous qtconfig installation -- is qtconfig needed by Scribus on Ubuntu/Gnome or not? If yes, would you mind adding it to the dependencies? As I see it, we need it anyway to properly set the GUI font for Scribus on Gnome.

BTW, my "custom settings that creates this problem" were default settings after first install, Scribus was one of the first packages I installed, so expect more users like me.

2005-10-27 06:41

 

scribus_prefs.tar.gz (22,484 bytes)

mhanski

2005-10-27 06:50

developer   ~0007231

I think, I know now what has happened.

I renamed my .scribus directory (see the attached file) in my home directory to .scribus_old and launched scribus once again: everything worked fine:) I renamed it back to .scribus, and the odd behaviour was there again.

Steps to reproduce:
1. I first installed the scribus 1.23 breezy package from Alex' repository, to see if it works.
2. It worked, so I deinstalled it again and installed the breezy 1.3.1+cvs package.
3. Launched Scribus > odd behaviour + crashes

You could alternatively take my .scribus directory and see what happens on your system.

malex

2005-10-27 17:11

administrator   ~0007240

Maciej,

This is the problem line you had in your ~/.scribus/scribus13.rc file:

<MAINWINDOW WIDTH="32767" HEIGHT="32767" YPOS="23" XPOS="5" />

once those numbers are changed to something sensible like 800, 600, 100, 300 Scribus started up just fine. I will close this bug after I try to persuade Craig or somebody else to implement some sort of boundary check for the window parameters. This is important since such behavior keeps coming up regularly on the IRC and the ML.

avox

2005-11-23 22:43

administrator   ~0007521

malex: I committed some sanitychecks for windowpos in 1.3.2cvs prefsmanager.cpp.

Can you test if this solves the problem for Ubuntu?

malex

2005-11-29 23:18

administrator   ~0007583

I've tested last night's build (2005-11-29) on Ubuntu breezy and it started just fine with Maciej's scribus13.rc file. The only message produced at the console was: "QComboBox::changeItem: (LY) Index 0 out of range. I think avox resolved this bug. When I closed Scribus and looked at the scribus13.rc files I found out that <MAINWINDOW WIDTH="1024" HEIGHT="768" YPOS="26" XPOS="5" /> was appropriate and aparently set by avox's function. Maciej, please test and respond here if you still find something. Otherwise I'll close the bug.

mhanski

2005-11-30 00:52

developer   ~0007584

Last edited: 2005-11-30 00:53

I've just tested it, all is fine now.

So we've finally reached the point, when it's time to say: thank you Malex and Avox for solving this initially not so obvious bug :)

malex

2005-11-30 04:48

administrator   ~0007585

Thanks to Avox, we beat this one.

Issue History

Date Modified Username Field Change
2005-10-21 20:44 mhanski New Issue
2005-10-21 20:44 mhanski File Added: scribus131_ubuntu.png
2005-10-21 20:45 mhanski File Added: scribus131_and_gimp_on_ubuntu.png
2005-10-21 23:40 cbradney Note Added: 0007171
2005-10-22 00:34 mhanski Status new => assigned
2005-10-22 00:34 mhanski Assigned To => malex
2005-10-22 00:37 mhanski Note Added: 0007176
2005-10-22 13:48 plinnell Note Added: 0007179
2005-10-24 17:47 alexandre Note Added: 0007199
2005-10-26 21:43 mhanski Note Added: 0007222
2005-10-26 21:43 mhanski Relationship added related to 0002751
2005-10-26 22:47 plinnell Note Added: 0007223
2005-10-26 23:40 mhanski Note Added: 0007224
2005-10-26 23:44 malex Note Added: 0007225
2005-10-26 23:51 malex Note Added: 0007227
2005-10-26 23:51 malex Status assigned => feedback
2005-10-27 00:00 plinnell Note Added: 0007228
2005-10-27 00:05 mhanski Note Added: 0007229
2005-10-27 06:41 mhanski File Added: scribus_prefs.tar.gz
2005-10-27 06:50 mhanski Note Added: 0007231
2005-10-27 17:11 malex Status feedback => resolved
2005-10-27 17:11 malex Fixed in Version => 1.3.2cvs
2005-10-27 17:11 malex Resolution open => fixed
2005-10-27 17:11 malex Note Added: 0007240
2005-10-27 18:57 avox Status resolved => assigned
2005-10-27 18:57 avox Assigned To malex => avox
2005-11-15 01:02 mhanski Relationship added related to 0002790
2005-11-23 22:42 avox Assigned To avox => malex
2005-11-23 22:43 avox Note Added: 0007521
2005-11-29 23:18 malex Note Added: 0007583
2005-11-30 00:52 mhanski Note Added: 0007584
2005-11-30 00:53 mhanski Note Edited: 0007584
2005-11-30 04:48 malex Status assigned => closed
2005-11-30 04:48 malex Note Added: 0007585