View Issue Details

IDProjectCategoryView StatusLast Update
0002954ScribusGraphics / Image Framespublic2006-07-18 21:34
Reporterchristoph_s Assigned Tocbradney  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformallOSallOS Versionall
Product Version1.3 
Target VersionFixed in Version 
Summary0002954: Picture frames should keep the behaviour set in the properties palette
DescriptionWhen a picture is moved and the path has been reset in the "Manage Pictures" dialog, the settings made in the properties palette should remain intact. If Scribus would just compare size resolution and perhaps name of the image, no resizing would be necessary at all, which will be in the user's interest most of the time.
Additional InformationFrom the mailing list:
>>>>Anyway, it is an interesting question if image frames should keep the
>>>>behaviour chosen in the properties palette or if they should switch back
>>>>to default after changing the content.
>
>>
>>
>> What about a dialog box that asks "Restore Properties to default? (Y/N)" if the
>> properties are not at the default and the image is changed. Best of both
>> worlds, as it were.


Perhaps. It's not necessarily a useful prompt, though, when Scribus
should be able to figure it out its self 95% of the time. All we should
really need to do is compare the image dimensions and resolution, and if
they're the same we can make the reasonable assumption that the user
probably just moved the image, or is replacing it with one they'd
probably like to be positioned the same.

Sure, it'll be wrong some of the time, but the user can easily just fix
those odd cases. I suspect it'd be a lot better than bugging them with a
dialog all the time.

--
Craig Ringer
TagsNo tags attached.
Patch

Relationships

duplicate of 0003190 closedfschmid Manage Pictures: position and size of pictures that are found again are reset 

Activities

ringerc

2006-04-15 18:42

reporter   ~0010015

mhanski: I'm too busy with other things to even consider implementing this, and don't have much else to offer on this. Is there anything in particular you wanted my input on?

mhanski

2006-04-15 19:04

developer   ~0010016

ringerc: no input necessary, please keep doing other things:)

I only wanted to add you to monitoring users, because this rfe refers to your mail . Some time, when you have more time, you may want to set the status to "acknowledged" or "won't fix".

mhanski

2006-04-29 20:21

developer   ~0010633

jo-hannes: this one seems pretty much identical to your 0003190 -- which one do you like more: the bug or the feature?

Issue History

Date Modified Username Field Change
2006-01-02 22:38 christoph_s New Issue
2006-01-16 22:47 plinnell Product Version 1.3.2cvs => 1.3.3cvs
2006-01-28 00:08 jo-hannes Severity minor => feature
2006-04-15 17:17 mhanski Product Version 1.3.3cvs => 1.3
2006-04-15 18:42 ringerc Note Added: 0010015
2006-04-15 19:04 mhanski Note Added: 0010016
2006-04-29 20:16 mhanski Relationship added related to 0003190
2006-04-29 20:21 mhanski Note Added: 0010633
2006-04-29 20:21 mhanski Status new => feedback
2006-07-18 21:31 cbradney Relationship replaced duplicate of 0003190
2006-07-18 21:31 cbradney Duplicate ID 0 => 3190
2006-07-18 21:31 cbradney Status feedback => resolved
2006-07-18 21:31 cbradney Resolution open => duplicate
2006-07-18 21:31 cbradney Assigned To => cbradney
2006-07-18 21:33 cbradney Status resolved => closed
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames