View Issue Details

IDProjectCategoryView StatusLast Update
0003424ScribusStory Editor / Text Framespublic2007-12-20 21:11
Reportermkoren Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSDebian LinuxOS VersionStable/Testing
Product Version1.3.3cvs 
Target VersionFixed in Version1.3.5svn 
Summary0003424: coordinates in properties still display wrong for multiple selections/groups
DescriptionIf you select a group of objects, the x coordinates display wrong and y seems to go to absolute rather than page coordinates (big numbers). I've seen some of this in the past for single objects, but it was fixed. Clicking on the object again sets right values, but it goes off again if you change the basepoint.
Sorry if this has already been reported this time; I thought I saw it somewhere before but I didn't see it in the bug list just now.
TagsNo tags attached.
Patch

Relationships

has duplicate 0004763 closedchristoph_s Base Point in Properties initial shows semi-random values on selected stacked objects 
related to 0003609 closedcbradney lock/unlock multiple objects in properties messes up coordinate display 
child of 0003812 acknowledged Metabug: Grouped objects 

Activities

cbradney

2006-03-15 06:33

administrator   ~0009290

Seems ok here.. two created frames on one page, selecting both gives me the correct x,y. Not that I think this area has changed but please check for deb updates as they should be being updated daily now.

mhanski

2006-04-20 09:19

developer   ~0010166

tested with scribus 1.3.3.1, works fine

mkoren: feel free to reopen, if you can provide steps to reproduce the issue, a screen shot would be very helpful in this case

mkoren

2006-04-22 02:34

reporter   ~0010287

It's changing the basepoint that does it. Create two frames; select; change basepoint -> wrong x,y. See first screenshot (I just changed basepoint back to left--should read (98,64) ).

There are other similar display errors too. Toggling any of the lock/flip/visibility family of buttons for groups sets coordinate display to (0,0,1,1) as described in bug 0003609 (see second screenshot).

Coordinates are also incorrectly displayed after adjusting the coordinates of a line in "endpoints" mode, but the behavior is completely messed up generally there (see 0003592--point 3 and the last two screenshots for this).

2006-04-22 02:35

 

wrong_coords.png (47,374 bytes)
wrong_coords.png (47,374 bytes)

2006-04-22 02:35

 

wrong_coords2.png (45,175 bytes)
wrong_coords2.png (45,175 bytes)

2006-04-22 02:36

 

line_before.png (46,153 bytes)
line_before.png (46,153 bytes)

2006-04-22 02:36

 

line_after.png (45,777 bytes)
line_after.png (45,777 bytes)

jo-hannes

2006-12-21 10:43

developer   ~0014138

confirmed with 1.3.4cvs

christoph_s

2007-12-20 21:11

administrator   ~0018374

Tested, fixed. Thanks.

Issue History

Date Modified Username Field Change
2006-03-15 04:48 mkoren New Issue
2006-03-15 06:33 cbradney Note Added: 0009290
2006-04-20 09:19 mhanski Status new => closed
2006-04-20 09:19 mhanski Note Added: 0010166
2006-04-20 09:19 mhanski Resolution open => unable to reproduce
2006-04-22 02:34 mkoren Status closed => feedback
2006-04-22 02:34 mkoren Resolution unable to reproduce => reopened
2006-04-22 02:34 mkoren Note Added: 0010287
2006-04-22 02:35 mkoren File Added: wrong_coords.png
2006-04-22 02:35 mkoren File Added: wrong_coords2.png
2006-04-22 02:36 mkoren File Added: line_before.png
2006-04-22 02:36 mkoren File Added: line_after.png
2006-05-04 11:29 mhanski Relationship added related to 0003609
2006-05-13 17:00 christoph_s Relationship added child of 0003812
2006-12-21 10:43 jo-hannes Note Added: 0014138
2006-12-21 10:43 jo-hannes Status feedback => confirmed
2007-12-14 21:43 cbradney Status confirmed => assigned
2007-12-14 21:43 cbradney Assigned To => fschmid
2007-12-14 21:43 cbradney Status assigned => resolved
2007-12-14 21:43 cbradney Fixed in Version => 1.3.5svn
2007-12-14 21:43 cbradney Resolution reopened => fixed
2007-12-20 21:11 christoph_s Status resolved => closed
2007-12-20 21:11 christoph_s Note Added: 0018374
2008-02-06 14:59 christoph_s Relationship added has duplicate 0004763
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames