View Issue Details

IDProjectCategoryView StatusLast Update
0003592ScribusUsabilitypublic2016-05-18 14:09
Reportermkoren Assigned ToKunda  
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionno change required 
PlatformanyOSanyOS Versionany
Product Version1.3.3 
Target VersionFixed in Version 
Summary0003592: Setting line geometry properties display errors
DescriptionI'm running into a few difficulties setting accurate line geometry properties:

3) The tooltips are wrong when the above combobox is set to "endpoints" (they still say width, height, etc.) and switching to another frame and back in this mode causes the fourth field to become grayed out and inaccessible. I believe this setting may be incorrectly being transferred from the other line basepoint mode (along with the tooltips), where that field is height and does not apply to lines.

This special case extra mode for lines might be removable if both bounding box and frame/shape nodes (here line endpoints) could be used as basepoints for all frames (see 0003591).
Tagsbasepoint, tooltips
Patch

Relationships

related to 0007287 new Add to ability change basepoint of lines 
related to 0000689 closedjghali basepoint of lines cannot be set 
related to 0003751 new additional/clearer basepoint options for lines 
related to 0003752 new move or replace hidden line basepoint setting in properties 
related to 0003612 closedjghali Changing width or height of rotated items behaves inconsistently depending on basepoint 
child of 0003821 acknowledged Metabug: Usability 

Activities

mkoren

2006-04-09 21:06

reporter   ~0009767

Last edited: 2016-02-15 22:37

View 2 revisions

I've submitted separate reports for points 1 (see 0000689 & 0003751 & 0007287) and 2 (see 0003752).

mkoren

2006-05-04 20:37

reporter   ~0010920

For point 3, everything seems to work wrong when the "basepoint" option in the lines tab is set to "endpoints": tooltips, changing coordinates, display.... You'll have to try it to see.

Also look at the last two screenshots in bug 0003424 for an example of incorrect behavior when changing coordinates.

mhanski

2006-05-06 22:34

developer   ~0011032

I have looked:
-- Tooltips are wrong: which tab/which fields? What would be the correct ones?

christoph_s

2006-05-06 22:46

administrator   ~0011034

>>>This special case extra mode for lines might be removable if both bounding box and frame/shape nodes (here line endpoints) could be used as basepoints for all frames

Exactly. The current approach seems quite clumsy to me. From a usability point of view, this needs improvement.

Kunda

2015-06-25 23:30

manager   ~0035514

Looks like the report was edited and removed issues that were fixed. So the context is hard to understand. Can someone help me understand if this issue is still relevant?

Kunda

2016-05-05 15:13

manager   ~0040786

I'm uploading an image of the line geometry tab in the PP. Can someone point out where OP is referring to in point 3) in the summary?

Kunda

2016-05-05 15:14

manager  

line-geometry-tab.png (46,906 bytes)
line-geometry-tab.png (46,906 bytes)

Kunda

2016-05-05 15:14

manager   ~0040787

Christoph, can you shed some light on this?

Kunda

2016-05-17 22:59

manager   ~0041173

Closing per christoph's request:
>> I suggest closing 3592. It has been so heavily edited that it's no longer clear what mkoren originally meant.

Issue History

Date Modified Username Field Change
2006-04-09 04:00 mkoren New Issue
2006-04-09 21:06 mkoren Note Added: 0009767
2006-04-29 19:31 mhanski Relationship added related to 0003612
2006-05-02 21:50 mhanski Status new => feedback
2006-05-04 20:13 mkoren Note Edited: 0009767
2006-05-04 20:25 mkoren Note Edited: 0009767
2006-05-04 20:37 mkoren Note Added: 0010920
2006-05-06 22:16 mhanski Summary difficult and confusing to set line geometry => Setting line geometry properties display errors
2006-05-06 22:16 mhanski Description Updated
2006-05-06 22:34 mhanski Note Added: 0011032
2006-05-06 22:46 christoph_s Note Added: 0011034
2006-05-06 22:54 mhanski Status feedback => confirmed
2006-05-15 18:05 christoph_s Relationship added child of 0003821
2014-09-16 11:09 Kunda Relationship added related to 0007287
2014-09-16 11:09 Kunda Relationship added related to 0000689
2014-09-16 11:10 Kunda Relationship added related to 0003751
2014-09-16 11:11 Kunda Relationship added related to 0003752
2015-06-25 23:30 Kunda Note Added: 0035514
2016-02-15 22:37 Kunda Note Edited: 0009767 View Revisions
2016-04-08 17:46 Kunda Tag Attached: basepoint
2016-05-05 15:13 Kunda Note Added: 0040786
2016-05-05 15:14 Kunda File Added: line-geometry-tab.png
2016-05-05 15:14 Kunda Note Added: 0040787
2016-05-05 15:15 Kunda Tag Attached: tooltips
2016-05-05 15:15 Kunda Tag Attached: #pending
2016-05-17 22:59 Kunda Note Added: 0041173
2016-05-17 23:00 Kunda Status confirmed => resolved
2016-05-17 23:00 Kunda Resolution open => no change required
2016-05-17 23:00 Kunda Assigned To => Kunda
2016-05-18 07:32 christoph_s Status resolved => closed
2016-05-18 14:09 Kunda Tag Detached: #pending