View Issue Details

IDProjectCategoryView StatusLast Update
0003625ScribusGeneralpublic2008-01-29 23:34
Reporterchristoph_s Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinuxOS VersionSuSE 9.3/10.0
Product Version1.3.4cvs 
Fixed in Version1.3.5svn 
Summary0003625: The longer Scribus is running in the background, the longer it takes to reappear
DescriptionThis is true for all 1.3x versions I have used by now, including 1.3.4cvs. Sometimes it takes 10 seconds or more to completely redraw the interface. It's not an issue of 1.2. versions.

UI is KDE 3.4.
TagsNo tags attached.
Patch

Relationships

child of 0003432 closed Scribus 1.3.x: low performance 

Activities

cbradney

2006-04-11 21:46

administrator   ~0009819

Sounds simply like its being paged out of memory...

christoph_s

2006-04-11 21:51

administrator   ~0009820

Hmmm, then why is Scribus the only app that shows that effect? Even the much bigger OO.o is back without delay, same with Mozilla or Adobe Reader.

ringerc

2006-04-12 03:38

reporter   ~0009824

christoph_s: Is OO.o really that much bigger in terms of memory use? Scribus can eat a lot of memory. This sounds a lot, as cbradney says, like Scribus is just being paged out and must be pulled back into memory before it can respond.

It's also possible that because of Scribus's code structure and the way it uses its data, it needs to be more completely paged in before it can draw. Either way, I don't see that it's a Scribus issue - at least one that can be realistically addressed at this point.

I'm inclined to close this as `no change required'

christoph_s

2006-04-12 18:49

administrator   ~0009866

I'm not sure, but OO.o and Mozilla are really "fat" apps. What seems strange to me is that the issue is only with Scribus 1.3x, not 1.2x. Moreover, the Scribus docs need not be large. An empty page is enough to cause this behaviour.

christoph_s

2006-06-07 22:41

administrator   ~0011599

Same with SuSE 10.1. With many apps open, it may take _minutes_ for Scribus 1.3 to redraw the interface, even after a memory upgrade (1536 MB).

christoph_s

2008-01-29 23:34

administrator   ~0018771

Working now.

Issue History

Date Modified Username Field Change
2006-04-11 21:31 christoph_s New Issue
2006-04-11 21:34 mhanski Relationship added child of 0003432
2006-04-11 21:46 cbradney Note Added: 0009819
2006-04-11 21:51 christoph_s Note Added: 0009820
2006-04-12 03:38 ringerc Note Added: 0009824
2006-04-12 03:38 ringerc Status new => acknowledged
2006-04-12 18:49 christoph_s Note Added: 0009866
2006-06-07 22:41 christoph_s Note Added: 0011599
2008-01-29 23:06 cbradney Status acknowledged => resolved
2008-01-29 23:06 cbradney Fixed in Version => 1.3.5svn
2008-01-29 23:06 cbradney Resolution open => fixed
2008-01-29 23:06 cbradney Assigned To => cbradney
2008-01-29 23:34 christoph_s Status resolved => closed
2008-01-29 23:34 christoph_s Note Added: 0018771