View Issue Details

IDProjectCategoryView StatusLast Update
0004050ScribusGeneralpublic2008-01-30 19:46
Reporterlkcl Assigned Toavox  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.3.2cvs 
Target VersionFixed in Version1.3.4cvs 
Summary0004050:  isn't a valid xml character and should not be used in the SLA format
DescriptionThe Scribus file format uses a character that is not legal in XML documents to represent paragraph breaks. The resulting documents are not well formed and can not be valid XML, causing standards compliant parsers to fail.

Original reporter:

in order to parse the .sla document with python's sax module, i've had
to write some xxxxing stupid file-object-parser which pre-processes your
inability to stick to simple XML specifications which state that you _cannot_
have a &#xNN value less than 0x20.

please pick a different character - preferably something daft like 0x7f - as
your end-of-paragraph character - in order that you can output well-formed
XML and i and other people can actually friggin read the XML and do things
like create an HTML converter.
Steps To ReproduceAttempting to parse a Scribus document in a standards compliant parser will fail the well-formedness check. Try the xsltproc tool, Python's XML modules, etc.
Additional InformationThis breaks parsers that check for well-formedness (ie anything but Qt3's dodgy parser) and makes it very hard to write tools to process the SLA format.

This bug has been known for some time ; it will be fixed as part of the new file format work. At the same time a major cleanup of the format will be done, making it practical to actually work with it (the current format not being too friendly).

[unhelpful and rude comments by original reporter deleted - CR]
TagsNo tags attached.
Patch

Relationships

duplicate of 0001668 closedcbradney certain nonvalid (for xml) characters appear in scribus internal document format 
child of 0002098 acknowledged Metabug: New File Format 

Activities

lkcl

2006-07-22 14:18

reporter   ~0011960

hm... where's the means for me to change the priority to "low" on this interface, after having created the bug report?

avox

2006-07-22 21:37

administrator   ~0011962

We don't claim Scribus 1.2 -- 1.3.3 fileformat is pure XML, and we know about the  issue.

lkcl

2006-07-23 02:31

reporter   ~0011967

k. cool. glad to hear you know about it.

here's the thing: this is a complete show-stopper for people (like myself)
to write converters.

it's _critical_ that you stick to the XML specification.

doing this sort of thing is _ridiculous_:

    def read(self, size):

        if size > len(self.buf):
            txt = self.f.read(size+5)
            self.buf += txt
            while 1:
                loc = self.buf.find('')
                if loc >= 0:
                    self.buf = self.buf[:loc] + '' + self.buf[loc+5:]
                else:
                    break
        ret = self.buf[:size]
        self.buf = self.buf[size:]
        return ret

just so i can get it to pass through the python xml handlers.
if you want other people to create addons for scribus - sla2html etc.
you've _got_ to get this fixed. make it &#x7f instead - that's
a valid xml character - _anything_.

avox

2006-07-23 11:55

administrator   ~0011968

It will be u2028 and u2029 in the future. I hope you don't mind UTF-8 :-)

lkcl

2006-07-23 12:03

reporter   ~0011970

yaay! hell, no, don't care at all!

ringerc

2006-07-23 15:20

reporter   ~0011975

lkcl: This is a known issue; it will be fixed with the new file format and not before.

ringerc

2006-07-23 15:22

reporter   ~0011976

Last edited: 2006-07-23 15:30

Additionally, I strongly suggest you be more polite in future. Swearing at the team is not a helpful way to achieve anything. Especially since I think everybody has explained the situation on the mailing lists at least once, and there was already a bug in the tracker if you'd merely bothered to search for it.

Rudeness doesn't help.

cbradney

2006-07-23 19:36

administrator   ~0011987

We are well aware of this, we will fix it. We never claimed we were writing XML compliant files, only XML based. This is not a bug, and we never suggested anyone should write a converter, feel free to do that when the new format is written.

avox

2008-01-30 19:44

administrator   ~0018792

This is fixed with the 1.3.4 file format.

Issue History

Date Modified Username Field Change
2006-07-22 14:17 lkcl New Issue
2006-07-22 14:18 lkcl Note Added: 0011960
2006-07-22 21:37 avox Note Added: 0011962
2006-07-22 21:37 avox Priority normal => low
2006-07-22 21:37 avox Severity major => tweak
2006-07-22 21:37 avox Projection none => major rework
2006-07-22 21:37 avox Summary  isn't a valid xml character. use something else, damnit! =>  isn't a valid xml character. use something else, please!
2006-07-23 02:31 lkcl Note Added: 0011967
2006-07-23 11:55 avox Note Added: 0011968
2006-07-23 12:03 lkcl Note Added: 0011970
2006-07-23 15:20 ringerc Note Added: 0011975
2006-07-23 15:21 ringerc Relationship added child of 0002098
2006-07-23 15:22 ringerc Note Added: 0011976
2006-07-23 15:23 ringerc Status new => confirmed
2006-07-23 15:28 ringerc Summary  isn't a valid xml character. use something else, please! =>  isn't a valid xml character and should not be used in the SLA format
2006-07-23 15:28 ringerc Description Updated
2006-07-23 15:28 ringerc Steps to Reproduce Updated
2006-07-23 15:28 ringerc Additional Information Updated
2006-07-23 15:29 ringerc Relationship added duplicate of 0001668
2006-07-23 15:30 ringerc Note Edited: 0011976
2006-07-23 19:36 cbradney Status confirmed => closed
2006-07-23 19:36 cbradney Note Added: 0011987
2006-07-23 19:36 cbradney Resolution open => suspended
2006-07-23 23:33 ringerc Resolution suspended => duplicate
2008-01-30 19:44 avox Note Added: 0018792
2008-01-30 19:46 avox Assigned To => avox
2008-01-30 19:46 avox Resolution duplicate => fixed
2008-01-30 19:46 avox Fixed in Version => 1.3.4cvs