View Issue Details

IDProjectCategoryView StatusLast Update
0004224ScribusPDFpublic2006-09-06 21:07
Reporterarguile Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformAMD OpteronOSLinuxOS VersionKernel 2.6.12
Product Version1.3.3.3 
Target VersionFixed in Version 
Summary0004224: AcroForm fields not properly exporting non-core face face styling.
DescriptionIf you specify a font face on a field (using the properties palette) Scribus shows any values in that font face and properly lists it for embedding.

Upon export to PDF 1.4 or 1.5 however, the font-face in the DA key (default appearance) references the "Font for use with PDF 1.3" font from the field properties.

  eg. DA => '/Helv 12.00000 Tf <colour info>'


Thanks
Steps To Reproduce1. Create a new document
2. Add an AcroForm text field
3. In the 'Properties' (not 'Field Properties') palette assign a non-core font.
4. Export to PDF (> 1.3)
Additional InformationAdobe PDF 1.4 Reference Section 8.6.2 Page 534 Tabel 8.5.1 ( http://partners.adobe.com/public/developer/en/pdf/PDFReference.pdf) defines that any text or graphics state operators are valid (meaning embedded fonts are fair game).
TagsNo tags attached.
Patch

Relationships

duplicate of 0003282 closedfschmid Fonts don't work with text fields of forms. 

Activities

arguile

2006-09-06 17:24

reporter   ~0012453

Oops, it seems bug 3282 (http://bugs.scribus.net/view.php?id=3282) already existed describing this issue.

I'd mark this as duplicate if I could. Sorry for the inconvenience.

Issue History

Date Modified Username Field Change
2006-09-06 17:21 arguile New Issue
2006-09-06 17:24 arguile Note Added: 0012453
2006-09-06 17:32 plinnell Relationship added related to 0003282
2006-09-06 18:22 mhanski Relationship replaced duplicate of 0003282
2006-09-06 18:24 mhanski Status new => resolved
2006-09-06 18:24 mhanski Resolution open => duplicate
2006-09-06 21:07 cbradney Status resolved => closed