View Issue Details

IDProjectCategoryView StatusLast Update
0003282ScribusPDFpublic2007-02-04 15:24
ReporterSirElvis Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformanyOSanyOS Versionany
Product Version1.3 
Target VersionFixed in Version1.3.4cvs 
Summary0003282: Fonts don't work with text fields of forms.
DescriptionWhen creating a PDF form and applying a font to a text field, the resulting PDF doesn't use this font but rather falls back to the font that is specified in "PDF Options > Field Properties > Font for use with PDF 1.3" even when exporting as PDF 1.4 or 1.5. It doesn't matter if the font is embedded or not.

Since I can change the font of the text field in Acrobat Professional under Windows and this results in changed font even under Linux, I think this must be a problem with Scribus.
Steps To Reproduce1. Create a document with a PDF form text field on it.
2. Set a font for the text field (in Properties), for example use "Verdana Italic".
3. Set the fallback font (in PDF Options > Field Propterties) to another font (for example Courier).
4. Export the PDF as version 1.5.
5. Open it with acroread and look at the text field, it uses the second font (Courier in my example).

To verify even further:

6. Boot Windows, start Acrobat Professional and load the created document. The text field will also use the second font.
7. Use the "Select Object Tool" and select the text field, then click right and open the Properties.
8. Go the the Appearance tab and change the font from the second one (Courier) to the first (Verdana Italic).
9. Save, boot Linux, open with acroread and note that this time the first font is used.
TagsNo tags attached.
Patch

Relationships

related to 0000866 closedfschmid Implement check box radio behaviour in PDF forms 
related to 0003180 closedfschmid checkboxes are badly exported to PDF 
related to 0003964 closedplinnell 1.3.4 Release Metabug 
has duplicate 0004224 closed AcroForm fields not properly exporting non-core face face styling. 
related to 0005408 closedfschmid Generated PDF-form doesn't show/accept äöüÄÖÜ 
child of 0003831 acknowledged Metabug: PDF Forms 

Activities

mhanski

2006-04-17 16:43

developer   ~0010065

confirmed with scribus 1.3.3.1

tkejzlar

2006-04-19 16:29

reporter   ~0010125

For me fonts do not work for select boxes and lists of forms as well. Using Scribus 1.3.3.1.

mhanski

2006-04-22 20:43

developer   ~0010332

it needs yet some refinement. See the attached pdf 1.4 forms with embedded TTF and Type1 fonts -- I've used them for text fields and buttons, but they don't look good yet.

2006-04-22 20:44

 

testform_bookman_italic.pdf (120,270 bytes)

2006-04-22 20:44

 

testform_trebuchet_bold_italic.pdf (93,788 bytes)

2006-04-22 20:45

 

testform.sla (46,078 bytes)

2006-04-22 20:46

 

testform_bookman.sla (46,098 bytes)

2006-05-04 19:27

 

fschmid

2006-05-21 11:30

administrator   ~0011396

Have made some more fixes now. But there seems to exist a bug with Acrobat Reader 7. With Acrobat Reader 5 text fields use the provided fonts but i can't urge AR 7 to use the fonts, whatever i try.

2006-05-21 20:48

 

20060521_form.pdf (412,313 bytes)

mhanski

2006-05-21 21:10

developer   ~0011404

hmm, this one seems to be quite a tough issue. I've just played with creating forms in today's 1.3.4cvs, it's unusable for the time being -- Scribus keeps creating blank PDF files instead of forms, although every now and then a form will be created. The font issue has worsened in Acroread 7.0.1: now the kerning is messed up _and_ the font face is ignored.

I've uploaded a sample pdf form, will have a look at it in various acroread versions and see if it can be fixed with Acrobat. Franz, if you need any specific help and tests, please just let me know.

fschmid

2006-05-22 08:10

administrator   ~0011407

> I've just played with creating forms in today's 1.3.4cvs, it's unusable for
> the time being -- Scribus keeps creating blank PDF files instead of forms,
> although every now and then a form will be created.
This should be fixed now with current CVS, but i don't think that i can fix the main issue easily.

2006-05-23 15:43

 

20060523_form_corrected.pdf (674,646 bytes)

mhanski

2006-05-23 15:55

developer   ~0011431

Franz, I opened the last test form (20060521_form.pdf) in Acrobat Pro 6.0 and had a look at the 3 problematic fields. The font face of all three fields was TimesNewRomanPSMT, although I clearly remember having assigned to them 3 different font faces. It looks as if Scribus would override font faces chosen by the user.

I corrected those font faces in Acrobat Pro, saved the form, and everything works as expected in Acroread 7 (see the uploaded 20060523_form_corrected.pdf): kerning and font faces are fine.

fschmid

2006-05-24 21:50

administrator   ~0011456

Have downloaded the corrected pdf and looked how Acrobat Pro does the fields. Surprise, its exactly the same code in the PDF as Scribus does. The only difference is that you have used TrueType fonts.

After that i've made some more tests, results:
1) Avox seems to have broken the Font setting code in the moment.
2) With a pdf i've adjusted by hand with an Hex Editor i noticed that the setting
   of Fonts for Textfields works only with TrueType Fonts, Type1 aren't working.

mhanski

2006-05-24 22:14

developer   ~0011458

fschmid, thanks for your investigation, good to know the issue has become somewhat clearer. As soon as the font setting code works and kerning in form fields looks normally, we will have no trouble telling users they should use TTF only.

fschmid

2007-02-02 09:27

administrator   ~0015075

Remaining Issues should be fixed now.

mhanski

2007-02-04 15:23

developer   ~0015087

Tested with PS und TTF fonts in form fields, works fine, congratulations, closing

Issue History

Date Modified Username Field Change
2006-02-23 12:12 SirElvis New Issue
2006-04-17 16:43 mhanski Note Added: 0010065
2006-04-17 16:43 mhanski Status new => confirmed
2006-04-17 16:44 mhanski OS Gentoo Linux => any
2006-04-17 16:44 mhanski OS Version N/A => any
2006-04-17 16:44 mhanski Platform x86 => any
2006-04-17 16:44 mhanski Product Version 1.3.2 => 1.3
2006-04-17 18:19 cbradney Status confirmed => assigned
2006-04-17 18:19 cbradney Assigned To => fschmid
2006-04-19 16:29 tkejzlar Note Added: 0010125
2006-04-19 17:24 mhanski Relationship added related to 0000866
2006-04-19 17:26 mhanski Relationship added related to 0003180
2006-04-22 12:51 fschmid Status assigned => resolved
2006-04-22 12:51 fschmid Fixed in Version => 1.3.4cvs
2006-04-22 12:51 fschmid Resolution open => fixed
2006-04-22 20:43 mhanski Status resolved => feedback
2006-04-22 20:43 mhanski Resolution fixed => reopened
2006-04-22 20:43 mhanski Note Added: 0010332
2006-04-22 20:44 mhanski File Added: testform_bookman_italic.pdf
2006-04-22 20:44 mhanski File Added: testform_trebuchet_bold_italic.pdf
2006-04-22 20:45 mhanski File Added: testform.sla
2006-04-22 20:46 mhanski File Added: testform_bookman.sla
2006-05-02 09:32 mhanski Severity minor => major
2006-05-04 19:27 mhanski File Added: messed_up_kerning_in_form_fields.png
2006-05-04 19:28 mhanski Status feedback => assigned
2006-05-17 17:46 mhanski Relationship added child of 0003831
2006-05-21 11:30 fschmid Note Added: 0011396
2006-05-21 20:48 mhanski File Added: 20060521_form.pdf
2006-05-21 21:10 mhanski Note Added: 0011404
2006-05-22 08:10 fschmid Note Added: 0011407
2006-05-23 15:43 mhanski File Added: 20060523_form_corrected.pdf
2006-05-23 15:55 mhanski Note Added: 0011431
2006-05-24 21:50 fschmid Note Added: 0011456
2006-05-24 22:14 mhanski Note Added: 0011458
2006-09-06 17:32 plinnell Relationship added related to 0004224
2006-09-06 18:22 mhanski Relationship replaced has duplicate 0004224
2006-11-15 22:33 plinnell Relationship added related to 0003964
2007-02-02 09:27 fschmid Status assigned => resolved
2007-02-02 09:27 fschmid Resolution reopened => fixed
2007-02-02 09:27 fschmid Note Added: 0015075
2007-02-04 15:23 mhanski Status resolved => closed
2007-02-04 15:23 mhanski Note Added: 0015087
2007-03-02 21:02 mhanski Relationship added related to 0005408