View Issue Details

IDProjectCategoryView StatusLast Update
0004363ScribusStory Editor / Text Framespublic2006-10-12 09:39
Reporternihao Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
PlatformPentium DOSUbuntuOS Version6.?
Product Version 
Target VersionFixed in Version 
Summary0004363: Can't enter text
DescriptionHi,

The only key that works when entering text in a textfield is the spacebar. Nothing else works.

Running an Apple keyboard through a USB KVM switch.

Paul
Steps To ReproduceStart a new document, make a textfield and attempt to enter text - no go. The story editor has the same problem.
TagsNo tags attached.
Patch

Relationships

child of 0003826 closedcbradney Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers into real number spinboxes 

Activities

ringerc

2006-10-05 02:46

reporter   ~0012798

That's ... extremely odd. Have you tried without the KVM? Do any other apps have problems? Have you tried any other Qt based apps? Does qtconfig accept keyboard input ok?

Can you navigate the Scribus menus by "alt" key, arrow keys, and letter accelerator keys, or type into the number fields in the properties palette?

What's the console output from running "xev" and type some things over the xev window, including space but also other characters? (if xev isn't installed it should be in xbase-clients).

Does Scribus produce any output when run from an xterm while you try to type into a frame?

What version of Scribus are you using? (we have that field there for a reason!). How did you get it - from debian.scribus.net, from another 3rd party repository, from Ubuntu universe, compiled a snapshot, built CVS, or compiled a release version?

(Flagging ->minor (that really means "normal severity", the name is dumb) as there's no data loss and the issue isn't widespread. In a sense every bug is major, we have to draw the line somewhere.)

mginou

2006-10-12 03:28

reporter   ~0012928

Last edited: 2006-10-12 03:36

I have the exact same problem.

Scribus 1.2.4.1 on Ubuntu Edgy (scribus package 1.2.4.1.dfsg-1)

I run GNOME and (generally) have as few as possible KDE libraries installed.
I'm running on an amd64 architecture.

No KVM here, just the keyboard.

And the menus work fine, I can navigate using the keyboard.
Properties dialogs also accept numbers just fine.

The only output when run from an xterm is "Font /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType/Racotf04.ttf is broken, discarding it"

Thanks!
Mike

mginou

2006-10-12 03:34

reporter   ~0012929

I just ran installed and ran Scribus 1.2.4.1 in my Ubuntu Dapper i386 chroot (scribus package 1.2.4.1.dfsg-1) and there is no keyboard issue.

Since this is the same build (same package probably) running on the same hardware, I would have to conclude that it probably isn't a Scribus problem.

Cheers,
Mike

plinnell

2006-10-12 08:03

viewer   ~0012933

This is clearly a Ubuntu Dapper issue. A default install of Scribus on a new Dapper install is broken in a few ways. Poor default choices, Qt issues, error messages in the console and more...

Issue History

Date Modified Username Field Change
2006-10-05 01:17 nihao New Issue
2006-10-05 02:46 ringerc Note Added: 0012798
2006-10-05 02:46 ringerc Severity major => minor
2006-10-05 02:46 ringerc Status new => acknowledged
2006-10-05 02:46 ringerc Category Build System => Story Editor / Text Frames
2006-10-12 03:28 mginou Note Added: 0012928
2006-10-12 03:34 mginou Note Added: 0012929
2006-10-12 03:36 mginou Note Edited: 0012928
2006-10-12 07:58 plinnell Relationship added child of 0003826
2006-10-12 08:03 plinnell Note Added: 0012933
2006-10-12 08:03 plinnell Status acknowledged => resolved
2006-10-12 08:03 plinnell Resolution open => not fixable
2006-10-12 09:38 plinnell Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames