View Issue Details

IDProjectCategoryView StatusLast Update
0003826ScribusGeneralpublic2007-08-10 06:23
Reportermhanski Assigned Tocbradney  
Status closedResolutionnot fixable 
PlatformPentium(R) M processor 1.50GHzOSLinux Ubuntu/KubuntuOS VersionDapper Drake
Summary0003826: Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers into real number spinboxes
DescriptionReference to the Ubuntu Dapper bugracker regarding issue with entering numbers in real fields:



1. launch Scribus in this way: LC_ALL=C scribus
2. remove the scim_qtimm package (attention: kubuntu-desktop depends on scim_qtimm and will be removed too)
Additional InformationSee also:
TagsNo tags attached.


parent of 0004363 closed Can't enter text 
parent of 0003041 closedplinnell line width spinbox in Properties palettes behaves weird 
has duplicate 0004034 closed chaange size of the font from the text properties is difficult 
has duplicate 0004232 closedplinnell Importing SVG distorted in kubuntu 
has duplicate 0004741 closedcbradney Line width stays 0.0 pt 
has duplicate 0004585 closedcbradney Spin boxes in the style dialog for lines don't work 
child of 0004423 closedcbradney Metabug: Ubuntu/Kubuntu issues that prevent it from being the perfect platform for Scribus 



2006-05-16 23:49

administrator   ~0011336

This will depend on the language being used re translations and the version. There should not be any issue in at all.


2006-05-16 23:57

administrator   ~0011337

Oh, and this is a dupe, just cant find the one now. It was about the line spinbox on properties palette.


2006-05-17 06:38

developer   ~0011342

Last edited: 2006-05-17 06:39

Craig, please read the Ubuntu Bug #37111, I've filed it there. It's not a bug on your side, it's a Dapper issue, imho.

-- it has nothing to do with translations, and it happens with _every_ Scribus version on Dapper:,, 1.3.3cvs, 1.3.4cvs. Tested with English, Polish, and German GUI language

-- It's not a dupe, unless you prove, I'm wrong. There was a mail exchange on the mailing list between Kurt Lhotzky and me, and I followed your advice to file it on Ubuntu Bug Tracker. See this thread:

-- It has nothing to do with malex' packackges for Ubuntu, since it happens with self built binaries too.

If you guys knew some technical details that could be added to the Ubuntu Bug #37111 and would convice Ubuntu makers to do sth about it, it would be of great help.


2006-05-17 10:28

developer   ~0011345

Last edited: 2006-05-17 10:43

Craig and anybody who is willing to help to investigate this issue: perhaps I should specify what kind of help would be necessary imho to convince the Ubuntu Dapper makers to do sth about it:

-- which libraries/files are to be examined to find out what causes this weird spinbox behaviour?

-- do you know any other programs which use those spinboxes? It would help me to test it and convince Ubuntu guys, that this is not an "upstream" (means Scribus, i presume) issue, what they seem to believe now.

I've spent much time investigating this issue. It's well described, it can be easily reproduced, and I can provide any further help if needed. But now we've reached the point when only you guys with deeper knowledge of Scribus internals can do something about it.


2006-05-17 10:46

reporter   ~0011347

Isn't this the same old "Qt is broke" issue we saw in SuSE earlier?


2006-05-17 11:00

developer   ~0011348

Last edited: 2006-05-17 11:01

ringerc: thx for your responce. I can't say if it's broken, but QT version is 3.3.6 (at least Scribus/Help claims this). The installed qt libraries are:

-- libqt3-mt (Version
-- libqt3-mt-dev (version as above)
-- libqt3-headers (version as above)
-- libqt3-i18n (vesion as above)

2006-05-17 16:22


spinbox_issue1.ogg (318,993 bytes)


2006-05-17 16:25

developer   ~0011351

Last edited: 2006-05-18 10:44

i've uploaded a screencast spinbox_issue1.ogg (ogg theora) of the issue (use mplayer or kaffeine to play it in full screen mode)

the second screencast spinbox_issue_workaround.ogg demonstrates how the issue goes away after running a script from the "Scripts/Scribus Scripts" menu

BTW: isn't this a funny thing, this issue goes away after running a script? Does anybody have a clue, how these two things might influence each other?

2006-05-17 18:31


spinbox_issue_workaround.ogg (1,358,016 bytes)


2006-05-19 15:02

developer   ~0011377

Last edited: 2006-05-19 15:03

A quick summary of what avox and mrdocs found out during our conversation on IRC yesterday:

[01:44] <mhanski> mrdocs: are those spinboxes standard widgets, or are they somehow extended by Scribus team
[01:44] <mrdocs> those are customized widgets.. however they also work ok on MacOSX and Win32
[01:49] <avox> mhanski: could you test your libqt if it contains the IMModule patch?
[02:09] <mhanski>
[02:10] <mhanski> avox: have you found sth?
[02:10] <avox> mhanski: yep, QInputContext is from the qt immodule patch
[02:10] <mhanski> avox: what does it mean, issue triggered?
[02:13] <avox> mhanski: that means that dapper includes some unofficial patch for Qt 3.3.6
[02:14] <avox> I just found a plausible cause
[02:15] <avox> I guess each distro has their private adaption of this patch to the current Qt 3.x version, others might not include it at all
[02:17] <mhanski> avox: do you think, you can work out a way around this issue in dapper?
[02:17] <avox> AFAIK immodule communicates with an external process, so that would explain that a script might reset it
[02:18] <avox> No, that needs serious debugging on a dapper system by someone who is knowledgable with Qt and immodule
[02:18] <avox> I recommend using Qt without that patch and use XIM instead :-)


2006-05-24 07:24

administrator   ~0011434

FWIW, Qt 3.3.6 breaks our text flows around frame controls on properties palette too. First entry in their changelog is about the QButtonGroup. bleagh.


2006-06-04 10:06

reporter   ~0011568

This happens to me under SUSE 10.1 too. I am using the packed Scribus RPM from the scribus homepage.
But it does not happen immediately.

It seems just to occur with --lang de, it never hapened to me with --lang en.

Removing ~/.scribus/ solves the problem for some time.

#rpm -qf /usr/lib/qt3/lib/


2006-08-02 14:05

developer   ~0012089

Last edited: 2006-08-02 14:07

We have two confirmed cases of the same bug on SuSE 9.3 and Gentoo/PPC by now.

SuSE 9.3 bug description and workaround:

Gentoo/PPC (same workaround):

I'm not that sure anymore, this was an unique Ubuntu issue...


2006-08-02 20:15

reporter   ~0012092

mhanski: I think it is not unique I am hitting this bug under SuSE 10.1 too.

But just with --lang de. --lang en is working for me!

It must have something to do with the locale.


2006-08-02 20:40

developer   ~0012093

fm: --lang en doesn't work for me, it doesn't have any influence on the issue. The common denominator will be scim, I guess, as indicated in SuSE 9.3 mails (see my previous note).


2006-08-03 08:45

reporter   ~0012097

I do not have scim installed.

# rpm -q scim
package scim is not installed

scim-1.4.4-23.i586.rpm is avaible on the SuSE FTPs.


2006-08-08 11:10

reporter   ~0012152

i got in #scribus the hint to use "XIMInputStyle=Over The Spot" in /etc/X11/qtrc and so far it is working.

The SUSE default is "XIMInputStyle=On The Spot"

More information on XIMInputStyle can be found at


2006-10-09 10:41

reporter   ~0012857

I solved the problem by removing scim and skim packages from my Kubuntu installation.


2006-10-09 11:47

developer   ~0012858

I solved the problem by removing scim and skim packages from my Kubuntu installation.

I don't have scim installed, only scim_qtimm and skim. Removing scim_qtimm solves the problem in my case, but this is a really dirty workaround, since kubuntu-desktop depends on scim_qtimm and will be removed too:

 maciej@pan:~/tmp$ sudo apt-get remove scim-qtimm
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
  kubuntu-desktop scim-qtimm
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Need to get 0B of archives.
After unpacking 303kB disk space will be freed.
Do you want to continue [Y/n]?

This workaround solves the Scribus issue, but deprives me of keeping my system up to date with the current kubuntu development.


2007-01-05 01:06

administrator   ~0014544

More information from the users of the current Ubuntu development version - Edgy Eft.

Re: Qt/SCIM broken (Cannot enter numbers in to spinbox widget) from silentb at 2006-12-07 12:40:10 MST

I still experience this issue in Edgy. "LANG=de LC_ALL=de scribus-ng" solves it.
Re: Qt/SCIM broken (Cannot enter numbers in to spinbox widget) from Benoit St-André at 2007-01-04 17:45:37 MST

I can reproduce this on Edgy. My locale is fr_CA , and my xorg conf contains this

        Option "XkbModel" "pc105"
        Option "XkbLayout" "ca"
        Option "XkbVariant" "fr"

Also, thought you might know that starting scribus-ng with those parameters seemed to solve the problem

 "LANG=fr_CA LC_ALL=fr_CA scribus-ng"

except that all the spinbox using that any spinbox using inches as length turns to a bizarre high value and makes them unable to change any value in them.

 "LC_ALL=C scribus-ng" does the same thing.

With "LANG=en LC_ALL=C scribus-ng", everything is back to normal. The problem there is that the interface is not localized that way, but scribus works anyway.

Just ask me if there are other tests that might be needed.


2007-01-05 01:11

administrator   ~0014545

Can someone let me know if there is a default way to install Edgy to reproduce this, ie, will I be able to reproduce this in a VM with a default English install too?


2007-01-08 19:21

reporter   ~0014662

If you install Edgy in french, it has the bug the default way. Probably that the bug doesn't affect english only install, but I can't be sure about that. Maybe you can try just installing language-support-fr on an english install to reproduce the bug.


2007-02-19 23:45

administrator   ~0015333

Have ported this to Qt4 and testing code is out there. This issue will not be fixed in 1.3.3.x or 1.3.4.x.


2007-08-09 22:11

administrator   ~0017002

Maciej, can we close this now? We will not be changing our Qt3 versions, and as far as I know, the issue does not exist in 1.3.5svn.


2007-08-10 06:22

developer   ~0017005

closing, since we can be pretty sure they (Ubuntu folks) won't fix it, and this bug has fullfilled its documentary mission.

Issue History

Date Modified Username Field Change
2006-05-16 15:48 mhanski New Issue
2006-05-16 17:34 mhanski Status new => confirmed
2006-05-16 23:49 cbradney Note Added: 0011336
2006-05-16 23:57 cbradney Note Added: 0011337
2006-05-17 06:38 mhanski Note Added: 0011342
2006-05-17 06:39 mhanski Note Edited: 0011342
2006-05-17 10:28 mhanski Note Added: 0011345
2006-05-17 10:43 mhanski Note Edited: 0011345
2006-05-17 10:46 ringerc Note Added: 0011347
2006-05-17 11:00 mhanski Note Added: 0011348
2006-05-17 11:01 mhanski Note Edited: 0011348
2006-05-17 16:22 mhanski File Added: spinbox_issue1.ogg
2006-05-17 16:25 mhanski Note Added: 0011351
2006-05-17 16:33 mhanski Note Edited: 0011351
2006-05-17 18:31 mhanski File Added: spinbox_issue_workaround.ogg
2006-05-17 18:33 mhanski Note Edited: 0011351
2006-05-18 09:16 mhanski Note Edited: 0011351
2006-05-18 09:17 mhanski Note Edited: 0011351
2006-05-18 09:18 mhanski Summary Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers in real fields => Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers in real number spinboxes
2006-05-18 09:19 mhanski Summary Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers in real number spinboxes => Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers into real number spinboxes
2006-05-18 10:44 mhanski Note Edited: 0011351
2006-05-19 15:02 mhanski Note Added: 0011377
2006-05-19 15:03 mhanski Note Edited: 0011377
2006-05-24 07:24 cbradney Note Added: 0011434
2006-06-04 10:06 fm Note Added: 0011568
2006-07-18 08:27 mhanski Relationship added has duplicate 0004034
2006-07-21 22:39 mhanski Description Updated
2006-07-24 13:34 mhanski Description Updated
2006-07-24 13:36 mhanski Additional Information Updated
2006-08-02 14:05 mhanski Note Added: 0012089
2006-08-02 14:06 mhanski Note Edited: 0012089
2006-08-02 14:07 mhanski Note Edited: 0012089
2006-08-02 20:15 fm Note Added: 0012092
2006-08-02 20:40 mhanski Note Added: 0012093
2006-08-03 08:45 fm Note Added: 0012097
2006-08-03 09:02 mhanski Description Updated
2006-08-08 11:10 fm Note Added: 0012152
2006-09-09 16:22 plinnell Relationship added parent of 0004232
2006-09-30 15:57 plinnell Relationship replaced has duplicate 0004232
2006-10-09 10:41 nestordiaz Note Added: 0012857
2006-10-09 11:47 mhanski Note Added: 0012858
2006-10-12 07:58 plinnell Relationship added parent of 0004363
2006-10-12 08:04 plinnell Severity minor => major
2006-10-12 08:04 plinnell Status confirmed => feedback
2006-10-12 08:04 plinnell Resolution open => not fixable
2006-10-12 08:15 mhanski Description Updated
2006-10-17 21:34 mhanski Relationship added child of 0004423
2006-11-02 00:37 cbradney Relationship added parent of 0003041
2007-01-05 01:06 malex Note Added: 0014544
2007-01-05 01:11 cbradney Note Added: 0014545
2007-01-08 19:21 benoitstandre Note Added: 0014662
2007-02-19 23:44 cbradney Status feedback => assigned
2007-02-19 23:44 cbradney Assigned To => cbradney
2007-02-19 23:45 cbradney Note Added: 0015333
2007-03-29 16:44 cbradney Relationship added has duplicate 0004741
2007-03-29 21:22 cbradney Relationship added has duplicate 0004585
2007-08-09 22:11 cbradney Note Added: 0017002
2007-08-10 06:22 mhanski Note Added: 0017005
2007-08-10 06:22 mhanski Status assigned => closed