View Issue Details

IDProjectCategoryView StatusLast Update
0004232ScribusImport / Exportpublic2006-09-30 15:58
Reporteragusmba Assigned Toplinnell 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformIntel Pentium DOSKubuntuOS Version6.06
Product Version1.3.3.3 
Target VersionFixed in Version 
Summary0004232: Importing SVG distorted in kubuntu
DescriptionImporting a simple SVG in a document distorts the imported figure.
I have seen this on my kubuntu box. Maybe related to bug 3826, because one of the workarounds suggested there for fixing the spinbox problem also solves this issue
Steps To ReproduceOpen a new scribus, and either create a new document or open an existing one.
Select import SVG, and select a simple file with some figures (I tried it with text converted to outline in inkscape).
The imported SVG is distorted.
Additional InformationWorkaround: if I execute the font script, importing the SVG works fine again. !?
TagsNo tags attached.
Patch

Relationships

duplicate of 0003826 closedcbradney Reference to Ubuntu Dapper Bug #37711: Unable to enter numbers into real number spinboxes 
related to 0002425 closed Scribus ignores "No" in dialogs 

Activities

2006-09-08 08:14

 

reglas12_1.svg (7,139 bytes)

agusmba

2006-09-08 08:15

reporter   ~0012463

I uploaded a sample SVG file to test the import issue.

ringerc

2006-09-09 07:00

reporter   ~0012472

A few details on the exact workaround you used would not hurt.

At this point I'm inclined to think your problem is with the Qt package in Kubuntu, not anything to do with Scribus, and as you say is probably the same issue as 0003826.

marking ->feedback but should probably go ->dup(3826) .

agusmba

2006-09-09 15:24

reporter   ~0012475

The workaround I was referring to was executing the font-script before importing the SVG. It was already mentioned in the "Additional Information" field, but maybe it was not very clear, sorry.

ringerc

2006-09-11 06:04

reporter   ~0012483

OK, so this:

"because one of the workarounds suggested there for fixing the spinbox problem also solves this issue"

refers to running "the font script", where "the font script" refers to the font sampler Python script shipped with Scribus? Is that correct?

It seems odd, because the 0003826 seems to be a problem with SCIM, an input method, and should not affect SVG import.

Please try running Scribus from the command line using:

LANG=C LC_ALL=C scribus

(this will start it up in the "POSIX" locale, which is 7-bit ASCII US English like what's used on primitive UNIXes) and see if the problem still happens there. If it does, then this issue is probably not really related to 0003826 .

agusmba

2006-09-29 23:42

reporter   ~0012707

I tried running scribus from the command line, changing the LANG and LC_ALL as suggested, and both issues (the spinbox and the import svg) dissapeared. So they must be related somehow.

I think that if there are problems with real/decimal numbers, that could be why the import gets distorted, as the imported points are shifted, when losing precission. Or maybe not :-)

Issue History

Date Modified Username Field Change
2006-09-08 08:04 agusmba New Issue
2006-09-08 08:14 agusmba File Added: reglas12_1.svg
2006-09-08 08:15 agusmba Note Added: 0012463
2006-09-08 13:15 jo-hannes Severity major => minor
2006-09-09 07:01 ringerc Note Added: 0012472
2006-09-09 07:01 ringerc Status new => feedback
2006-09-09 15:24 agusmba Note Added: 0012475
2006-09-09 16:22 plinnell Relationship added child of 0003826
2006-09-11 06:00 ringerc Relationship added related to 0002425
2006-09-11 06:04 ringerc Note Added: 0012483
2006-09-29 23:42 agusmba Note Added: 0012707
2006-09-30 15:57 plinnell Relationship replaced duplicate of 0003826
2006-09-30 15:57 plinnell Duplicate ID 0 => 3826
2006-09-30 15:57 plinnell Status feedback => resolved
2006-09-30 15:57 plinnell Resolution open => duplicate
2006-09-30 15:57 plinnell Assigned To => plinnell
2006-09-30 15:58 plinnell Status resolved => closed