View Issue Details

IDProjectCategoryView StatusLast Update
0004856ScribusStory Editor / Text Framespublic2007-01-06 00:38
Reporterchristoph_s Assigned Toavox  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinuxOS VersionSuSE 10.1
Product Version1.3.4cvs 
Target VersionFixed in Version1.3.4cvs 
Summary0004856: "Pos 1" and "End" keys don't work in text frames
DescriptionCursor jumps to second resp. last but one character. Arrow keys also can't move to the end of a line, unless the user switches focus and back.
TagsNo tags attached.
Patch

Relationships

has duplicate 0004925 closedavox Pressing "End" key doesn't send cursor to end of the line 
child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

avox

2007-01-02 09:57

administrator   ~0014360

I'm aware that the cursor seems to jump to the beginning of the next line, but that's because Scribus can't distinguish this position. I'll try to limit this behaviour to when there's no space or parsep at the lineend.

jo-hannes

2007-01-05 00:01

developer   ~0014531

cursor seems randomly to jump second lines after doing pos1, end a while and moving up and down. could reproduce that with textframe with sample text.

avox

2007-01-05 01:31

administrator   ~0014546

Johannes, can you confirm this is only with lines which don't end with a space or parsep, ie. they end with a hyphen? If so, this is a wont fix for now.

jo-hannes

2007-01-05 12:35

developer   ~0014561

dont know what parsep is, but if you take the german sample text it happens for example in line 3 ("großen").

as christoph mentioned at another place, illogical cursor movements costs a lot of time and are annoying.

avox

2007-01-05 14:43

administrator   ~0014565

jo-hannes, that's not enough information to reproduce.
I created a frame with German sample text, line 3 contained "großen Sprachozean" and Pos1 and End work as advertized. Please provide a sample file and say where you place the cursor and what keys you press in what order.

BTW, parsep = paragraph separator, gets inserted when you hit the enter key.

jo-hannes

2007-01-05 14:57

developer   ~0014566

oh sorry of course. you even didnt know how big my textframe was ;) my fault. i'll add some additional information soon

christoph_s

2007-01-05 15:45

administrator   ~0014568

End works now, Pos 1 works except for the first line of a text frame.

jo-hannes

2007-01-05 16:10

developer   ~0014573

i attached cursor positioning.sla. I see two issues with the text frame there:

- go in edit mode, position the cursor at the beginning of a line and press cursor left. cursor goes one line up, but to the second last character.

- position the cursor in the middle of line 4 ("großen Sprachozeans") and press End. Then press cursor down -> the cursor jumps over the next line to line 6.

Both issues are here regardless of which line is selected.

2007-01-05 16:12

 

cursor positioning.sla (49,610 bytes)

avox

2007-01-05 22:58

administrator   ~0014591

I can confirm the cursor-left-at-start issue and the cursor-down-at-end issue, but Pos1 in first line works here.

But those two issues don't really belong to "Pos1 and End not working", do they?

jo-hannes

2007-01-05 23:07

developer   ~0014593

pos 1 works for me, too.

Issue History

Date Modified Username Field Change
2006-12-18 13:31 christoph_s New Issue
2006-12-18 13:32 cbradney Status new => assigned
2006-12-18 13:32 cbradney Assigned To => avox
2006-12-21 23:25 avox Relationship added has duplicate 0004925
2007-01-02 09:57 avox Status assigned => resolved
2007-01-02 09:57 avox Fixed in Version => 1.3.4cvs
2007-01-02 09:57 avox Resolution open => fixed
2007-01-02 09:57 avox Note Added: 0014360
2007-01-05 00:01 jo-hannes Status resolved => feedback
2007-01-05 00:01 jo-hannes Resolution fixed => reopened
2007-01-05 00:01 jo-hannes Note Added: 0014531
2007-01-05 01:31 avox Note Added: 0014546
2007-01-05 12:35 jo-hannes Note Added: 0014561
2007-01-05 14:43 avox Note Added: 0014565
2007-01-05 14:57 jo-hannes Note Added: 0014566
2007-01-05 15:45 christoph_s Note Added: 0014568
2007-01-05 16:10 jo-hannes Note Added: 0014573
2007-01-05 16:12 jo-hannes File Added: cursor positioning.sla
2007-01-05 22:58 avox Note Added: 0014591
2007-01-05 23:07 jo-hannes Note Added: 0014593
2007-01-05 23:16 jo-hannes Status feedback => resolved
2007-01-05 23:16 jo-hannes Resolution reopened => fixed
2007-01-06 00:38 plinnell Status resolved => closed
2007-05-23 21:10 christoph_s Relationship added child of 0003157
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames