View Issue Details

IDProjectCategoryView StatusLast Update
0005441ScribusGeneralpublic2007-04-26 22:50
Reportermhanski Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.3.9cvs 
Target VersionFixed in Version1.3.3.9cvs 
Summary0005441: Scribus 1.3.3.* refuses to embed perfectly embeddable TTF and PS fonts
DescriptionScribus refuses recently to embed some TTF and PS fonts and moves them automatically to "Fonts to outline" field, although they are embedabble in earlier Scribus version (e.g. 1.3.3.4).


Reported via mailing list:
http://nashi.altmuehlnet.de/pipermail/scribus/2007-March/022800.html
TagsNo tags attached.
Patch

Relationships

related to 0003701 assignedavox PDF export: better UI for Font Embedding 
related to 0004562 assignedavox PDF Export: Subsetting of OTF fonts (CFF variant) as Type1 subsets in PDF version < 1.6 
related to 0004564 closedavox PDF Export: Subsetting of OTF fonts (TTF variant) as true TTF subsets in PDF version < 1.6 
has duplicate 0005448 closedplinnell Exported PDF filled with blanks 
has duplicate 0005926 closed Embedding fonts. 

Activities

2007-03-12 12:58

 

1339_ttf_embedding_issue.tar.bz2 (494,275 bytes)

2007-03-12 12:58

 

1339cvs_font_tab.png (208,623 bytes)
1339cvs_font_tab.png (208,623 bytes)

mhanski

2007-03-12 13:02

developer   ~0015523

the user on the mailing list reported it for OpenSuse 10.2 and 1.3.3.7, I can confirm it with 1.3.3.8 and 1.3.3.9cvs on Kubuntu

joolsr

2007-03-12 14:20

reporter   ~0015525

Sorry to be a bit vague, but I had a similar problem with embedding Arial a couple of months back, although it seems ok now. I think I posted on the mailing lsit about this, but cant find ref to it now ...

fschmid

2007-03-12 14:21

administrator   ~0015527

Our Font Loader has a check for the number of Glyphs, above a certain limit the Font is assumed to be a "big Font". This limit is 2048 in 1.3.4cvs and was only 512 glyphs in 1.3.3.9cvs. Raised that limit to 2048 glyphs for 1.3.3.9cvs.

mhanski

2007-03-12 15:33

developer   ~0015530

tested, works fine, closing

mhanski

2007-04-07 12:04

developer   ~0015786

Last edited: 2007-04-07 12:06

one of our power users claims in 0005534 that the issue with embedding Georgia or Times New Roman still needs to be fixed in 1.3.4cvs, glyph limit seems to be not high enough

Magnes

2007-04-09 14:00

reporter   ~0015826

Last edited: 2007-04-09 14:01

I still have the issue in 1.3.4 CVS version (downloaded from cvs and build today). Steps to reproduce:
1. Create new document. Add text frame with some text.
2. In Text Editor: select all the text, change font to Georgia Regular.
3. Export PDF, in "Save as PDF" dialog Georgia Regular and Times New Roman Regular are in "Fonts to outline" box and cannot be moved to "Fonts to embed" (they disappear from the list if you try). Also I'm not sure if Times New Roman should be on the list if it's not used anymore (but some default styles use it so maybe it's OK).

2007-04-10 19:13

 

jghali

2007-04-10 19:21

administrator   ~0015850

Georgia Regular and Times New Roman Regular, like most default fonts on Windows, are OpenType fonts and hence cannot be embedded (PDF 1.6 feature)

Magnes

2007-04-10 19:30

reporter   ~0015851

Last edited: 2007-04-10 19:36

jghali, very strange, I embedded Times New Roman in Adobe InDesign with no problem (or maybe it was outlined? I can't try it now because I don't have InDesing anymore). Why Scribus doen't inform user about the reason of not embeding?

mhanski

2007-04-10 19:44

developer   ~0015852

@magnes: because of 0005541 I've not been able to test your issue with Georgia on 1.3.4cvs, but now I am, and everything works as expected with the current 1.3.4cvs (built today) -- please see the attached screen shot 134cvs_font_export_dialog_with_georgia.png.

I have ms fonts delivered with the "msttcorefonts" package from the multiverse repository of Ubuntu, which are true TTF fonts. Do you have real TTF fonts or their OTF versions (don't get fooled by the .ttf extensions, look at their symbols in the Fonts tab of the PDF export dialog). If they are OTF fonts, they can't be embedded in Scribus, only converted to outlines. Scribus doesn't have the capability to embed OTF fonts. As we found out, Adobe InDesign extracts Type1/TTF fonts from OTF fonts before embedding them, that's why this works with Adobe Indesign in PDF < 1.6. Scribus simply doesn't have the code to do it yet.

mhanski

2007-04-10 19:52

developer   ~0015853

@magnes: see 0003701 (font tab improvement proposals), 0004562 and 0004564 for more info on OTF embedding dilemma

Magnes

2007-04-10 20:35

reporter   ~0015855

Last edited: 2007-04-10 20:46

mhanski, the screen looks promising. I reinstalled mstcorefonts, moved away all my other georgia and times fonts (yeah, I have a mess in my font folders) but it didn't work. My Georgia font has 139.6KB. Before I had also 151.4KB version of it.

I'll try something else tomorrow, maybe I still have some hidden georgia and times OTF versions somewhere...

edit: It's strange, but the old version of Georgia I had - 151.4KB one - is embedding, but the 139.6 one (from mstcorefonts) isn't. So I can embed Georgia and times know, but I have to use the larger version (not from mstcorefonts, I suppose I had theme copied from Windows XP) of Georgia and Times.

jghali

2007-04-10 21:09

administrator   ~0015856

For your information msttcorefonts are all OpenType fonts... As said by mhanski, don't get fooled by the .ttf extensions. On Windows 2k and XP, OpenType and real TrueType fonts have different icons : an O for OpenType fonts and TT for TrueType fonts

2007-04-10 21:16

 

mhanski

2007-04-10 21:19

developer   ~0015857

<jghali>For your information msttcorefonts are all OpenType fonts.</jghali>

at least not here (kubuntu dapper, msttcorefonts from multiverse), see the attached screen shot of Scribus Preferences/Fonts/Georgia

jghali

2007-04-10 21:26

administrator   ~0015858

The ones i've just downloaded from sourceforge and which are original ms packages are all opentype fonts:
http://sourceforge.net/project/showfiles.php?group_id=34153&release_id=105355

2007-04-10 22:02

 

update-ms-fonts (7,719 bytes)
#!/bin/sh
# Download and install the Microsoft Core Fonts for the Web
#
# (C) 2000,2001 Eric Sharkey.
# You may freely distribute this file under the terms of the GNU General
# Public License, version 2 or later.

#abort if anything goes wrong
set -e

FONTDIR=/usr/share/fonts/truetype/msttcorefonts

if [ `id -u` != 0 ] ; then
  echo "update-ms-fonts can only be run as root."
  exit -1
fi

for opt in "$@"; do
    case "$opt" in
        -q) QUIET_MODE=1 ;;
        -c) CHECK_ONLY=1 ;;
        -s*) SAVEDIR=${opt#-s} ;;
        -u*) URLOVERRIDE=${opt#-u} ;;
	-p*) HTTPPROXY=${opt#-p} ;;
        *) LOCALCOPY=$opt ;;
    esac
done
if [ "$(echo $LOCALCOPY | tr '[:upper:]' '[:lower:]')" = "none" ] ; then
  exit 0
fi

EXITCODE=0

# Base URL for Microsoft fonts
##URLROOT="http://unc.dl.sourceforge.net/sourceforge/corefonts/"

URLROOTS="http://belnet.dl.sourceforge.net/sourceforge/corefonts/
         http://easynews.dl.sourceforge.net/sourceforge/corefonts/
         http://twtelecom.dl.sourceforge.net/sourceforge/corefonts/
         http://aleron.dl.sourceforge.net/sourceforge/corefonts/
         http://cesnet.dl.sourceforge.net/sourceforge/corefonts/
         http://switch.dl.sourceforge.net/sourceforge/corefonts/"

if [ "$URLOVERRIDE" ] ; then
  URLROOTS="$URLOVERRIDE"
fi

if [ -z "$QUIET_MODE" ] ; then
    cat <<EOF
These fonts were provided by Microsoft "in the interest of cross-
platform compatibility".  This is no longer the case, but they are
still available from third parties.

You are free to download these fonts and use them for your own use,
but you may not redistribute them in modified form, including changes
to the file name or packaging format.
EOF
fi

SCRATCHDIR=$(mktemp -t -d msttcorefonts.XXXXXX)
chmod 0755 $SCRATCHDIR
cd $SCRATCHDIR

cat <<EOF > msfonts.info
663974c9fe3ba55b228724fd4d4e445f  Andale_Mono.ttf                 andale32.exe andalemo.ttf
3e7043e8125f1c8998347310f2c315bc  Arial_Black.ttf                 arialb32.exe ariblk.ttf
f11c0317db527bdd80fa0afa04703441  Arial.ttf                       arial32.exe  arial.ttf
34cd8fd9e4fae9f075d4c9a2c971d065  Arial_Bold.ttf                  arial32.exe  arialbd.ttf
a2b3bcdb39097b6aed17a766652b92b2  Arial_Bold_Italic.ttf           arial32.exe  arialbi.ttf
25633f73d92a0646e733e50cf2cc3b07  Arial_Italic.ttf                arial32.exe  ariali.ttf
a50f9c96a76356e3d01013e0b042989f  Comic_Sans_MS.ttf               comic32.exe  comic.ttf
81d64ec3675c4adc14e9ad2c5c8103a7  Comic_Sans_MS_Bold.ttf          comic32.exe  comicbd.ttf
20f23317e90516cbb7d38bd53b3d1c5b  Courier_New.ttf                 courie32.exe cour.ttf
7d94f95bf383769b51379d095139f2d7  Courier_New_Bold.ttf            courie32.exe courbd.ttf
167e27add66e9e8eb0d28a1235dd3bda  Courier_New_Italic.ttf          courie32.exe couri.ttf
da414c01f951b020bb09a4165d3fb5fa  Courier_New_Bold_Italic.ttf     courie32.exe courbi.ttf
f4b306eed95aa7d274840533be635532  Georgia.ttf                     georgi32.exe georgia.ttf
c61b355a5811e56ed3d7cea5d67c900e  Georgia_Bold.ttf                georgi32.exe georgiab.ttf
1e4e5d1975bdf4a5c648afbf8872fa13  Georgia_Italic.ttf              georgi32.exe georgiai.ttf
e5d52bbfff45e1044381bacb7fc8e300  Georgia_Bold_Italic.ttf         georgi32.exe georgiaz.ttf
8fc622c3a2e2d992ec059cca61e3dfc0  Impact.ttf                      impact32.exe impact.ttf
4f97f4d6ba74767259ccfb242ce0e3f7  Times_New_Roman.ttf             times32.exe  times.ttf
ed6e29caf3843142d739232aa8642158  Times_New_Roman_Bold.ttf        times32.exe  timesbd.ttf
6d2bd425ff00a79dd02e4c95f689861b  Times_New_Roman_Bold_Italic.ttf times32.exe  timesbi.ttf
957dd4f17296522dead302ab4fcdfa8d  Times_New_Roman_Italic.ttf      times32.exe  timesi.ttf
70e7be8567bc05f771b59abd9d696407  Trebuchet_MS.ttf                trebuc32.exe trebuc.ttf
055460df9ab3c8aadd3330bd30805f11  Trebuchet_MS_Bold.ttf           trebuc32.exe trebucbd.ttf
8f308fe77b584e20b246aa1f8403d2e9  Trebuchet_MS_Italic.ttf         trebuc32.exe trebucit.ttf
fb5d68cb58c6ad7e88249d65f6900740  Trebuchet_MS_Bold_Italic.ttf    trebuc32.exe trebucbi.ttf
3ba52ab1fa0cd726e7868e9c6673902c  Verdana.ttf                     verdan32.exe verdana.ttf
a2b4dc9afc18e76cfcaa0071fa7cd0da  Verdana_Bold.ttf                verdan32.exe verdanab.ttf
24b3a293c865a2c265280f017fb24ba5  Verdana_Italic.ttf              verdan32.exe verdanai.ttf
f7310c29df0070530c48a47f2dca9014  Verdana_Bold_Italic.ttf         verdan32.exe verdanaz.ttf
1a56b45a66b07b4c576d5ead048ed992  Webdings.ttf                    webdin32.exe webdings.ttf
EOF

for ttf in `awk '{print $2}' msfonts.info` ; do
    if [ ! -e $FONTDIR/$ttf ] || \
        [ `md5sum $FONTDIR/$ttf | awk '{print $1}'` != $(awk "/$ttf/ {print \$1 }" msfonts.info) ]
        then
        THISFILE=`grep $ttf msfonts.info | awk '{print $3}'`
        if ! echo $FONTFILES | grep -q $THISFILE ; then
            FONTFILES="$FONTFILES $THISFILE"
        fi
    fi
done
if [ -n "$CHECK_ONLY" ] ; then
    if [ -n "$FONTFILES" ] ; then
        EXITCODE=1
    fi
elif [ -n "$FONTFILES" ] ; then 
    if [ -n "$QUIET_MODE" ] ; then
        QUIET_ARG="--quiet"
    else
        QUIET_ARG=""
    fi
    for URLROOT in $URLROOTS ; do
        for ff in $FONTFILES; do
            if [ ! -e $ff.done ] || [ ! -e $ff ] ; then
                if [ -z "$LOCALCOPY" ] ; then
                    if ! http_proxy=$HTTPPROXY wget --continue --tries=1 --dns-timeout=10 --connect-timeout=5 --read-timeout=300 $QUIET_ARG --directory-prefix . -c $URLROOT$ff ; then
                        continue 2
                    fi
                else
                    cp $LOCALCOPY/$ff .
                fi
                touch $ff.done
            fi
        done
    done
    if [ -n "$SAVEDIR" ] ; then
        mkdir -p "$SAVEDIR"
    fi
    for ff in $FONTFILES; do
        cabextract $ff 1>&2
        if [ -n "$SAVEDIR" ] ; then
            cp $ff "$SAVEDIR"
        fi
        rm $ff
    done
  #Add some level of predictability by folding everything to lower case
    for x in *; do
        y=`echo $x | tr '[A-Z]' '[a-z]'`
        if [ "$x" != "$y" ]; then
            mv "$x" "$y"
        fi
    done
    
    chmod 644 *
    
  # Give sane names. These are nearly the same names MS uses for the
  # Macintosh versions
    
    mkdir -p /usr/share/doc/msttcorefonts $FONTDIR
    if [ -e licen.txt ] ; then
        mv licen.txt "/usr/share/doc/msttcorefonts/READ_ME!"
        gzip -f "/usr/share/doc/msttcorefonts/READ_ME!"
    fi
    for ff in $FONTFILES; do
        for ttf in `grep $ff msfonts.info | awk '{print $4}'`; do
            longname=$(awk "/$ttf/ { print \$2 }" msfonts.info )
            mv $ttf $FONTDIR/$longname
            ln -sf $longname $FONTDIR/$ttf
        done
    done
    
  # Make a note of what we installed so we can uninstall it later
    mkdir -p /var/lib/msttcorefonts
    awk '{print $2}' msfonts.info > /var/lib/msttcorefonts/ms-fonts
    awk '{print $4}' msfonts.info >> /var/lib/msttcorefonts/ms-fonts
fi

if [ -z "$CHECK_ONLY" ] ; then
    
  # Remove old links
  for ttf in `awk '{print $2}' msfonts.info` ; do
    if [ -L /usr/lib/X11/fonts/TrueType/$ttf ] ; then
      rm /usr/lib/X11/fonts/TrueType/$ttf
    fi
  done
  rm -f /usr/lib/X11/fonts/TrueType/msttcorefonts.scale
  if [ -d /usr/lib/X11/fonts/TrueType -a ! -L /usr/lib/X11/fonts/TrueType ] ; then
    rmdir --ignore-fail-on-non-empty /usr/lib/X11/fonts/TrueType
  fi
  # Make sure X knows those fonts are gone
  /usr/bin/defoma-font reregister-all /etc/defoma/hints/msttcorefonts.hints
fi

rm -rf $SCRATCHDIR

if [ -z "$QUIETMODE" ] ; then
    if [ $EXITCODE = 0 ] ; then
        echo "All fonts downloaded and installed."
    else
        echo "Fonts need to be updated."
    fi
fi

exit $EXITCODE
update-ms-fonts (7,719 bytes)

mhanski

2007-04-10 22:02

developer   ~0015859

they are OTF _now_ -- older versions were TTF, and msttcorefonts package of dapper (taken from debian's http://packages.debian.org/unstable/x11/msttcorefonts ) doesn't contain the fonts, it only installs the fonts from the web, see the attached /usr/sbin/update-ms-fonts script from my kubuntu dapper, it's pretty self-explanatory and you'll see the url's too

jghali

2007-04-10 22:38

administrator   ~0015860

msttcorefonts package of dapper downloads fonts from sourceforge corefont projects (links above) and as said corefont provides otf fonts. Given ttf and otf fonts stuctures are quite similar, it seems our font detection algorithm may be perfectible

2007-04-10 23:08

 

pdf_with_embedded_georgia.pdf (111,898 bytes)

2007-04-10 23:09

 

georgia.tar.gz (268,973 bytes)

mhanski

2007-04-10 23:12

developer   ~0015861

the uploaded pdf file pdf_with_embedded_georgia.pdf contains embedded Georgia TTF, the attached georgia.tar.gz contains Scribus 1.3.4 "Collect for output" inclusive Georgia TTF which has been installed with msttcorefonts package on Kubuntu Dappaer from multiverse repository.

jghali

2007-04-10 23:15

administrator   ~0015862

An easy way to make the difference between a truetype font and an opentype font is to look for the DSIG table with an hex editor, it's usually at the beginning of the file. If DSIG is here, then the font is an OpenType font.

jghali

2007-04-10 23:21

administrator   ~0015863

Fonts provided in georgia.tar.gz have that DSIG table and are consequently OpenType fonts

mhanski

2007-04-10 23:25

developer   ~0015864

Last edited: 2007-04-10 23:38

jghali, how do you explain the fact this georgia is embedded in the uploaded pdf 1.4 file?

avox

2007-04-11 00:01

administrator   ~0015865

Doesnt really matter, since Scribus should treat all OT fonts with version tag "1.0" and TTF glyphs as TrueType. The additional tables are allowed according to TTF spec and should be ignored.

avox

2007-04-11 00:03

administrator   ~0015866

Oh, are those problematic fonts by any chnace stored in a TrueType collection (TTC file)?

Magnes

2007-04-11 19:46

reporter   ~0015871

Last edited: 2007-04-11 20:03

I still can't embed the Georgia Regular font in 1.3.3.9CVS (today build) but I can in 1.3.4CVS and i can embed Georgia Bold in both versions. Don't know if it matters (probably not) but 1.3.4 I build with Cairo.

I attached the Georgia Regular font in two versions:
- the 139.6 KB one is embedding in 1.3.3.9CVS
- the 151.4 KB one is embedding only in 1.3.4CVS (probably, I'm a little lost ;) )

PS. I just got another weird issue - Times New Roman Regular WAS on the fonts to embed list, but i removed it and... it can't be moved there again (in "Save to PDF" dialog). :) (1.3.3.9CVS)

2007-04-11 19:51

 

Georgia.ttf (142,964 bytes)

2007-04-11 19:53

 

georgia.2.ttf (155,068 bytes)

jghali

2007-04-11 21:35

administrator   ~0015873

I can embed both versions in 1.3.3.9cvs and 1.3.4cvs.

jghali

2007-04-11 21:40

administrator   ~0015874

For the TrueType/OpenType stuff, it appears indeed that Windows default OpenType fonts are also according to TrueType specs valid TrueType fonts.

mhanski

2007-04-12 22:22

developer   ~0015881

@magnes: the same correct behaviour as reported by jghali -- I too can embed your both Georgias in 1.3.3.9cvs and in 1.3.4cvs.

jghali

2007-04-26 22:49

administrator   ~0016034

closing again as issue cannot be reproduced

Issue History

Date Modified Username Field Change
2007-03-12 12:58 mhanski New Issue
2007-03-12 12:58 mhanski File Added: 1339_ttf_embedding_issue.tar.bz2
2007-03-12 12:58 mhanski File Added: 1339cvs_font_tab.png
2007-03-12 13:02 mhanski Note Added: 0015523
2007-03-12 13:02 mhanski Status new => confirmed
2007-03-12 14:20 joolsr Note Added: 0015525
2007-03-12 14:21 fschmid Status confirmed => resolved
2007-03-12 14:21 fschmid Fixed in Version => 1.3.3.9cvs
2007-03-12 14:21 fschmid Resolution open => fixed
2007-03-12 14:21 fschmid Assigned To => fschmid
2007-03-12 14:21 fschmid Note Added: 0015527
2007-03-12 15:33 mhanski Status resolved => closed
2007-03-12 15:33 mhanski Note Added: 0015530
2007-03-13 14:27 plinnell Relationship added has duplicate 0005448
2007-04-07 12:04 mhanski Status closed => feedback
2007-04-07 12:04 mhanski Resolution fixed => reopened
2007-04-07 12:04 mhanski Note Added: 0015786
2007-04-07 12:06 mhanski Note Edited: 0015786
2007-04-09 14:00 Magnes Note Added: 0015826
2007-04-09 14:01 Magnes Note Edited: 0015826
2007-04-10 19:13 mhanski File Added: 134cvs_font_export_dialog_with_georgia.png
2007-04-10 19:21 jghali Note Added: 0015850
2007-04-10 19:30 Magnes Note Added: 0015851
2007-04-10 19:36 Magnes Note Edited: 0015851
2007-04-10 19:44 mhanski Note Added: 0015852
2007-04-10 19:49 mhanski Relationship added related to 0003701
2007-04-10 19:50 mhanski Relationship added related to 0004562
2007-04-10 19:51 mhanski Relationship added related to 0004564
2007-04-10 19:52 mhanski Note Added: 0015853
2007-04-10 20:35 Magnes Note Added: 0015855
2007-04-10 20:45 Magnes Note Edited: 0015855
2007-04-10 20:46 Magnes Note Edited: 0015855
2007-04-10 21:09 jghali Note Added: 0015856
2007-04-10 21:16 mhanski File Added: msttfcorefonts_georgia_scribus_preferences.png
2007-04-10 21:19 mhanski Note Added: 0015857
2007-04-10 21:26 jghali Note Added: 0015858
2007-04-10 22:02 mhanski File Added: update-ms-fonts
2007-04-10 22:02 mhanski Note Added: 0015859
2007-04-10 22:38 jghali Note Added: 0015860
2007-04-10 23:08 mhanski File Added: pdf_with_embedded_georgia.pdf
2007-04-10 23:09 mhanski File Added: georgia.tar.gz
2007-04-10 23:12 mhanski Note Added: 0015861
2007-04-10 23:15 jghali Note Added: 0015862
2007-04-10 23:21 jghali Note Added: 0015863
2007-04-10 23:25 mhanski Note Added: 0015864
2007-04-10 23:38 mhanski Note Edited: 0015864
2007-04-11 00:01 avox Note Added: 0015865
2007-04-11 00:03 avox Note Added: 0015866
2007-04-11 19:46 Magnes Note Added: 0015871
2007-04-11 19:48 Magnes Note Edited: 0015871
2007-04-11 19:51 Magnes Note Edited: 0015871
2007-04-11 19:51 Magnes File Added: Georgia.ttf
2007-04-11 19:53 Magnes File Added: georgia.2.ttf
2007-04-11 19:54 Magnes Note Edited: 0015871
2007-04-11 20:01 Magnes Note Edited: 0015871
2007-04-11 20:03 Magnes Note Edited: 0015871
2007-04-11 21:35 jghali Note Added: 0015873
2007-04-11 21:40 jghali Note Added: 0015874
2007-04-12 22:22 mhanski Note Added: 0015881
2007-04-26 22:49 jghali Status feedback => resolved
2007-04-26 22:49 jghali Resolution reopened => fixed
2007-04-26 22:49 jghali Note Added: 0016034
2007-04-26 22:50 jghali Status resolved => closed
2007-06-21 16:07 christoph_s Relationship added has duplicate 0005926