View Issue Details

IDProjectCategoryView StatusLast Update
0003701ScribusImport / Exportpublic2016-12-29 21:38
Reportermhanski Assigned Toavox  
PrioritynormalSeverityfeatureReproducibilityalways
Status assignedResolutionopen 
PlatformanyOSanyOS Versionany
Product Version1.3 
Target Version1.6 milestoneFixed in Version 
Summary0003701: PDF export: better UI for Font Embedding
DescriptionFile/Export/Save as PDF/Fonts:

-- although "Embed all fonts" is checked by default, there are no fonts in "Fonts to embed" field

-- disabling "Embed all Fonts" and adding them manually to "Fonts to embed" doesn't work

This needs to be reworked to indicate which fonts are embedded and why some are converted to outline. Maybe a third list on the right side indicating which fonts are converted to outline on export

TagsNo tags attached.
PatchNo

Relationships

related to 0002276 closedjghali The register "Fonts" in the dialog "Save as PDF" is quite confusing (and has a bug). 
related to 0004546 closedfschmid PDF Export: Despite "Do not embed fonts, do not subset" settings, Scribus converts fonts to outlines 
has duplicate 0004091 closedplinnell Problems embedding font & subset in PDF generation. 
related to 0004523 closedsubik "Embed all fonts" checkbox is not saved 
related to 0004562 assignedavox PDF Export: Subsetting of OTF fonts (CFF variant) as Type1 subsets in PDF version < 1.6 
related to 0004564 closedavox PDF Export: Subsetting of OTF fonts (TTF variant) as true TTF subsets in PDF version < 1.6 
related to 0005441 closedfschmid Scribus 1.3.3.* refuses to embed perfectly embeddable TTF and PS fonts 
child of 0003821 acknowledged Metabug: Usability 

Activities

plinnell

2006-04-25 23:32

viewer   ~0010453

What kind of fonts are these ? Open Type fonts which are the large majority of fonts shipped with XP are not fully embeddable, but are always indicated as subset, which with OTF means converted to outlines.

I agree the UI is confusing, but on Win2k with TTF or Type 1 there is no issue. I can switched between embedded and subset easily and its working as designed.

plinnell

2006-04-25 23:40

viewer   ~0010456

Reminder sent to: jghali, jo-hannes

Jean, Johannes, please double check this works OK on XP with some non-Unicode True Type and/or Type 1 fonts. Works here on Win2k

2006-04-26 11:29

 

embedding_fonts_win32.png (129,085 bytes)
embedding_fonts_win32.png (129,085 bytes)

mhanski

2006-04-26 12:00

developer   ~0010469

Last edited: 2006-04-26 12:03

Peter, first, thank you for investigating this issue and posting your answer http://nashi.altmuehlnet.de/pipermail/scribus/2006-April/017464.html -- this is not an easy one. OTF fonts with .ttf extensions + Scribus GUI build together a perfect pitfall for users -- you really need mrdocs to help you out of this:)
 
I'm reopening this to share some thoughts about the font embedding tab in File/Export/Save as PDF window (see the attached screen shot). I also would like to know, what jo-hannes and jghali think about this. We can change this issue to a feature request named "Improve font embedding handling of OTF fonts" or sth like that, if you want to.

As you can see on my screen shot, the font in question is Times New Roman TTF. As we know now, it's not really a TTF font, but OTF. There is no a hint in the GUI, that the font cannot be embedded. Some suggestions:

-- Rename "Embed all fonts" to "Embed all TTF and Type 1 fonts"

-- Extend tooltips of both checkboxes (and perhaps add one to the field "Available fonts") to reflect what you've found out about the misbehaviour of MS guys regarding the handling of OTF fonts

-- I wouldn't put the OTF fonts into the field "Available fonts", since you cannot really embed them, in fact there is nothing you can do about them in this dialog, whatever you click or try to do with them

-- If Scribus is able to recognise a "hidden" OTF font with a .ttf extension (which obviously is the case, since it's subset is converted to outlines by default), please consider giving the user some visual hint about it in the font list/name - from user's point of view, it's rather impossible to know the difference between the true TTF fonts and the wrapped ones.

-- jo-hannes, jghali: your suggestions?

cbradney

2006-04-26 12:11

administrator   ~0010471

In reality, we just need to OTF embedding working.. stop making excuses for PDF 1.3, we just dont have the OTF embedding code.

avox

2006-04-26 14:18

administrator   ~0010484

Embedded OTF fonts is only supported in PDF 1.6

Currently, when embedding is requested for an OTF font, Scribus converts it to outlines,
which is the right thing to do IMHO.

mhanski

2006-04-30 23:22

developer   ~0010716

Last edited: 2006-04-30 23:34

avox: if OTF cannot be embedded, then the user interaction in the font tab should be radically improved. The user should know, what's happening to him -- see my previous note on tooltips etc.

Additionally, the user can decide not to subset TTF or Type1 fonts, but he is forced to subset OTF fonts. Is there a technical reason that OTF fonts cannot be removed from the list to subset?

BTW, since there is not a real subset of OTF fonts after the export, just a bunch of outlines, there should be at least an extended tooltip about it, a title like "convert OTF to outlines" would be better -- the user can clearly expect, that Scribus makers mean "subset", if they write "subset".

A proposal for the new, less confusing font tab in pdf export:

X Embed all TTF and Type1 fonts
X Subset all fonts

Embedding
Available TTF and Type1 fonts: || Fonts to embed:




Subsetting
Available fonts: || Fonts to subset:

PLucAuclair

2006-05-03 15:49

reporter   ~0010833

A bit OT: Would OTF embedding reduce file size at export?

timi

2006-05-07 18:00

reporter   ~0011064

In issue 2276, I've shared some thougts about integrating this in the UI. Please have a look.

2006-11-17 02:18

 

dragonia_nr4.pdf (1,801,154 bytes)

mhanski

2006-11-17 02:35

developer   ~0013437

>Embedded OTF fonts is only supported in PDF 1.6

avox, I've uploaded an amateur linux magazine: dragonia_nr4.pdf. It's been made in Indesign. and if you go to the Document Properties in Acroread, you'll see the PDF version 1.4 and embedded MinionPro and MyriadPro in the Fonts tab. This confuses me a little, since both fonts are referred to as "Type 1" fonts, and I assumed there were only OTF versions of them.

What I'm going to ask now might be very dumb, but I'm risking it anyway: is it possible that Indesign performs some form of OTF to Type1 conversion before embedding the converted font subset into the pdf 1.4 file?

avox

2006-11-17 02:53

administrator   ~0013438

Yes, very likely.

OTF comes in two variants, a TTF variant and a CFF variant.
Fontfiles with extension *.otf are usually the CFF variant and CFF is just a compressed form of Type1 outlines.

mhanski

2006-11-17 10:25

developer   ~0013439

<quote>Fontfiles with extension *.otf are usually the CFF variant and CFF is just a compressed form of Type1 outlines.</quote>

It sounds very promising:) Wouldn't it be doable for us too, to decompress the OTF/CFF fonts and embed their Type1 subsets into PDF < 1.6 while exporting to PDF?

I'm asking because the obligatory conversion to outlines causes major pain to e-zines authors -- they cannot force every potential reader to use acroread as a pdf viewer, and other pdf viewers display a horrible mess -- see the No 5 of the same magazine (the authors switched to Scribus:):
http://www.dragonia.pl/download.php?view.8

aliyousuf

2015-08-27 17:11

reporter   ~0036105

http://wiki.scribus.net/canvas/Scribus_Output

Kunda

2015-12-02 12:54

manager  

screenshot2.png (36,366 bytes)
screenshot2.png (36,366 bytes)

Kunda

2015-12-02 12:55

manager   ~0037790

added screenshot2 from now closed 0002276

sommerluk

2016-12-29 06:07

reporter   ~0043248

Seems to be fixed in SVN.

Kunda

2016-12-29 21:38

manager   ~0043253

@jghali please advise

Issue History

Date Modified Username Field Change
2006-04-25 21:14 mhanski New Issue
2006-04-25 23:32 plinnell Status new => resolved
2006-04-25 23:32 plinnell Resolution open => unable to reproduce
2006-04-25 23:32 plinnell Assigned To => plinnell
2006-04-25 23:32 plinnell Note Added: 0010453
2006-04-25 23:40 plinnell Note Added: 0010456
2006-04-26 11:29 mhanski Status resolved => feedback
2006-04-26 11:29 mhanski Resolution unable to reproduce => reopened
2006-04-26 11:29 mhanski File Added: embedding_fonts_win32.png
2006-04-26 12:00 mhanski Note Added: 0010469
2006-04-26 12:03 mhanski Note Edited: 0010469
2006-04-26 12:11 cbradney Note Added: 0010471
2006-04-26 12:14 mhanski Severity major => feature
2006-04-26 12:14 mhanski Summary PDF export: fonts embedding doesn't work on windows => PDF export: OTF fonts embedding doesn't work
2006-04-26 12:14 mhanski OS windows xp => any
2006-04-26 12:14 mhanski OS Version => any
2006-04-26 12:14 mhanski Platform => any
2006-04-26 14:18 avox Note Added: 0010484
2006-04-30 23:22 mhanski Note Added: 0010716
2006-04-30 23:23 mhanski Note Edited: 0010716
2006-04-30 23:34 mhanski Note Edited: 0010716
2006-05-01 19:26 plinnell Status feedback => assigned
2006-05-01 19:26 plinnell Resolution reopened => open
2006-05-01 19:26 plinnell Summary PDF export: OTF fonts embedding doesn't work => PDF export: better UI for Font Embedding
2006-05-01 19:26 plinnell Description Updated
2006-05-01 19:27 plinnell Assigned To plinnell =>
2006-05-01 19:27 plinnell Status assigned => acknowledged
2006-05-03 12:42 mhanski Relationship added related to 0002276
2006-05-03 15:49 PLucAuclair Note Added: 0010833
2006-05-07 18:00 timi Note Added: 0011064
2006-08-05 11:09 plinnell Relationship added has duplicate 0004091
2006-10-22 21:26 mhanski Relationship added child of 0003821
2006-11-14 11:24 mhanski Relationship added related to 0004523
2006-11-14 11:26 mhanski Product Version 1.3.3.1 => 1.3
2006-11-17 02:10 mhanski Relationship added related to 0004546
2006-11-17 02:18 mhanski File Added: dragonia_nr4.pdf
2006-11-17 02:35 mhanski Note Added: 0013437
2006-11-17 02:53 avox Note Added: 0013438
2006-11-17 10:25 mhanski Note Added: 0013439
2006-11-17 10:45 mhanski Description Updated
2006-11-21 11:11 mhanski Relationship added related to 0004562
2006-11-21 11:38 mhanski Relationship added related to 0004564
2007-04-10 19:49 mhanski Relationship added related to 0005441
2015-05-08 15:34 Kunda Assigned To => avox
2015-05-08 15:34 Kunda Status acknowledged => assigned
2015-06-25 23:31 Kunda Patch => No
2015-06-25 23:31 Kunda Target Version => 1.6 milestone
2015-08-27 17:11 aliyousuf Note Added: 0036105
2015-12-02 12:54 Kunda File Added: screenshot2.png
2015-12-02 12:55 Kunda Note Added: 0037790
2016-12-29 06:07 sommerluk Note Added: 0043248
2016-12-29 21:38 Kunda Note Added: 0043253